1. Download our Official Android App: Forums for Android!

Support Wierd Wifi Issue with Samsung Galaxy Ace

Discussion in 'Android Devices' started by Rupeshgw, Jun 21, 2011.

  1. Rupeshgw

    Rupeshgw Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jun 21, 2011

    Jun 21, 2011
    5
    0
    5
    I am using samsung galaxy ace since last 1 week now... but sadly i am unable to connect to wifi network... the network gets detected but when i try to connect after entering the password... it gets disconnected immediately... and this process keeps on going on... i know that wifi network is working properly as i am able to connect to the same network using the same password from my laptop... i tried reinstalling the wifi driver on my galaxy ace but that didnt work... can some one help me with this issue...

    I wanted to know if this is common error on galaxy ace..
    Could it be fixed or i will have to upgrade to gingerbread 2.3.4 which is unofficial version till now :mad:
     

    Advertisement

  2. Rupeshgw

    Rupeshgw Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jun 21, 2011

    Jun 21, 2011
    5
    0
    5
    Sad forum... 87 views and not a single reply...
     
  3. Gammer

    Gammer Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    285
    Joined:
    May 23, 2011

    May 23, 2011
    285
    47
    43
    UK
    I wouldn't say it was a sad forum,maybe no one else is having this problem hence no one has replied.
    To be honest it sounds like a simple password key error. I had the same problem when keying in my password took me loads of attempts to get it right and it simply boiled down to the fact I couldn't read my own writing and i was putting in an 's' instead of a '5'.
     
  4. nathanmnm

    nathanmnm Lurker
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Aug 4, 2011

    Aug 4, 2011
    6
    1
    6
    Fixed this in the end.

    Solution - Downgraded the firmware on the router.

    Explanation - Using router Netgear DNG3300v2 found that there was an
    issue with current firmware (link), downgrading to the older firmware
    (.42) fixed the issue. This is slightly odd as the new firmware gave no
    problems with any other device or the android phone when running 2.2.x.
    The only issue was with the android phone running 2.3.3 (tested with and
    without network security, on N and G both on a range of channels - all
    failed), it seems that the wifi standards are being tightend and android
    is perhaps not keeping up. Still it appears sorted and I wont be
    upgrading the router firmware for the foreseeable future as I don't want
    this coming back!
     
    the_metal likes this.
  5. kareine

    kareine Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Aug 7, 2011

    Aug 7, 2011
    3
    0
    5
    i face the same problem too. it is android problem. I very fed up with this issue. When i turn off and turn on back sometimes it fail to connect.

    So we must downgrade the firmware and how to do that?
     
  6. the_metal

    the_metal Newbie
    Rank:
    None
    Points:
    16
    Posts:
    17
    Joined:
    Sep 5, 2011

    Sep 5, 2011
    17
    1
    16
    i hate android , and i hate android users more .
    Why ? because whenever you have a problem they just keep sayin its your problem , its your router , its your handset , but they will never admit that android OS has issues and bugs like hell cause they are fanboys .
    how come very old handsets like nokia n81 and samsung star works just fine on my router , but the new produced latest SUPER DUPER OS can't keep up with router security , how come a stupid OS works great while the super smart android phone cant even connect to a router . I really hate you android , and this is my first and will be my last android handset i'll ever buy .
     

Share This Page

Loading...