1. Are you ready for the Galaxy S20? Here is everything we know so far!

Wifi auto reconnects when I dont want it to

Discussion in 'Android Apps & Games' started by tweacle, Jan 17, 2011.

  1. tweacle

    tweacle Newbie
    Thread Starter

    Hi there im trying to save my battery by only connecting to the WIFI when I need to.

    I have a disable wifi icon on my phone and thats fine. The problem comes when the screen goes into sleep mode and I have to swipe the screen to restart.

    Thats when the wifi reconnects. Is there any setting or app so that it dont do this.

    Thanks
     



    1. Download the Forums for Android™ app!


      Download

       
  2. BookLover

    BookLover Android Expert

    Wifi uses less battery than 3G. Also, if you have low-usage data plan, you *want* to default to using wifi.

    Don't change it or both your data usage AND your battery will suffer.

    If you want to, you can shut off wifi when NOT in the vicinity of a known wifi source.

    Even then, it's been reported there's negligible battery drain even if you leave wifi on all the time.

    I personally keep my wifi off when away from home. But I use Tasker, which turns my wifi on and off automatically, so I don't even think about it.
     
  3. Shalizmar

    Shalizmar Lurker

    Settings > WiFi Settings > Options Button > Advanced > WiFi Sleep Policy. Only way I've found around it.
     
    amlothi likes this.
  4. amlothi

    amlothi Android Expert

    Agree with both of the posts above. If you really want to turn it off, it sounds like your Wifi Sleep policy is causing the behavior you noted.

    However, Booklover is correct and you should reconsider turning Wifi off if the alternative is maintaining a 3G connection.

    That said, if you want to have both 3G and Wifi off that will use even less power (of course) :)
     
  5. tweacle

    tweacle Newbie
    Thread Starter

    Thats brill.

    Many Thanks
     
Loading...

Share This Page

Loading...