1. Download our Official Android App: Forums for Android!

General Wifi autoconnect issues

Discussion in 'Android Devices' started by Timmer1992, Mar 16, 2016.

  1. Timmer1992

    Timmer1992 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Aug 26, 2010

    Aug 26, 2010
    12
    2
    16
    My phone randomly connects to open wifi networks i have never been connected to. So i have done some looking around and have found a few threads about this same issue on other devices. It always seems to be the same answers. Turn off notify of open wifi networks, turn off connections optimizer, forget the network from your network list, or turn off wifi when youre travelling. None of these answers address the actual issue. I have the s7 edge with verizon, i can not find an equivilant of the sprint connections optimizer on my verizon phone. The networks its connecting to are mostly open networks with sign in portals. It randomly connects to them while i am abroad driving around causing connection issues while im streaming music. I have never connected the phone to an open network. I use two networks. One at home and one at work. I have turned off show wifi popup, smart network switch, wifi notifications and passpoint. It will still connect to these random networks. Turning wifi off is an option but with my limited data plan i tend to forget to turn it back on. Most importantly i shouldnt have to deal with this. My original droid still will only connect to networks i tell it about.
     

    Advertisement

  2. Shootr

    Shootr Well-Known Member
    Rank:
     #369
    Points:
    43
    Posts:
    139
    Joined:
    Nov 6, 2009

    Nov 6, 2009
    139
    37
    43
    Mine will not auto-connect to my home or work networks - just a notification they are available and then I have to manually tap to connect every time I wake the phone.

    Any idea what setting I'm overlooking?
     
    #2 Shootr, Mar 17, 2016
    Last edited: Mar 17, 2016
  3. Shootr

    Shootr Well-Known Member
    Rank:
     #369
    Points:
    43
    Posts:
    139
    Joined:
    Nov 6, 2009

    Nov 6, 2009
    139
    37
    43
    Going to bump this up again.

    My S7 only connects to my home WiFi sporadically. Sometimes it will connect automatically, other times I just get a notification network is available and I have to manually connect to it.

    Tried restarting the phone, checking all kinds of settings - I can't figure it out.
     
  4. Snakeyeskm

    Snakeyeskm Android Expert
    Rank:
     #86
    Points:
    293
    Posts:
    1,644
    Joined:
    Apr 8, 2014

    Apr 8, 2014
    1,644
    840
    293
    Male
    Investment Banking
    US
    Try the following in order.

    1) Go to your Wi-Fi settings, tap on your Wi-Fi identifier and then tap on forget. Restart the phone and reenter the information for your Wi-Fi.
    2) try turning your smart network switch to Off. Or alternatively, toggle it.
    3)Recycle your router by disconnecting it for a few minutes.
    4) check any apps that are antivirus, protection etc. Some apps are unknown to build in this unnecessary security.
    5) reserve your phones IP address (fixed) on your router. PITA.
     
    Shootr likes this.

Samsung Galaxy S7

The Samsung Galaxy S7 was launched in 2016 and was one of two devices in the lineup. The device features a 5.1-inch display with a resolution of 2560 x 1440, 4GB of RAM, 32GB of storage, and a 12MP rear camera.

Share This Page

Loading...