1. Are you ready for the Galaxy S20? Here is everything we know so far!

Wifi - Can't connect...

Discussion in 'Android Devices' started by Maj Bob, Oct 26, 2010.

  1. Maj Bob

    Maj Bob Lurker
    Thread Starter

    Please have mercy - I'm new to the forum and to Android. Last week I replaced my Palm Centro with the new AT&T Xperria X10. About a week before the new cell phone arrived, I replaced our old Netgear wireless router with a new Cisco-Linksys E2000 router. All was well, EXCEPT my daughter's PC (XP Home) and my other daughter's laptop (Vista), could not connect to the router. Got the new X10, and it connected without any problem. Then - trying to get the other two computers to connect, I changed the 801.b security from WAP2 Personal to WEP Shared (One of them has an old Linksys wireless adapter that won't allow anything but WEP . . .). Then my daughters were both able to connect, but not the Xperia. I have tried everything I can think of - no success.

    I changed the router security mode to DISABLED, and I could not connect. I changed the Xperia to Static IP - no connection.

    I entered the password in both ASCII text and HEX, neither succeeded.

    Can anyone help me get the X10 connected to the router?

    Thanks in advance - - Bob Hendry :thinking:

    1. Download the Forums for Android™ app!


  2. BarneyF

    BarneyF Newbie

    Have you tried putting the router back onto WAP2? The x10 may have kept the WAP2 sign in and will not link unless it gets the same connection?

    I had trouble the first time i used mine and found that disabling mac filtering on the modem/router allowed it to connect. I turned it back on and the x10 connected fine after that.

    In the list of wifi discoveries did you delete the remembered connection the x10 has kept for the first connection? Removing that may allow you to make a new connection using WEP shared?
    Maj Bob likes this.
  3. Maj Bob

    Maj Bob Lurker
    Thread Starter

    Thanks - How do is get to the list of wifi discoveries?

    I appreciate your help . . .

    Bob Hendry
    BarneyF likes this.
  4. BarneyF

    BarneyF Newbie

    Hi Bob

    Tap on Settings> Wireless Controls>

    Now you must turn on WiFi at the top first.

    Now tap the one below that... WiFi Settings.

    Give it a while because it scans your area for modems.

    Tap your modem in the list and then tap the Forget button.

    Now you may have to turn WiFi off and on again for it to rediscover your router?

    You will have to sign in again.

    Hope this fixes the problem?
    Maj Bob likes this.
  5. Maj Bob

    Maj Bob Lurker
    Thread Starter

    Still no success . . . How should my Cisco-Linksys E2000 Wireless Router be set? I've reset it to WAP2 and got connected. Then I powered-off the phone, and reset router to WEP (40/64 bit), powered phone back on, deleted (forget) the lod wifi connection, scanned, and tried to login again - this time no success. It continually is searching for the IP address.

    There doesn't seem to be much I can set on the Xperia? Just password - should I use the hex code? All caps? Or ASCII password? (I've tried all - nothing seems to work.

    H - E - L - P - !!!

    Bob Hendry
  6. CallMeMrPrice

    CallMeMrPrice Lurker

    ive just had the same problem, and well i read up on some forms and well didnt work for me so all i did was turn my router off and then back on

Sony Ericsson Xperia X10 Forum

Features and specs are not yet known.

Release Date

Share This Page