1. Download our Official Android App: Forums for Android!

Wifi connected, but no internet?? Possible solution

Discussion in 'Android Lounge' started by NetWizard, Mar 9, 2015.

  1. NetWizard

    NetWizard Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    3
    Joined:
    Mar 9, 2015

    Mar 9, 2015
    3
    1
    16
    I am a network engineer, installer and internet consultant.

    This problem of phones having a connection but no internet when connecting over a wifi repeater seems to be a problem for everyone and has plagued me too for a long time now.

    I am not going to claim I have THE magic solution but something I have discovered seems to work for me.
    If anyone can try this solution to let us all know if it works for you too, it would be very helpful in diagnosis of this probelm at least. I am looking deeper into this and would love to find the "fix all" remedy.

    The problem seems to lie with authentication and dhcp over the two devices. Router and Wfi Repeater.

    Try this solution:

    1. Before you start with the wifi repeater, go to your main router and set the "cipher type" from TKIP to AES. (This may shorten the range of the wifi a little but a necessary step.)
    Reboot the router.

    2. All connected devices will now NOT connect automatically. On PC's and Laptops remove the connection from "managed wireless connections" and "forget" the connection on phones. You will need to reconnect all devices a fresh later.

    3. Factory reset your wifi repeater (whatever model)

    4. Set up your repeater in "Universal Repeater" Or "Repeater" mode. making no adjustments to anything. Just click default on everything. Don't change the network SID, IP address or anything, It should also be configured to use dhcp as default.

    5. Reconect all devices to the wireless network as a fresh start. Don't forget to "forget" any previous networks that are stored on any device or PC or laptop before you start.

    Your devices should now all connect and recieve connection to the internet.

    This seems to work for me but please post your findings here, fix or no fix and post the make and model of your wifi repeater as this will help find a solution for you if it does not work.

    Thanks.
     

    Advertisement

    #1 NetWizard, Mar 9, 2015
    Last edited by a moderator: Mar 9, 2015
    Crashdamage likes this.
  2. EarlyMon

    EarlyMon The PearlyMon
    Rank:
     #1
    Points:
    5,218
    Posts:
    57,632
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    57,632
    70,424
    5,218
    New Mexico, USA
    I've moved your post out from an older phone forum to where I hope more folks may notice it.

    Welcome to the forums!
     
  3. NetWizard

    NetWizard Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    3
    Joined:
    Mar 9, 2015

    Mar 9, 2015
    3
    1
    16
    Ok thanks. I was not sure I was in the right forum anyway. I'm still trying to find my way around.
     
  4. EarlyMon

    EarlyMon The PearlyMon
    Rank:
     #1
    Points:
    5,218
    Posts:
    57,632
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    57,632
    70,424
    5,218
    New Mexico, USA
    No worries. :)

    Takes a bit to get the hang of the place but it's worth it.
     
  5. NetWizard

    NetWizard Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    3
    Joined:
    Mar 9, 2015

    Mar 9, 2015
    3
    1
    16
    UPDATE - ANOTHER POSSIBLE SOLUTION:

    Further experiments have found a common problem to be that the WPA mode on a lot of routers is set by default to be "mixed mode" being WPA AND WPA2. Phones and mobile devices seem to have a problem using this mode when on a wifi repeater. Therefore when setting up your wireless repeater this mixed mode will be carried forward causing internet connection problems.
    Upon testing all mobile phone connection problems seemed to have dissapeared when using this set up detailed below... so if the above solution of using cipher mode AES does not work for you try the following... your feedback would be appreciated:

    1. Set the main router to use TKIP cipher BUT then make sure the WPA mode is set to WPS2 ONLY and NOT "mixed" WPA and WPA2
    2. Reboot your router and make sure all previously connected devices are reconnected preferably with new (not rememebred) connections.
    3. Set up your wifi repeater in the mode, of WIFI Repeater or Universal Repeater, making no other changes.
    4. After the Wifi repeater reboots make new connections with your phones and tablets (don't forget to "forget" previously stored connections). All devices should now connect easily.
    5. Please comment in order to help others and further research.

    Thanks.
     
    #5 NetWizard, Mar 16, 2015
    Last edited: Mar 16, 2015
  6. Meetopin

    Meetopin Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Dec 10, 2016

    Dec 10, 2016
    1
    0
    15
    Male
    @NetWizard: I tried your first solution using AES and it worked. My repeater connection now has internet. Thanks.

    I couldn't figure out how to make your second option work. My main router (Linksys WRT610N v2) is using the original Linksys firmware and I didn't find, for instance, any reference to the TKIP cipher.
     
  7. Slug

    Slug Check six!
    Moderator
    Rank:
    None
    Points:
    2,043
    Posts:
    20,551
    Joined:
    Aug 1, 2009

    Aug 1, 2009
    20,551
    16,993
    2,043
    Male
    Mobile phone retail
    Inverness, UK
    If #1 worked then you don't need #2. ;)
     
  8. evanborkow

    evanborkow Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 29, 2015

    Mar 29, 2015
    1
    0
    5
    Male
    I know this is a little simplistic but when my phone looses internet capability despite being connected to the router (exclamation point next to the wireless icon), rebooting the phone solves the problem. This problem is not limited to my home.
     

Share This Page

Loading...