1. Are you ready for the Galaxy S20? Here is everything we know so far!

wifi connected, but no internet??

Discussion in 'Android Devices' started by peekapoo, Jun 6, 2010.

  1. peekapoo

    peekapoo Newbie
    Thread Starter

    I just connect my evo with my home network, and it finds network ok and everyting.
    I even see 4 wifi signal bars on my evo screen, but no internet connection. I am using my laptop through that wifi now without any issue.

    I am using netgear WGR614 g/bwireless router.

    Anyone knows what is the problem?

  2. Thefoodman52

    Thefoodman52 Android Expert

    It's either the router is running a security thing that the phone can't connect through, or it's something wrong with permissions. Might be an IP conflict, though that's highly doubtful.

    Is there security in place on the router?
    Have you gotten any pop ups on the computer saying anything about a conflict with another device on the network sharing the same IP adress?
  3. peekapoo

    peekapoo Newbie
    Thread Starter

    Nope not an ip issue at all.

    My laptop and my wife's iphone is connected to the router and no problem.

    My evo says its connected and everything. Just no internet...
  4. vdubfast

    vdubfast Newbie


    Have you had any luck with this as yet?

    I was having the signal strength issues with my routers here at work, both of which are 50+ feet away. I had a spare WAP (Linksys 610WAPn), so I set it up in my office. I am literally 3 feet from it. Everything worked fine for the first few hours. Then I decided to watch the WC on Sprint TV, which of course means turning of WiFi. Since doing this, I now have the issue that I connect fine to my WAP, get an IP, signal is excellent, etc. BUT, I can't get any data at all.

    I have tried several things with my WAP:
    Changed the channel
    Changed the password

    None works.

    I have also walked my Evo over to 2 of the other WAPs in the office and I get the same thing. I connect to the WAP with full bars and an IP, but can't get data.

    I have also restarted the phone with no luck.

    Anyone else with this issue? If you have had this and resolved, please let us know how. Very frustrated right now. I have started (last night at home) using WiFi for data and turning off 3G to save battery. Worked very well last night and planned to do the same at work.

    Thank you ahead of time.

  5. sh4o8kid

    sh4o8kid Well-Known Member

    I have encountered this problem before and may have found a fix... well for me at least. Login to your router and change your router type to either "B" or "G". Don't put "B/G". I don't know why but i had the same problem as you. I just played around with my wireless router and changed the Type from "B/G" to B or G only and it works fine.
    ZekeCresando likes this.
  6. Try unplugging the router, wait a minute, then plug it back in. I find this happens about once a week on my laptop. I will be connected to the router, but not to the internet. A power cycle usually fixes it.
  7. vdubfast

    vdubfast Newbie

    Thanks. I forgot to mention that in my post. I have tried all settings (except N of course):
    B only
    G only

    Still have the same issue.

    I have read somewhere else of trying a factory reset on the phone. If I can't connect back to my home router(s) tonight, that will probably be the direction I take.
  8. vdubfast

    vdubfast Newbie

    The WAP is brand new, but I have done the reboot thing several times as I have changed the settings. Also, it isn't just this WAP. It is 3 separate WAPs. One is a Linksys WAP610n, both of the others are Linksys WAP54G. I believe this is an issue on the phone itself, I am just at a loss on how to repair.
  9. vdubfast

    vdubfast Newbie

    Thanks everyone. It looks like my Evo is having issues with the network here in my office. I tested on my Linksys and my Airport Extreme at home last night and had no issues. I still have the same issue in the office, though.
  10. I probably swap more hotspots every day than anybody. I have under my belt, downloaded, tested and rated every wifi app and widget available.

    The One:

    "Wifi Manager" <-free too

    by: Kotya Vasilyev
    (drops to knees and bows at the mention of creator's name)

    I keep this widget at the top front center of my homescreen as the information it displays, and the variables it commands are more vital to me than any other status. On the widget I can toggle wifi on/off, view status, signal strength and see which network I'm currently on.

    From that single widget I can hunt and swap networks in literally 3 clicks.

    My favorite, most used and most indispensable app!

    For anybody having wifi issues, I couldn't recommend this treasure enough.

    No adds either.

    To troubleshoot your individual wifi connec issues, put the Wifi Manager widget on your desktop, click on it and 'refresh' for networks.

    Press your menu button then "radar".

    This shows you the various networks' channels and signal strengths. If the network that's giving you trouble is sharing a channel with one or more other networks, log into your router, set it to an unused channel and reboot.

    Make sure as many of your router's client configs (b,g,n, link speed, half/full duplex, negotiations, etc...) are set to "Auto" negotiate as possible, as what might be good for one device may be exclusionary to another.

    Make sure your router's firmware is up to date etc...

    It's also a good idea to remember or note all of your fav protected hotspot's passwords and clear out your wifi history (disconnect and "forget") to avoid conflicts when having connec issues.

    I've heard reports that the Evo's wifi was sub-par, but must contend that I have only experienced it's wifi excellence!

    And better things are yet to come...

    Wireless N on the Evo 4G
    HTC EVO 4G Gets Wi-Fi N With Minor Code Tweak
    panteraguy and susandennis like this.
  11. If you all are trying to help this is very frustrating.

    I'm having the same problem where i'm connected to my home network, but I cant retrieve data from the net.

    and the conclusion was to go get a wigget that DOES NOT HAVE a "Refresh" network option.

    Or "Dont connect you your work router" I need help.

    How am I connected and not recieving data?
    Who do I need to call, HTC? Android? or Cisco?

    can anyone help?
  12. JoshUng

    JoshUng Well-Known Member

    This doesn't seem exactly like the same situation, but I had some internet problems last week. The modem was fine, but I couldn't get the internet on my computer. If I turned my phone's wifi on, I got a full signal, but the phone wouldn't connect to the internet.

    My phone was getting the same wifi signal it always does at home, so I guess it could still detect the modem, but wasn't able to notice that the modem wasn't getting internet.
  13. Mr. Ed

    Mr. Ed Extreme Android User

    I have randomly had this issue at home and have found no solution other than disabling wifi and then re enabling it
  14. ** SOLUTION ** for Phone: HTC EVO, Router: Linksys E3000

    1) I CALLED SPRINT (ever think of that?) Or in your case you should call your carrier.
    2) They said simply. Connect to your Wifi First! and from your phone Press Menu-> Settings -> System updates -> Update profile
    3) Majic it worked case closed

    All these other stories about standing on 1 leg barking like a dog, all while naming your top 10 pizza's in reverse order is SO frustrating.

    brianblank and Lucascain like this.
  15. Undrpsi

    Undrpsi Lurker

    Well I am new here and very new to smartphones, but I had this problem. I did what WIFI said and got message it was configuring something, but it didnt work, tried again same thing. Powered down the phone, unplgged the router for about 25 secs, then turned on phone, redid my security for wifi, it now asked what key and for security code. Works great now! Thanks!

    Before it would only work if i turned off security on my router settings.
    panteraguy likes this.
  16. abecc2000

    abecc2000 Lurker

    I was having this same problem using a Netgear WGR614 router. The solution I discovered was to disable Wireless Multimedia Extensions (WMM) in the router settings.
  17. grifo

    grifo Lurker

    hey guys

    i'm having same problem. i have a HTC wildfire and a Sagem F@st 2604 router. on my phone i can detect and connect to the router but i when i try to load any internet page i can't. i've already tried changing ssid, password, channel, security type and etc...

    please guys can anyone help???
  18. bhanu860

    bhanu860 Lurker

    I had the same problem, wifi connects to my office network successfully but not data traffic(even the ping requests fail). Then instead of using DHCP, I configured the same IP and other settings(DNS, Gateway etc)(which I got using DHCP) statically.
    This solved the problem and now I can access the Internet too using my Samsung Galaxy phone.

    Hope this helps.
  19. There is no need to be rude about this. Did you consider that the problem, despite presenting the same symptoms, might actually be different for different people and that your "Majic" solution might only be a solution for you? I had the exact same symptoms, and did what you said, but like several others in this thread who tried your solution, it did not work for me. I ended up going into my router settings and finding an option titled "WI-FI PROTECTED SETUP" which was enabled, and disabled it. Once I did this, my connection started working perfectly. So if anyone else has tried everything in this thread to no avail, try turning off WPS on your router.
  20. headero

    headero Lurker

    After trying all the above, I went into my router settings and updated my DNS values for DNS 1 and 2 to the Google Public DNS ( and

    It could be that the DNS entries I had set were not reachable by the EVO, but they were able to be used by my laptop and other devices.

    I would give that a try.
  21. yosammedysam

    yosammedysam Lurker

    I've had lots of problems with this too, but I saw this link on another site and it has worked for me on my Xoom. It basically walks you through how to config your IP to be static on a Xoom, but is probably similar on other Android OS devices. Motorola Xoom connects to wi-fi but not the internet – How to fix it Of Code and Me
    In addition to this I logged into my router and reserved that IP so there would never be a conflict. I also had to restart my router after reserving the IP for it to work, but I've been using WIFI since.
  22. obi_van

    obi_van Lurker

    Hi all,
    this is my first post here. I had same problem, connected to WiFi and no internet connection. So after who knows how many resets of my phone, I did as follows on my router:

  23. du.chammas

    du.chammas Lurker

    Hi guys,

    I have 3 wifi routers, two linksys WRT54G and one TP-Link841N, all of them running DD-WRT firmware. My Motorola Milestone , could connect and navigate in one of the Linksys and the TP-Link.
    But, on one of the Linksys I faced the same problem, I could connect to the router but no internet data at all. And it was just the nearest router to my desk...
    I found that I couldn't even ping the router I was connected to.
    A bunch of laptops uses this router the whole day, so I couldn't mess arround with it. Tried all the possible setups in the phone without sucess.
    I did the hard way, went through all setup pages of two of the routers and found out that the failing router had "WMM Support" disabled against the operative router and it worked !!!!

    If you use DD-WRT on your router, it's on Wireless --> Advanced Settings , end of the page.

    Good luck.
  24. JaQuavian

    JaQuavian Lurker

    Umm. dude i just went and turned off my Static IP in wifi settings.. it works now. :)
  25. Samsung_gs2

    Samsung_gs2 Lurker

    Hi there, I have read through this thread and I still have an issue on my Samsung galaxy SII:

    At home, in my apartment, my phone can connect to my router in 2 ways. First I can deactivate "static IP" and it has no problem connecting, secondly I can activate static IP and simply type in the following information:

    IP Address:

    I do not type anything into the DNS areas, If I do then I cannot connect at home. However At work no matter what I do I cannot connect. I can get "connected" to the wireless by activating static IP and typing:

    IP Address:

    But even though I get connected to the wireless I do not have connection to the internet. I am a consultant where I work so I cant really go around telling them to restart routers or all this nonsense just so i can use my phone. So I was wondering if there was anything anyone would recommend me doing? If I cant use then so be it, just really annoying to have a "smart" phone that isn

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date
Similar Threads - wifi connected internet
  1. James_Watson
  2. aourose
  3. jjohnston
  4. Donny Tarter
  5. trelana
  6. Cala Nijel
  7. chrissiec
  8. bigescalade
  9. Tobin Bell
  10. Warren H

Share This Page