1. Are you ready for the Galaxy S20? Here is everything we know so far!

Wifi connection help please ?

Discussion in 'Android Devices' started by blaze66, Dec 25, 2012.

  1. blaze66

    blaze66 Lurker
    Thread Starter

    Hello everyone,
    I'm really hoping someone can help me out with this wifi problem.

    I recently purchased 3 x DXtreme tablets.
    1 x 903
    2 x 703B

    All of the tablets are running ICS 4.0.4 and although everything else seems to work ok (so far) I haven't been able to connect any of them to our home wifi.

    The access point is recognised but when I try to connect it gets stuck in a loop :
    Authenticating ......... Saved, secured with WPA / WPA2

    Nothing else happens and we still can't access the internet.

    I've already tried a few things that I came across as possible solutions but so far nothing has worked.

    Re-setting the tablet.
    Turning the router (Belkin) off at the power point.
    Re-setting the router.
    Changing the channel on the router (1 through 6).

    I don't know enough about this sort of thing to try anything else, I'm a bit worried I'll mess everything else up.

    At the moment we have 2 PCs, 1 Laptop, 2 Ipods and a couple of smart phones all accessing wifi with no problems.

    If anyone can help out it would be greatly appreciated.


    1. Download the Forums for Android™ app!


  2. mikedt

    mikedt 你好

    Can any of these tablets connect to open public WiFi, or any other routers at all besides your Beikin?

    Although given what they are, off-brand budget devices, fluky and faulty WiFi is a common problem with these.
  3. lunatic59

    lunatic59 Moderati ergo sum

    Hello and welcome to Android Forums, blaze! :)

    First I would check to see if your router has a restricted guest account that might restrict internet access. You may be inadvertently be connecting to that one. You might also try disabling your security on your wifi connection temporarily to see if the tablets can connect to the internet that way.
  4. blaze66

    blaze66 Lurker
    Thread Starter

    Thanks for the welcome and for both of your responses.

    I don't have any access to any other private routers at the moment but I'll try the public hotspot tomorrow.

    I do understand that these are budget tablets but from what I've read even top of the line phones / tablets are having issues since upgrading to ICS 4.0.4.
    Many people are trying to figure out how to rollback to an ealier version because of the problems the upgrade has caused.

    I don't think I have that option (unfortunately) because the tablets came with 4.0.4 installed.
    I will look into it though, I'm running Gingerbread on a HTC phone and it works perfectly.

    I'm not sure I understand what you mean by "guest account".
    I've checked the Belkin control page and can't see anything that looks like that might be the case, but then again I don't really know what I'm looking for.

    Belkin staff are back on deck tomorrow so I'll give them a call and see if they've got any suggestions.
    It's probably one of those really simple things and I'm just not seeing it (fingers crossed anyway).

    Thanks again.
  5. lunatic59

    lunatic59 Moderati ergo sum

    I hope you can get your connection problems worked out quickly. I know how frustrating it can be. I don't know that I'd be so quick to point the finger at ICS, though. You've touched on part of the problem and that is with people who upgrade their devices. When you upgrade from 2.3.x to 4.0.x you are really jumping two generations of the operating system. I've always recommended that when a person upgrades, they back up all their personal data and perform a full factory reset and clear out the caches. What many people don't realize is that much of the operating system runs from caches bits of code to optimized performance and that when you update the OS, it doesn't necessarily update the cache as well. It's those little conflicts that cause most of the problems.

    Because the original OS on your tablet was 4.04, you shouldn't be effected by any of that.

    As for the router, I'm not familiar with Belkin's default settings as I generally use Cisco (and the Linksys consumer line from Cisco) routers. But, I am sure they do things similarly. Many times a guest account with limited access is set on a home router for visitors you might wish to give access to a printer or the internet without letting them into your home network. You normally have to approve access so the default might be to have a guest account with access to nothing. If you entered your passkey incorrectly, you'd be connected to the guest account, which would explain why you can't connect to anything.

    Open settings>wifi and long press on your home connection and choose forget. Then you can re-enter the info in case you mistyped something.
    blaze66 likes this.
  6. blaze66

    blaze66 Lurker
    Thread Starter

    Thank you so much for the above post on the OS, I'm not that familiar with anything other than Windows so this information was very helpful.

    Anyway, problem solved.
    I had to drop the security level to WEP and reconnect everything else in the house with a new key but it's all working perfectly now.

    Thanks again for taking the time to help me out, much appreciated.

Share This Page