1. Are you ready for the Galaxy S20? Here is everything we know so far!

wifi connection problem after Froyo update

Discussion in 'Android Devices' started by sixwarzone, Aug 6, 2010.

  1. sixwarzone

    sixwarzone Newbie
    Thread Starter

    After updating to Froyo, I can no longer connect to my home WiFi... anyone else having a similar issue? I've tried re-entering my WEP key with no luck. I know my WiFi is working, I took Froyo on it and my wife's Evo that hasn't been updated to Froyo connects fine.

  2. chiyex

    chiyex Lurker

    i have the same problem.i think sprint blocked it on froyo.i wish i never updated
  3. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    It works just fine.

    Strongly suggest you pick up Wifi Analyzer free from the market.

    I've solved any number of issues with that - the screens sweep left-right to get to various tools. The first one you want is the one that shows your router broadcasting, plus any others nearby. You want yours to be on its own channel and for that channel to show decent quality. It's an X-Y plot with colored upside-down parabolas for channel spread/signal strength.

    And not to mention the obvious - but here's the obvious - especially if you've gotten an Actiontec.

    I went through an upgrade on one machine, lost wifi, blamed the upgrade. By the end of the week, all five computers had stopped connecting - but only one had upgraded.

    Per Murphy's Law, the upgrade was coincidental and the router was the issue.

    If you see that on an Actiontec, it is fixable - but that was last year, so I don't remember the specifics.

    Probably you're getting a channel conflict maybe?
  4. pwnst*r

    pwnst*r Android Expert

    FUD, don't.

    As EM said, it works fine, so it's not an issue with Froyo. Follow the troubleshooting steps in his post.
    EarlyMon likes this.
  5. 82ndCowboy

    82ndCowboy Member

    My WiFi was not working after the 2.2 OTA either.
    It was working fine before the update.
    So I downloaded the Wifi Analyzer as suggested by EarlyMon. And I couldn't get that to work either. Uninstalled it and reinstalled it. Still no change. There was no signal.
    removed my access point and then added back into the wifi setting in the EVO.
    Nothing. Just kept getting connecting, out of range.
    So I checked Linksys for a firmware update. They had one. So I updated my router.
    Still no change.
    So for S&G's I hit the reset security on my router settings.
    And the Wifi Analyzer signal meter started beeping like mad. And BAM EVO was connected to my Access Point.
    So I started looking at the settings and found that the SSID Broadcast on the router (that I normally keep Disabled) was now Enabled.
    So I changed it back to Disabled. BLOOP! There went my EVO connection. Gone! Wifi Analyzer... No Signal.
    Turn the SSID Broadcast back to Enabled.
    BAM! Connection and Excellent Signal.

    So I believe what has happened is in the new Froyo Update, is that WiFi will not connect without the SSID Broadcast enabled on the router.

    So my question is...
    Who do we inform so they can fix this in the next update?
  6. sixwarzone

    sixwarzone Newbie
    Thread Starter

    I really appreciate the help, but I still cannot connect. I have tried everything! I have even done the factory reset of my EVO exactly as described in EarlyMon post (you were right, it wasn't so bad after all... and I do have improved performance)... but I still cannot connect to my wifi :s

    Here is the deal... I CAN connect to WIFI at work, just not on my Microsoft MN-700 wireless router at home (but remember, my wife's 2.1 EVO connects fine, and my EVO used to connect pre-Froyo also).

    Here is what I have tried on the router:
    -power cycle router
    -power cycle dsl modem
    -base station reset (on the router)
    -disable/re-enable DHCP
    -switched back and forth from no broadcast ssid/broadcast SSID
    -Firmware update (it was already up to date)
    -changed wireless security to WPA and back to WEP and back to WPA now.
    -changed between fixed b/ fixed g/ mixed mode on wireless router
    -played with every setting on the wireless router that I could find

    Here is what I've tried on the EVO
    -factory reset
    -installed wifi analyzer again
    -switch security types WEP/WPA/WEP, back on WPA now.
    -forget network and re-entered info
    -manually attempted to connect to the network
    -I have not tried static IP yet (my router DHCP expires 2 weeks max so this is not a viable long term solution, but I may try it just to see anyway)

    By logging into the router from my pc, I see my Android with my correct MAC address but it has the EVO assigned as, which from past experience is the IP address that is used by my router if DHCP fails and corresponds to "limited or no connectivity" in windows (which of course, won't let me access anything from my EVO). I've looked at the security logs on my wireless router, and there isn't even 1 clue of the failed attempt.

    I know I'm getting through the wireless security okay, because if I enter an incorrect WEP key or WPA password it says it's incorrect, but entering the correct one doesn't do this, it just hangs on "obtaining ip address". So it has something to do with DHCP I guess. My router is setup to DHCP range to My wireless router itself is and if I install the droid network app ping and try to ping the router, it attempts to use the 3G network (and if disable the cellular network it doesn't even try the hung up wifi connection), so I really don't have any tools left to debug this any further.

    I've seen some other people with a similar EVO Froyo WIFI issue with older wireless routers have went and bought a new one. I am hoping to avoid that so any further advice would be greatly appreciated.
  7. sixwarzone

    sixwarzone Newbie
    Thread Starter

    Update: Although it's not really a great long term solution, I am able to connect to my home network using a static ip (as suggested on some other threads). After going back to DHCP, it still fails. But at least I have a solution now until this issue is fixed (or I get a newer router).

    Here is how I setup a static IP (basically the same approach as posted before but I thought I'd post exactly what I did):

    1. Menu -> Settings ->Wireless & Networks -> WiFi Settings -> Menu -> Advanced
    2. Check "Use Static IP"
    3. Enter an IP address. Make sure you use one that is not already in use... for my wireless router, the range was set to - 199, so I selected
    4. Enter your Gateway (for me I just did ipconfig/all from a command prompt on another computer already connected to my Wifi). The IP address I entered for my Gateway was the same as my router's ip address ( for me).
    5. Enter the netmask, again same as ipconfig/all on another computer (
    6. Enter the DNS1, again same as ipconfig/all on another computer and was the same as my Gateway/Router IP ( for me).

    Boom, I'm connected.

    The EVO will save this single static IP settings even if unchecked (if you need to go back to DHCP for hotspots or at work you can just uncheck "Use Static IP" and it will remember your last setting when you go home and check "Use Static IP" again). There are apps on the Market that can store multiple static IP locations if you need to remember IP information for more than one network.

    Hope this helps and please update this thread if anyone else finds any other workarounds for this issue. Thanks for the help!
  8. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    OK, I'd guess your of the school that likes no SSDID broadcast as a higher security measure.

    Just so I'm clear... you're not able to put in the SSID under Add Network when not broadcasting it from your router?

    There are various places to report this sort of thing to Google, I'll have to check for you, unless someone knows and can chime in.

    A quick search says this is Froyo-wide, so this goes on the Big G's doorstep.
  9. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Sorry if this is a dumb question, but I'm unclear: did you also try the Wifi Analyzer and note that you can change pages to the channel view I'd described?

    The ability to work with a static IP while failing with DHCP on a known-good router is one the typical symptoms of either a channel conflict or channel quality problem.

    An assertion's been made that wifi reception has been improved for 2.2 - if true, this would make it more sensitive to conflicting routers or other types of radio interference than before.
  10. sixwarzone

    sixwarzone Newbie
    Thread Starter

    Yes, I've tried not broadcasting the ssid and then broadcasting it again. Both settings I'm unable to DHCP (i.e. I get stuck obtaining an IP address). I haven't tried this after the factory reset but I will now. Also, note the static IP seems a bit more flaky than when I had DHCP working on my EVO pre-Froyo, but maybe I just got unlucky (had to turn on and turn off WIFI twice already in about an hour).

    And yes, I have tried WiFi Analyzer (and tried before installing it just in case it was the culprit). Channel rating is great (apparently my neighbors use 2 cans and a string because I only have 1 other network in the area I can see).
    EarlyMon likes this.
  11. paynekiller

    paynekiller Newbie

    ok I am sort of having a similar problem on my EVO, not that it wont connect to WiFi because it still does, but when I go into a call it seems to disable it so I can no longer use the internet while in a call which I could do before. Did this change for everyone or is it just me?
  12. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    ^That's a good question - I didn't know you could that before. I'll check first chance I get unless someone else can answer earlier.
  13. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    This is working for me - I'm a call right now, and visiting a new site (so I know it's not cached).
  14. paynekiller

    paynekiller Newbie

    hmmm, so then it is just me.. which is sort of good because that means there must be a way to fix it and its not like sprint blocked such a useful feature.

    So now.... How do I fix this? :p Anyone?
  15. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    OK - just a while ago, I installed AppBrain, HP iPrint Photo and about 8 app updates.

    I just turned wifi off/on and now I'm endlessly getting the connect/disconnect cycle.

    No doubt in my mind this is some sort of app conflict.
  16. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    OK - Here's what I did:

    1. Uninstall AppBrain, no luck.

    2. Decide to not fart around, check logs using aLogcat. Saw lots of references I wasn't accustomed to, did http://androidforums.com/support-troubleshooting-evo-4g/141369-how-fix-froyo.html

    3. Still no luck, rebooted router.

    All working. So - it was either the router - or the router after the full reset / restore.

    Tested by cycling wifi on/off 3 times - locked every time.

    Hope this helps.
  17. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    This solves so many problems - might as well read this over, and let us know if it works if you decide to do this:

  18. sixwarzone

    sixwarzone Newbie
    Thread Starter

    After trying all the suggestions, I was still unable to dhcp, so needing a wireless-n router anyway, I've replaced my old b/g router with a new b/g/n router, and I am able to dhcp now just fine. Must have been some incompatibility with froyo and the really old router that was no longer supported with firmware updates.
  19. heavychevy

    heavychevy Android Expert

    This is garbage, my wifi no longer works either. I should have stayed on .3
  20. Slick1020

    Slick1020 Android Enthusiast

    All I can say is that with EarlyMon's background in signals he hit the nail square on top of the head with his analysis. Don't blame Froyo especially when I can see like around 6 different hotspots on my street with my EVO. You better believe there is some some interference happening.
  21. sixwarzone

    sixwarzone Newbie
    Thread Starter

    Earlymon's advice was useful as all his advice is.... However, there is a real issue here, especially when others are having a similar issue on the Sprint forum when they were all fine before and have checked everything else (including interference). The best advice that seems to have worked when all other common causes were eliminated is to attempt a firmware upgrade on the wireless router.
  22. heavychevy

    heavychevy Android Expert

    I had just done a hard reset when I went from .3 to .6 so I thought I'd try it again to see if the wifi would work and sure enough it did.

    However I'm getting the wrong times in the notification bar for text messages and calls. I keep thinking I missed calls but when I actually go to the messages or calls the right time shows up. Hope the reset fixed that too.
  23. infinitempg

    infinitempg Member

    An issue with this I noticed is at work after froyo my battery would literally cook itself out, carry in my pocket so hard not to notice. Today I looked and even though my work open WiFi network was "available", phone wasn't connected. Manually connected and it resolved an address, battery cooled and everything is fine. Lately my battery was <30% by lunch. Today it's time to leave and I'm still >75%.

    I don't think it's a matter of WiFi or not, I think the phone was "trying" to connect all day and this was frying the battery life. Anyone else know of issues auto-connecting to WiFi?
  24. dcordova

    dcordova Lurker

    After upgrading to Froyo on my Samsung Vibrant, my Wifi always got stuck on "Obtaining IP Address".

    After restarting my router, my Samsung Galaxy tab also had the same thing happen.

    The problem has to do with Android remembering the IP address used to connect to the router. If the router no longer has that IP address available when connecting, Android goes into a loop.

    I found that deleting the following file fixed my problem on both devices. I used "Terminal Emulator" and my devices are rooted.

    >rm /data/misc/dhcp/dhcp_list
    EarlyMon likes this.

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date

Share This Page