1. Download our Official Android App: Forums for Android!

Support Wifi connects - "no internet"

Discussion in 'Android Devices' started by marybunny, Jan 1, 2012.

  1. marybunny

    marybunny Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jan 1, 2012

    Jan 1, 2012
    2
    0
    5
    My Droid Global has never (had it a year) been able to use a wifi connection. It will find the signal, it will show that it's connected, but when I try to browse, I get a "no internet connection" message. This happens everywhere - home, library, Starbuck's - all places my husband's phone (Samsung) has no trouble connecting. Ideas?
     

    Advertisement

  2. biggiesmalls657

    biggiesmalls657 Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    326
    Joined:
    Nov 30, 2010

    Nov 30, 2010
    326
    30
    43
    Retail Clerk
    United States

    Does it actually assign an IP address to the device cause there were reports of D2/D2G's that on stock wouldnt be able to connect to wifi....it was a bug that was fixed in Gingerbread, at least it did for me. But now i am on a custom rom so my life is better already! My D2 would loop or sometimes never be connected to the router and i found that it was the level of encryption on the N Router w/ WPA AES. Rooting might solve your problems but then your taking it in your own hands. -Dan p.s. if you need more help let me know!
     
    marybunny likes this.
  3. marybunny

    marybunny Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jan 1, 2012

    Jan 1, 2012
    2
    0
    5
    Thanks for the reply, Dan. I'm not as tech-savvy as most on this site, but in answer to your question about assigning an IP address, when I'm supposedly connected, and look at the information on the connection, it does have an IP address. I'm hesitant to think this has to do with my router, as I have this problem everywhere. My husband's Samsung Stratosphere hops right on our home network.

    I do notice that when I first connect, the bands are blue, then they turn to white, but still show signal strength.

    I've upgraded to Gingerbread, but it's made no difference.
     
  4. biggiesmalls657

    biggiesmalls657 Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    326
    Joined:
    Nov 30, 2010

    Nov 30, 2010
    326
    30
    43
    Retail Clerk
    United States
    Thats odd. I noticed when i was on stock that bands turned from white to blue. Did you factory reset? You could sbf if all else fails but then the whole phone is wiped. But also might fix whats plaguing you...
     
  5. chrstdvd

    chrstdvd Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    435
    Joined:
    Sep 28, 2010

    Sep 28, 2010
    435
    60
    53
    Retired
    Virginia
    I do not understand why you are connected but get no internet, so I started tinkering with my D2 that I use only with WIFI. Once last month after my Droid Charge got the Gingerbread update I was trying to see if my tether apps would still work. Something happened and my D2 would not connect to the Droid Charge or my home WIFI. I had to go into the D2 settings and make the phone "forget" my home connection. When I tried the scan and it found my Home router, it would not connect. Finally found out that you have to scroll that tiny screen and there is a place for the router's pass word. I entered it and the thing started working again.

    Today as I finished reading this post, I discovered some "secret settings" I had never seen before, so I will tell you what mine say and U check if yours are the same.

    Menu > Settings > Wireless & networks > WiFi says connected and there is a green box with a white check mark. Just below this is a WiFi Settings that says "set up and manage .." Touch that. Mine has the first box checked, the second box Open Network is checked.

    Now hit your menu button and you get two options at the bottom of the screen. Touch Advanced. My Peer to Peer (Ad-hoc) channel is set to 1, my WiFi sleep policy (when touched) is set to never. I see a MAC address but can do nothing with it, in IP settings section I have "Enable Auto IP" checked.

    If you change anything, hit your Menu button and touch Save, otherwise the phone will go back to the way it was and you will think you did not fix the problem.

    Hope this helps.
     
  6. Goodspike

    Goodspike Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,144
    Joined:
    Dec 28, 2010

    Dec 28, 2010
    1,144
    143
    143
    Male
    Seattle
    [I don't think this is the same thing I had going on prior to GB, but just in case it helps someone I thought I would dig up something I posted months ago.]

    My WiFi was working fine until I installed a wireless printer using AOSS for automated setup of the wireless connection of the printer to the router. After that my WiFi would indicate connected to the phone (both at the phone and the router), but not work, and it would periodically try to find a new IP address.

    What I discovered is that AOSS not only set up a new SSID for that system, but it also changed the type of connection on the main SSID to WPA-PSK-TKIP mixed (or WPA/WPA2-PSK-mixed). For Buffalo routers you change that in the AOSS setup screen, setting the encryption level expansion function to disabled to eliminate the "mixed" part of the encryption. Apparently these phones cannot deal with that, even though my wireless computer connections dealt with it fine.
     

Share This Page

Loading...