1. Are you ready for the Galaxy S20? Here is everything we know so far!

WiFi constantly connects & disconnects with WPA2 security

Discussion in 'Android Devices' started by redgtconv, Sep 23, 2010.

  1. redgtconv

    redgtconv Member
    Thread Starter

    When my router is set to WPA the Droidx connects and stays connected. But when I change to WPA2 it keeps connecting and disconnecting every few seconds. This leaves me with a choice of less security for my entire network, or no wifi for the Droidx. I have seen this problem mentioned on the Motorola support page, but I have not heard of any resolution. Does anyone have a fix for this? I am using the new Froyo 2.2 OTA update.

  2. VinniePaz

    VinniePaz Newbie

    Same here , I have to use WPA-PSK (TKIP) or it keeps turning off and on. Hope we can get some help.

    Also I only had this problem recently happen (maybe starting this month sometime)
  3. Mr X

    Mr X Newbie

    I've had this happen to me exactly once - turned WIFI off and then back on and it hasn't happened since. Give it a shot.
  4. Paycer

    Paycer Android Enthusiast

    I think I remember reading that turning on, "Settings > Wireless & networks > Wi-Fi settings > Menu > Advanced > Enable Auto IP" can sometimes help WiFi connection issues. I think its mention was intended more for those using Wireless-N, but it shouldn't hurt to enable it if it isn't already.
    JediZombie and Good13man like this.
  5. redgtconv

    redgtconv Member
    Thread Starter

    I have tried everything!!! I just read in the Motorola support forums that they became aware of this shortly before the 2.2 release and will have a fix in their next ota update (whenever that may be. That means that everyone should be having this problem. I know the people complaining on the Motorola site, have Netgear routers, and so do I, so it is possible that it only affects people with Netgear routers.
  6. Mr X

    Mr X Newbie

    Interesting.. I've got a Netgear router and just had it happen again. Did what Paycer suggested and it's fixed... for now.
  7. redgtconv

    redgtconv Member
    Thread Starter

    I tried it on mine, it appeared to work momentarily, and then went right back to connect and disconnect.
  8. kevinkar

    kevinkar Lurker

    Hi All,

    I got my brand new Droid X three weeks ago with 2.1 installed. It's been working 100% fine for the last three weeks until today when I received the 2.2 OTA update. The phone is stock, not rooted.

    When I got home, all hell broke loose with WiFi. My Linksys router and the Droid X were connecting without ONE drop all month until tonight when I got home and started tinkering with 2.2 to see what's changed. Unfortunately, the WiFi connection connects, authenticates, gets an IP, drops, scans, connects, authenticates, etc. over and over and over. It's maddening!

    So I have been working just fine all this time and 2.2 hits and BAM! Nothing but pain. I also have WPA2 for security and all my other devices are connecting just fine. Droid X is the only problem child at the moment and the only thing that's changed in the last 10 hours or so.

    redgtconv mentioned this was noted at the Motorola forums so I'll look there next (if you can tell me where to look, I'd appreciate the pointer). If anyone has a fix please let us know!


  9. kevinkar

    kevinkar Lurker

    Found a single setting on my router that I changed to get the Droid X to connect. I'm not entirely happy with the change but it works so I guess I'll go with it for now and see how it works out.

    I had my router set on 2.4GHz mode to be Mixed (B/G/N). Changing it to N-only did nothing. Changing it to G-Only finally allowed the phone to connect. It's been connected since last night and I was able to successfully download all my apps again (since I tried a hard reset yesterday morning) and it's been connected all day so far.

    Let us know if this works for you. It's odd that it did when it was working fine for three weeks on the same router/phone under 2.1. Must be a change in 2.2 though it should still be able to connect to a mixed B/G/N router in my opinion.

    Good luck!

  10. SlvrScoobie

    SlvrScoobie Android Enthusiast

    weird! mine works Great on my N network, but... im trying to get the FIOS remote to work and i can not get it to connect to a totally open g network.
    "connecting" then "disconnected". trys trys trys but never gets connected! even with manual IP settings.
  11. Kamikaze77

    Kamikaze77 Newbie

    Having the same issue at my buddies house using his wireless (I'm there a lot as he lives less than 5 minutes away). I have no problem at home though...
  12. BMWBig6

    BMWBig6 Newbie

    Same exact thing happened to me as soon as I received 2.2. I am using a Netgear WNDR3700 router. I'm not willing to drop down to G only though as I have many other N clients on my home network. This is unacceptable, and I hope a fix or workaround is released or discovered soon.
  13. MainManRay

    MainManRay Lurker

    Same issues here. Droid X, and the Netgear wndr3700, Froyo, non-rooted.
  14. somegeek

    somegeek Lurker

    Just registered to say thanks for this. My wifi was bouncing along on it's own. Forcing this setting to enable Auto IP seems to have stabilized it as it's not bounced since. Thanks, somegeek
  15. Eryl Flynn

    Eryl Flynn Android Enthusiast

  16. nattydread

    nattydread Lurker

    I have had major issues with wifi connecting and disconnecting as well. After many days and hours, I believe I have found the issue. For some odd reason when I changed the 2.4ghz Wireless mode from 'up to 300Mbs' to the '54Mbs' legacy mode all was fixed and there are no more issues. I tried to run the router in 130Mbs and still had problems, but changing it to 54 definately was the cure. Hope this helps some people.
  17. SlvrScoobie

    SlvrScoobie Android Enthusiast

    Mine will connect ONLY to my 300mbps Dlink router. The damn Fios router I need to use with the Fios DVR manager will NOT work with my X. It worked for a while, then i had to SBF and now its shot :p
    Every other computer in the house connects to it almost instantly.
  18. Xloaded

    Xloaded Lurker

    Problem, phone will connect and then disconnect, this will happen all the time. Changes to WPA2 to WAP and so on did not help at all.

    Wifi Router: Thomson TG789vn.
    Phone Samsung S5570, Android 2.3.4. Same phone model with android 2.1 dot not work also.

    Router Wifi settings : Configuration

    Interface Enabled: Yes

    Power Reduction Enabled: No

    Physical Address: 08:76:ff:96:d5:e2

    Network Name (SSID): Vandra Bussijaam

    Interface Type: 802.11b/g/n

    Actual Speed [Mbps]: 54

    Band: 2.4GHz

    Channel Selection: Auto

    Region: Europe

    Channel: 1

    Allow multicast from Broadband Network: No

    WMM: Disabled


    Broadcast Network Name: Yes

    Allow New Devices: New stations are allowed (automatically)

    Security Mode: WPA-PSK

    WPA-PSK Preshared Key: XXXXXXXXX

    WPA-PSK Encryption: AES

    WPA-PSK Version: WPA2

    NB; also tested it with Android 2.3 phones like Samsung Galagy II and meny others. Local IPS informed me that this on known problem. I belive that android phones do not work correctly with Wifi G and N...

    Any ideas?
  19. IHateMyTreo

    IHateMyTreo Android Expert

    This worked for me, but each set-up is different. I installed a free app called KeepWiFi, which forces the phone to maintain the connection.

    No harm in trying it.
    droidros likes this.
  20. lexluthor

    lexluthor Android Expert

    I'm surprised more people don't notice this. I bet it's a problem with every DX.

    Don't only go down to WPA, but also make sure you are set to TKIP, not AES and it should not disconnect anymore.

    I have home and work set to that and no problems. Forgot I even had this issue until yesterday when I was on a WPA2 router and I constantly got disconnected.
  21. VincentVespa

    VincentVespa Lurker

    Solution: Can't find the link but this worked for me to solve this problem. Change the channel that your router is broadcasting on. If three are too many networks in the same bandwidth Android seems to have trouble. You can use the free app wifi analyzer to see where the free bandwidth (channels) are. Hope this helps!
  22. lexluthor

    lexluthor Android Expert

    No, that didn't work for me. I'm convinced this is a problem with the device. I haven't had any issues on wpa/tkip in months.
  23. Good13man

    Good13man Lurker

    This solved the problem for me. Thank you! :)
  24. mahler9

    mahler9 Lurker

    Thank you for this! I tried the free app, it installs instantly and I'm holding onto the wifi connection for longer than any other time! I highly recommend KeepWifi :)
  25. IHateMyTreo

    IHateMyTreo Android Expert

    Glad it worked for you!

Motorola Droid X Forum

The Motorola Droid X release date was July 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, TI OMAP3630 processor, and 1540mAh battery.

July 2010
Release Date

Share This Page