1. Are you ready for the Galaxy S20? Here is everything we know so far!

WiFi constantly connects & disconnects with WPA2 security

Discussion in 'Android Devices' started by redgtconv, Sep 23, 2010.

  1. FromMichigan

    FromMichigan Lurker

    This workaround may help. Find a router which doesn't keep disconnecting and connectto it. Open the remembered router which keeps disconnecting to modify the settings. Turn off DHCP. Set the IP address to something random between 192.168.10.10 and 192.168.10.199. I used 192.168.10.167. Save the settings. Now try connecting again to the problem router. It should stay connected.
     


  2. lexluthor

    lexluthor Android Expert

    Why in the world would that work? What's the theory behind that working?
     
  3. FromMichigan

    FromMichigan Lurker

    The reason why the system keeps kicking the device off the network is due ip address conflict. Assigning the ip address manually resolves the issue, at least for me.
     
  4. Stri

    Stri Lurker

    Guys,

    Just to let you know I fixed this by setting 'New stations are allowed (automatically)' on my Thompson router

    Obviously, make sure you've got encryption set before you enable this.
     
  5. Tofudisan

    Tofudisan Newbie

    I had this same problem. My router's WAN port died and I bought a new dual-band. Everything else would connect just fine except for my Moto Electrify. Wife's Samsung Galaxy Mesmerize, Wii & two laptops had no problem. But my phone would go through the "scanning", "connecting", "disconnected" cycle constantly.

    I tried everything. I deleted all connections, tried KeepWifi, and finally did a factory reset on my phone. Still the same problem. I finally found a mention about mixed mode on the router. Logged in to the router and told it to only use 802.11n. Moto connects just fine.

    Since I don't have any old devices on a/b/g I think my problem is solved.
     
  6. wysocki

    wysocki Lurker

    Thanks to Lex, my DroidX is on wifi again! It was dropping the signal about once per minute and would say "scanning... connecting... connected... disconnected..." over and over. Switching from AES to TKIP did it!

    Tried a lot of other fixes, Thanx Lex!
     
  7. kevinosborn

    kevinosborn Lurker

    I know this thread is dated but wanted to post the solution I discovered yesterday. I have a Droid RAZR Maxx that replaced an original DROID. The original DROID had no problems staying connected to my home Wifi (Linksys router with WPA2 enabled). The RAZR Maxx had problems with signal loss.

    I downloaded Wifi Analyzer from Google Play (Android App store) and found that every couple seconds (like clockwork) the signal would drop to 0 but the router phone was still connected to the router. After some research and trial/error I turned on SSID Broadcast (formerly I was not broadcasting the SSID) and that fixed the issue. The signal now stays strong.

    Good luck.

    KO
     
  8. droidros

    droidros Android Enthusiast

    I know this is an old thread but I just discovered I am having the same problem. Scanning...connecting....disconnecting. I didn't realize that my wifi was not connecting because I have a widget that is supposed to indicate whether things are on or off... and the wifi shows green even when it's not connected. I guess it is always on and scanning but doesn't actually connect. So, I really don't know how long this has been going on for, although I know it was definitely working when I first set up my phone.

    My wireless router is Netgear. I have a DroidX, Froyo, recently rooted. I have not flashed a custom ROM.

    I've been trying to follow some of the recent suggestions in this thread, but admit I have a hard time understanding some of them. I tried setting the IP manually... that didn't make any difference. There were some suggestions that I think referred to messing with the router but I don't know. Like, broadcasting SSID -- where is that done?

    I got the router several years ago and set it up on a different computer from the one I have now. I thought I was reasonably technically savvy but configuring the router was the most technically challenging thing I'd ever had to deal with. After a number of conversations with nice representatives with very thick accents, I finally got it going. That computer crashed completely several months ago, and when I got my new computer I didn't have any of the programs, including my Netgear configuration. So now I have no idea how to go back and mess with anything. All I know is that I can hook my computers into the wifi, but apparently not my phone.

    I have the Netgear disk. Should I reinstall the software?
     
  9. OkeeChloe

    OkeeChloe Newbie

    I had the same problem with my router there was a fix online for android os at the router's website.
     
    droidros likes this.
  10. droidros

    droidros Android Enthusiast

    Thank you for this suggestion! I downloaded it yesterday and it seems to have done the trick!

    It's so simple, too. For anybody else who wants to try it, turn off your wi-fi first, then open the app and select Enable. Then turn your wi-fi back on and let it connect.
     
  11. OkeeChloe

    OkeeChloe Newbie

    Your welcome it was my daughter who figured it out for me.
     
  12. SHEILDPERL

    SHEILDPERL Lurker

    I've had similar problems with my Samsung galaxy android, I've been trying to connect to my WiFi but it doesn't let me through it just disconnects me and asks me to enter the password again, then it says something like: "Disconnected, secured with WPA,WPA2 etc" I've been trying to figure out the problem but had no luck. :/
     
  13. IHateMyTreo

    IHateMyTreo Android Expert

    From what I've learned from the other posters here, try updating the firmware on your router, and if it's a newer dual bandwidth, try broadcasting in only one bandwidth at a time and see if it helps.
     
  14. greedj

    greedj Lurker

    Droid X running 4.5.621 Rooted
    This fixed my Wifi drops but may drain the battery faster on Wifi.

    Using Root Explorer browse to /System/etc/wifi
    Edit the 4 ini files tiwlan*.ini

    Change the 3 lines in each file.
    Note: They look like copies but each file is slighly different

    AutoPowerModeDozeMode = 2

    AutoPowerModeActiveTh = 8

    AutoPowerModeDozeTh = 4

    Some people may edit these files on a PC and copy them back to the phone. Do not use Notepad, Workpad, etc because they will destroy the formatting. Use Editpad Lite or Notepad++ (Not the regular Notepad).

    Also verify that Settings/Wireless & Networks/Wifi settings then tap menu/Advanced/Wifi Sleep Policy and set to never.
     
  15. mrloyal1410

    mrloyal1410 Lurker

    try this ^^

    Fix for WPA,PSK Modem connecting/disconnecting same as HotSpot Password reset fix
    forum.xda-developers.com/showthread.php?t=1364875

    it works for me ! :D
     
  16. lort9458

    lort9458 Lurker

    ok well try this, i was trying to use the password from my Belkin router, with my phone (htc one V) and i was going about this all wrong. turns out when i clicked on the wifi connection ( and i mean your wifi connection) and scrolled down to show advanced settings and turned on WPS and set it to PIN from access point, from there i took the PIN from the bottom of my router and it worked, i was very happy i got it to work.
    Hopefuly this works out for you peoples :)
     
  17. davinci

    davinci Lurker

     
  18. davinci

    davinci Lurker

     
  19. davinci

    davinci Lurker

    Answer to wifi connecting and disconnecting. Had this problem on my Android Maxx Phone and by trial and error discovered that the wifi site I was trying to connect with was blocked by my security apps. Solution: Go to your apps on the phone. Open Security and Privacy. Then select wifi security. Select Manage Networks. It will show blocked and allowed wifi sites. If the wifi you are trying to connect is blocked...delete the wifi connection. I deleted the blocked site and my wifi connection opened and stayed open. Hope this helps. It worked for me.
     

Motorola Droid X Forum

The Motorola Droid X release date was July 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, TI OMAP3630 processor, and 1540mAh battery.

July 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...