1. Download our Official Android App: Forums for Android!

Root Wifi disconnected at lock screen

Discussion in 'Android Devices' started by noamsheffi, Mar 16, 2010.

  1. noamsheffi

    noamsheffi Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Mar 16, 2010

    Mar 16, 2010
    3
    0
    5
    Hi All

    It seems that I have problem to leave Wifi on in order to get skype & SIP calls when the screen shutoff (black screen / idle)
    I changed the "wifi sleep policy " to never but still i cant get incoming calls

    I tested it several time even tried to ping it but it seems that it is disconnects after the screen shutoff

    I would appreciate your help


    Thank you

    Noam
     

    Advertisement

  2. rori

    rori Well-Known Member
    Rank:
    None
    Points:
    35
    Posts:
    90
    Joined:
    Jan 7, 2010

    Jan 7, 2010
    90
    0
    35
    Austria/Vienna
    Go to:
    ->Settings
    ->Wireles&Netw....
    ->Wi-Fi settings
    ->select your connection and hold it
    ->change password
    ->set Security from Auto to your router settings ;)
    ->Save :)
     
  3. noamsheffi

    noamsheffi Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Mar 16, 2010

    Mar 16, 2010
    3
    0
    5
    same result.....
    I can ping it while the screen is on but the second that the screen lock (turn to black / sleep mode ) it stop until i open it (the N1 is still connected to the access point but no traffic is transmitted )
    the wireless nic is also at sleep mode !!!

    I found an workaround by leaving the screen on but it isnt the right solution for that problem
     
  4. noisemonkey

    noisemonkey Member
    Rank:
    None
    Points:
    36
    Posts:
    37
    Joined:
    Mar 9, 2010

    Mar 9, 2010
    37
    3
    36
    I'm having a similar issue.. have tried wifi fixer, currently checking out static wifi which seems to help...
     
  5. noamsheffi

    noamsheffi Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Mar 16, 2010

    Mar 16, 2010
    3
    0
    5
    i found workaround that works

    you will need to download & install "screenmodewidget" and choose to keep the screen active all time , now open clock and press on dim option (top - right icon)

    now the screen will go almost off but the wifi is still running perfectly (you be able to get incoming voip/skype calls)
     
  6. resplendent2209

    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jun 7, 2010

    Jun 7, 2010
    4
    0
    5
    Is that what you call a solution?

    I will be sending the device back to HTC on Monday. I am fed up of this WiFi issue.
     
  7. MothBox

    MothBox Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Dec 15, 2010

    Dec 15, 2010
    4
    0
    5
    If you go into the Wi-Fi settings, bring up advanced, and the Wi-Fi sleep policy. Change the option to Never.
     
Tags:

Share This Page

Loading...