1. Download our Official Android App: Forums for Android!

Root WiFi Going CRAZY!

Discussion in 'Android Devices' started by HarleyChick, Mar 7, 2011.

  1. HarleyChick

    HarleyChick Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    201
    Joined:
    Aug 31, 2010

    Aug 31, 2010
    201
    12
    38
    Ohio
    Yesterday, quite suddenly my wifi connection started turning on and off. It most often happens after I have had the NC "sleeping". The only way I can apparently fix it is to shut it the NC down and restart. Has anyone else had this problem? BTW, I did do a search and did not find any mention of this particular issue.

    Strangely enough, it didn't start doing this until after I downloaded a tethering app to my DInc, but since I didn't have to make any changes to the NC, I don't see how that would be affecting the regular wifi connection. My regular home wifi connection had been very stable up to this point. The NC also did the same thing this morning when I brought it to work, where there is NO wifi connection at all. After I rebooted, I was able to tether to my DInc with no problems.

    Any ideas? Is there some particular setting I need to turn on/off on my NC? I'm currently running Nookie Froyo from the sd card. :thinking:
     

    Advertisement

  2. bgrutter

    bgrutter Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    412
    Joined:
    Apr 20, 2010

    Apr 20, 2010
    412
    47
    43
    Are you running Tasker or widgetsoid?
     
  3. HarleyChick

    HarleyChick Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    201
    Joined:
    Aug 31, 2010

    Aug 31, 2010
    201
    12
    38
    Ohio
    I assume you are talking about the tethering app? I'm using something called "Tethering Widget" from my UNROOTED DInc.
     
  4. bgrutter

    bgrutter Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    412
    Joined:
    Apr 20, 2010

    Apr 20, 2010
    412
    47
    43
    No, Tasker is another app. Great app, but another discussion entirely. Widgetsoid is another great and unique app. Both have the ability to toggle the wifi settings.

    Depending on which Rom you're running, there may settings for the wifi. Sorry I'm not any help. I can't imagine it has anything to do with your Tethering app, unless the signal is just fluctuating.

    BTW, you dont need an app for thew DInc's hotspot to function. Let me know if you'd like me to tell you how.
     
  5. HarleyChick

    HarleyChick Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    201
    Joined:
    Aug 31, 2010

    Aug 31, 2010
    201
    12
    38
    Ohio

    Oh, yeah, tell me how. :D
     
  6. SiGuy11

    SiGuy11 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Aug 23, 2010

    Aug 23, 2010
    18
    2
    16
    Chicago, IL
    are you using cm7? i had the same problem with cm7 but even a restart didnt help me...
     
  7. HarleyChick

    HarleyChick Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    201
    Joined:
    Aug 31, 2010

    Aug 31, 2010
    201
    12
    38
    Ohio
    I'm running Nookie Froyo from my sd card, and somehow my wifi connections have resolved themselves. :D
     
  8. defex

    defex Newbie
    Rank:
    None
    Points:
    15
    Posts:
    12
    Joined:
    Feb 28, 2011

    Feb 28, 2011
    12
    0
    15
    Network Consultant
    New Orleans
    I'm having the same issue... hopefully a few reboots will fix. These roms aren't exactly OEM stable though, so I guess it's to be expected...
     
  9. stinky

    stinky Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    346
    Joined:
    Dec 9, 2009

    Dec 9, 2009
    346
    44
    63
    SoCal
    Pretty much most ROMs out there are having WIFI sleep issues, among other things. CM7 has been good to me for the 12 hours its been on my NC. NF 2.2 however was pretty bad.
     
  10. system60

    system60 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    23
    Joined:
    Jun 22, 2010

    Jun 22, 2010
    23
    2
    16
    my wifi has a been sketchy but eventually became stable on both froyo and hc
     
  11. 1JOD

    1JOD Member
    Rank:
    None
    Points:
    16
    Posts:
    42
    Joined:
    Oct 31, 2009

    Oct 31, 2009
    42
    9
    16
    Dallas
    I'm running CM7 on my nook color and i have the same "sleeping" wifi issues most of the time if I turn wifi off then back on it will connect but sometimes I have to reboot not sure why?
     
  12. stinky

    stinky Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    346
    Joined:
    Dec 9, 2009

    Dec 9, 2009
    346
    44
    63
    SoCal
    Its something to do with the Nook sleeping too hard for the Wifi to 'awake' correctly.

    Go to Menu > Settings > Wireless > Menu > Advanced > Sleep Policy > Never.

    This has helped mine on CM7 as well as NF.
     
  13. HarleyChick

    HarleyChick Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    201
    Joined:
    Aug 31, 2010

    Aug 31, 2010
    201
    12
    38
    Ohio

    Sounds good, but I don't appear to have an "advanced" choice from my wireless menu (using NF). Am I looking in the wrong place?
     
  14. stinky

    stinky Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    346
    Joined:
    Dec 9, 2009

    Dec 9, 2009
    346
    44
    63
    SoCal
    Once you get to the Wifi settings page you must hit Menu, that will pop up Advanced option.
     
    HarleyChick likes this.
  15. HarleyChick

    HarleyChick Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    201
    Joined:
    Aug 31, 2010

    Aug 31, 2010
    201
    12
    38
    Ohio
    Thanks, found it!
     
  16. HarleyChick

    HarleyChick Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    201
    Joined:
    Aug 31, 2010

    Aug 31, 2010
    201
    12
    38
    Ohio

    I have my sleep policy set to "never," and it still toggles between off and on all the time when I wake the NC up. Is this just something that I have to live with on NF? :(
     
  17. stinky

    stinky Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    346
    Joined:
    Dec 9, 2009

    Dec 9, 2009
    346
    44
    63
    SoCal
    Yea NF was doing this to me with and without the OC kernel. From reading posts at XDA, early versions of the kernel fixed it, but the newer available versions broke it again. If you can find an earlier version (pre 2/25) then that may be your only option.

    FWIW CM7 doesnt have this issue, at least without the OC kernel. Even with it, I didnt notice it.
     
  18. HarleyChick

    HarleyChick Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    201
    Joined:
    Aug 31, 2010

    Aug 31, 2010
    201
    12
    38
    Ohio
    You lost me; OC kernal? I've seen the term, but don't really know what it is, how to find it or what to do with it. That usually means that it is something I don't really want to mess with.
     
  19. bluewhite79

    bluewhite79 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    128
    Joined:
    Feb 2, 2010

    Feb 2, 2010
    128
    8
    36
    there is no advanced settings on 2.1 wifi.

    i just got the same issue today (crazy wifi) and i can't find sleep policy.

    I've had wifi issues in teh past, but nothing compared to today.

    2 power off/on cycles seems to have corrected the issue.
     
  20. Legobricke

    Legobricke Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    232
    Joined:
    May 26, 2010

    May 26, 2010
    232
    28
    43
    Film Buyer
    I'm in the same boat here...

    I have no advance settings here and I'm running 2.1

    Some days are better than others trying to get the wifi to awake when I wake the nook up...

    It shows wifi is on, but it's still sleeping as it shows my local wifi out of range.

    Lego
     
  21. lafester

    lafester Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    387
    Joined:
    Jul 24, 2010

    Jul 24, 2010
    387
    88
    53
    change your security to something other then wpa2.
     

Share This Page

Loading...