Help WiFi hotspot tethering issues - Stock kernel, 4.0.4, T-Mobile UK


I'm seeing some strange behaviour with WiFi hotspot tethering on my GS2.

To set the scene, I have tried various other ROMS, but have gone back to the stock ROM which I prefer for various reasons and have yesterday updated via Kies to 4.0.4. I have great 3G coverage and using EE as the provider, set automatically in settings.

I can activate the wireless hotspot and connect to it (using my Samsung Tab2) fine - i.e. it connects and gets an IP address etc. However, when I try and browse the interneton the tab or a laptop, there are 'connection issues' can't remember the exact message.

Investigating, I noticed a 'Wifi Direct' option in the networks setting, so I enabled that and tried reconnecting the hotspot tethering.

The hotspot tethering turned the 'Wifi Direct' off, however, the hotspot turned on and and this time I was able to browse the internet on my tab. Happy days!

Only problem is, I can't browse the internet on my mobile now when the hotspot is turned on. This was never the case in any of the custom ROMS I tried.

It is also intermittent. I might have to go through the whole routine everytime just to get the hotpsot to work for the tab or my laptop.

This proves that its a Smasung issue, not a T-Mobile/EE issue as the tethering works.

Any ideas?