1. Check out our app, Forums for Android! Download and leave feedback here!

Wifi insomnia

Discussion in 'Android Lounge' started by v1nsai, May 7, 2010.

  1. v1nsai

    v1nsai Well-Known Member
    Thread Starter
    16

    Mar 24, 2010
    60
    3
    16
    My backflip is really getting lousy battery life lately, and it seems to be because wifi is running a lot while I have the screen turned off. I've been very aggresively using a task killer to kill everything when I'm not using it, so I'm pretty sure I don't have a program keeping it awake.

    According to Spare Parts, my screen has been on about thirty minutes but wifi has been running (not just on but actually running) for over 3 hours. I've set it to turn off when the screen turns off in wireless settings, but it clearly isn't.

    Is this normal? Are there any apps out there that kill wifi when the screen turns off? Probably wouldn't be too hard to write maybe ill just code that for myself hehe.
     

    Advertisement

  2. club968

    club968 Well-Known Member
    36

    Dec 27, 2009
    111
    9
    36
    Whatever I can do to pay for more phones
    Scottsdale
    I have a nexus one so this may be a little different, but in the wifi settings menu, under advanced, there is a wifi connection option. It gives you 3 options. One of them is to disconnect wifi every time the phone goes to sleep. If you have this menu selection on your backflip, make sure it's on.
     
  3. v1nsai

    v1nsai Well-Known Member
    Thread Starter
    16

    Mar 24, 2010
    60
    3
    16
    Thanks for the reply, but I found that already and i've tried changing it back and forth and even rebooting but it still doesn't immediately turn off wifi when I turn off the screen, it seems to stay on long after I turn it off but it Does eventually turn off.
     
  4. mdeamicis

    mdeamicis Well-Known Member
    16

    Apr 29, 2010
    62
    1
    16
    interior design and oh yea, i'm a seahawk/blackhaw
    in the desert s of socal
    call the sp or take it into the store. you could have a defective unite or a simple fix issue.
     
  5. v1nsai

    v1nsai Well-Known Member
    Thread Starter
    16

    Mar 24, 2010
    60
    3
    16
    I noticed in the advanced wireless options, the wifi timeout isn't when to turn wifi off, it determines when wifi switches to cellular data. I'm on a backflip, which ATT is doing all within their power to sabotage, one of the basic abilities they have removed is the 2g/3g toggle, so I was using Quick Settings to completely disable cellular data to save battery.

    Sure enough, when I turn off the screen my phone immediately switches to 3g now.
     

Share This Page

Loading...