1. Download our Official Android App: Forums for Android!

Support WiFi is turning on Automatically on GS5

Discussion in 'Android Devices' started by breeves312, Aug 5, 2014.

  1. breeves312

    breeves312 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Aug 5, 2014

    Aug 5, 2014
    4
    0
    5
    I have a Galaxy S5 through T-Mobile and just recently I started noticing that I will turn off my WiFi but when I go somewhere that I have connected to their WiFi (home, work, etc) my phone will turn my WiFi on automatically. I don't like this, I don't want it to pick when I have it on. Also, when it does it at work it keeps me from getting phone calls when the WiFi is on.

    Please help, how to do I stop this insanity! :eek:
     

    Advertisement

  2. philayl

    philayl Android Expert
    Rank:
     #211
    Points:
    103
    Posts:
    833
    Joined:
    Jun 25, 2010

    Jun 25, 2010
    833
    228
    103
    Male
    Wirral, Merseyside, England
    Hi, try going to "Settings", "Wi-Fi", open the drop down menu (three dots in top right hand corner), select "Advanced", uncheck "Passpoint" and "Always allow scanning". Phil
     
  3. breeves312

    breeves312 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Aug 5, 2014

    Aug 5, 2014
    4
    0
    5
    Thank you Phil, but that option is grayed out in my settings. This is so frustrating.
     
  4. philayl

    philayl Android Expert
    Rank:
     #211
    Points:
    103
    Posts:
    833
    Joined:
    Jun 25, 2010

    Jun 25, 2010
    833
    228
    103
    Male
    Wirral, Merseyside, England
    In the same "Advanced" menu do you have "Keep WI-Fi on during sleep" set to Never
     
  5. breeves312

    breeves312 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Aug 5, 2014

    Aug 5, 2014
    4
    0
    5
    Yes I have that option, but I have it set to Never. Still turning the wifi on automatically.
     
  6. AZgl1500

    AZgl1500 Android Expert
    Rank:
     #46
    Points:
    618
    Posts:
    6,376
    Joined:
    Feb 3, 2011

    Feb 3, 2011
    6,376
    3,125
    618
    Male
    Retired and loving it.
    Oklahoma grasslands
    Do you have an option to turn off "Always allow scanning" ?

    Also turn off "Smart network switch"

    This is how my Verizon phone's WiFi options page looks. I turned off nearly everything.
     

    Attached Files:

  7. RyanSupertramp

    RyanSupertramp Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    105
    Joined:
    Oct 16, 2012

    Oct 16, 2012
    105
    14
    58
    Male
    Project Manager
    Phoenix Arizona
    What did the button say to the WiFi?

    "Off" lol
     
  8. AZgl1500

    AZgl1500 Android Expert
    Rank:
     #46
    Points:
    618
    Posts:
    6,376
    Joined:
    Feb 3, 2011

    Feb 3, 2011
    6,376
    3,125
    618
    Male
    Retired and loving it.
    Oklahoma grasslands
    You have fast fingers my friend, I started to post that, then noticed it had already been answered, and changed my post.
     
  9. breeves312

    breeves312 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Aug 5, 2014

    Aug 5, 2014
    4
    0
    5
    Both are turned off. Still coming on automatically.
     
  10. philayl

    philayl Android Expert
    Rank:
     #211
    Points:
    103
    Posts:
    833
    Joined:
    Jun 25, 2010

    Jun 25, 2010
    833
    228
    103
    Male
    Wirral, Merseyside, England
    I think you need to take a trip to the shop you got the phone from, or a Samsung service center, they should be able to sort it for you. Phil
     
  11. droid26

    droid26 Member
    Rank:
    None
    Points:
    36
    Posts:
    52
    Joined:
    Oct 24, 2009

    Oct 24, 2009
    52
    3
    36
    I am also having this wi-fi issue along with a laggy touch screen. Seemed to be happening right after my phone updated to the latest firmware.
     
  12. huggy110

    huggy110 Lurker
    Rank:
    None
    Points:
    26
    Posts:
    6
    Joined:
    Nov 18, 2012

    Nov 18, 2012
    6
    2
    26
    Male
    Don't know if this helps, sprint has a connections optimizer that when its on it automatically connects to any wifi the phone is near
     
  13. kaanosh

    kaanosh Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 22, 2012

    Mar 22, 2012
    1
    0
    5
    This is how I fixed the problem on my phone. Go to Tmobile app -> options
    Under wifi settings uncheck allow Tmobile app manage wifi connections...
     
  14. Holli Lancaster

    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Feb 11, 2015

    Feb 11, 2015
    1
    0
    15
    Female
    This worked! Thank you
     

Samsung Galaxy S5

Samsung Galaxy S5

Share This Page

Loading...