1. Download our Official Android App: Forums for Android!

Support Wifi issue after 2.3.3

Discussion in 'Android Devices' started by nathanmnm, Aug 4, 2011.

  1. nathanmnm

    nathanmnm Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Aug 4, 2011

    Aug 4, 2011
    6
    1
    6
    Hi, after updating to 2.3.3 I now cannot connect to my home wifi (have not tried any other wifi so far). The phone just gets stuck in a loop "obtaining IP address" then "disconnected".

    Have tried, checking pw, reloading the wifi drivers with *#*#526#*#* restarting phone, removing batterty, reseting phone to factory defaults, changing encryption mode of router.

    My other wifi devices (including my old Samsung Monte) still connect fine hence I think its the phone (am using the wifi on a netbook right now to post this). Any advice?

    All I can think of to do now is re-flash the phone with froyo - im on the network Three in the UK, any isues with this? I cant use Kies as that wont downgrade but I could probably get a random EU froyo and flash using Odin - that may cause more problems but I cant have no wifi :/
     

    Advertisement

  2. amarax

    amarax Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jul 11, 2011

    Jul 11, 2011
    5
    0
    5
    you are not alone
    http://androidforums.com/htc-sensation/343490-htc-sensation-wifi-problem.html

    looks like it's common problem and it's actually not with all wifis routers - try to play with your wifi's security settings, channels, DHCP/Static IP and so on.
    For some reason 2.3.3 has problem with some routers.

    I would kindly ask you to submit this issue to you phone manufacturer support so they will take a look into this issue (and reply here if they answer you)
     
  3. nathanmnm

    nathanmnm Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Aug 4, 2011

    Aug 4, 2011
    6
    1
    6
    Fixed this in the end.

    Solution - Downgraded the firmware on the router.

    Explanation - Using router Netgear DNG3300v2 found that there was an
    issue with current firmware (link), downgrading to the older firmware
    (.42) fixed the issue. This is slightly odd as the new firmware gave no
    problems with any other device or the android phone when running 2.2.x.
    The only issue was with the android phone running 2.3.3 (tested with and
    without network security, on N and G both on a range of channels - all
    failed), it seems that the wifi standards are being tightend and android
    is perhaps not keeping up. Still it appears sorted and I wont be
    upgrading the router firmware for the foreseeable future as I don't want
    this coming back!
     
  4. deepak0401

    deepak0401 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Nov 13, 2011

    Nov 13, 2011
    2
    0
    5
    hey,
    just tell me how to do downgrade the firmware on the router the router. My router is adsl2+ model no is 450tc1. just help me out.
     
  5. deepak0401

    deepak0401 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Nov 13, 2011

    Nov 13, 2011
    2
    0
    5
    hey,
    i also cnt connect my phone to wifi. more over when i try to connect the connection gets lost and i hv to restart my modem. just tell me how to do downgrading of the firmware on the router. My router is adsl2+, model no is 450tc1. just help me out.
     
  6. Snatch3r

    Snatch3r Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Sep 9, 2011

    Sep 9, 2011
    10
    0
    15
    India
    Try this!!!
    At your laptop/desktop machine read it (windows: run command prompt (run win-key + r, and type cmd) and execute: ipconfig /all).


    For me:

    Wireless LAN adapter Wireless Network Connection:
    IPv4 Address. . . . . . . . . . . : 192.168.2.51(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.2.1
    DHCP Server . . . . . . . . . . . : 192.168.2.1

    Settings you got their should be copied to Galaxy ACE:
    WiFi-Setting>advanced (menu option):

    - check use static ip
    - set ip address that is free: this is a bit tricky. Safe bet is to check IP address of your desktop machine: 192.168.2.51 and if your net mask is 255.255.255.0 then it means that you shoud keep 192.168.2. and set the last number. The safest would be close to 255 but less. I took 250.
    - Gateway: this is your router as gateway, usually your router IP (in my case: 192.168.2.1)
    - Netmask: set should be the same as on your desktop (in my case: 255.255.255.0)
    - DNS 1: set should be the same as on your desktop (in my case: 192.168.2.1)
    - DNS 2: not necessary but you can place it same as on your desktop (I didn't presen't it for the safety reason :) )
     

Share This Page

Loading...