1. Are you ready for the Galaxy S20? Here is everything we know so far!

Wifi issue w/ Galaxy S2? Rooted

Discussion in 'Android Devices' started by mcarther101, Dec 29, 2011.

  1. mcarther101

    mcarther101 Lurker
    Thread Starter

    I've rooted my phone, and have setcpu, autokiller, es file, astro, wifi tether, chainfire 3d, and superuser... just noticed I can't turn my wifi on now though. Whenever I click wifi on in settings or the bar at the top it will search for wifi networks... not find anything, then turn back off. What is going on? I even put my phone directly next to the wifi router? Reset the router just now, and restored the phone... still not able to connect?

    PS... I have AT&T Uverse wifi router that is some sort of all in one cable tv/internet magic wifi box. It was working just a few days ago fine, but now I can't seem to turn the wifi on?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. yono707

    yono707 Lurker

    having the same problem, someone help
     
  3. josun

    josun Lurker

    Have you tried doing a factory reset? I had the same problem and doing a factory reset fixed the wifi issue while retaining the rooted status. I'm personally having problems flashing any roms ATM but you might have better lucks.
     
  4. thebozdude

    thebozdude Lurker

    Do you have 2.3.6? If so, I had exactly same problem.

    Solution in my case: Unroot (go back to 2.3.4) and then root again. Do not update to 2.3.6. Apparently, there is no efficient root method for 2.3.6 yet (I could be wrong, but this is my experience.
     
  5. jsnowl

    jsnowl Newbie

    And how does one go back to 2.3.4?
     
  6. wolfyboy359

    wolfyboy359 Well-Known Member

    is your router working?
    Do you have internet access on your computer?
    If so, go to the browser and type in "gateway" without the parenthesis and see what your wifi status is.
     
  7. Quads

    Quads Newbie

    I wrote this over at XDA when I got stuck with the same issue.
    This is regards to using SuperOneClick to root your S2 on 2.3.6

    OK, after some hacking around, here's the issue (and a solution):
    In short, this root method doesn't work with Android Version 2.3.6. So if you did the OTA (Over The Air) update from ATT which took you from 2.3.4 to 2.3.6 then SuperOneClick Root version 2.3.3 won't work. It will hang on step 5 or 7.

    That being said, until there is an updated method to root the Android 2.3.6 version from ATT, you can easily go back to 2.3.4 *then* use SuperOneClick which works.

    First, make sure you have *ALL* the drivers. If not, download and install Kies from Samsung, which will install them for you: Kies

    Once you have Kies installed, I followed these steps to get back to 2.3.4:
    Download the Odin package with the stock ATT ROM here:
    Download GalaxyS2ATT/unroot/ATTGalaxyS2Unroot.zip at DownloadAndroidROM.com

    In that ZIP file will be Odin and the stock ATT ROM. Unzip it, and open Odin. Follow the steps in this youtube to put the 2.3.4 ROM back on your phone: How to Unroot AT&T Galaxy S2! [SGH-i777] - YouTube

    Once you're back to 2.3.4, use version 2.3.3 of SuperOneClick to root your phone.

    YMMV. I *just* went through this on my SGH-I777 and it works. I'm back to 2.3.4 with root installed.

    Cliffnotes:
    Install Kies.
    Download Odin and ATT stock ROM.
    Flash back to Android 2.3.4
    SuperOneClick 2.3.3 to root your Android 2.3.4 phone.
    *DO NOT* do the OTA upgrade (if ever prompted) as this will unroot your phone.

    Mods: Please move or split this reply if needed. I figured I'd post it here as I was stuck where others were and figured it'd be best / most helpful in this topic.

    Hopefully this will help some of you that are stuck at step 5 or 7 with Android 2.3.6.
     
  8. DeanFoster

    DeanFoster Lurker

    I'm also having problems with the wireless after I rooted it. I'm a linux guy--so I'm not using Odin. I've taken it back to "stock" a few times, but now the wireless doesn't work there either. (Factory reset looks like "out of the box" but it couldn't find the wireless.)

    I don't have access to a Window's box. So Quads nice walk through of resetting it that way doesn't work for me. Any one know where the problem is? Bad zImage? What keeps it broken after a factory reset? Where is the persistent state coming from?
     
  9. Quads

    Quads Newbie

    From what I read somewhere, (don't recall where) was the issue was the wifi adapter didn't have a MAC address after the root on 2.3.6. Again, don't quote me on it, but you may find some luck there.
     
  10. wolfyboy359

    wolfyboy359 Well-Known Member

    I was wondering if anyone here knew the best way to go back to 2.3.4? Should I root and backup what I have and then unroot and flash and then root again and backup? Thanks.
     
  11. Momomuffins

    Momomuffins Newbie

    Not sure what you've already done since this thread is a few days old...

    I just rooted my 2.3.6 device via the "Zedomax Method" and in the instructions the guy said that the kernel installed during the rooting process causes Wifi to malfunction (exactly the same way you're describing). So the recommended kernel to fix this is located here [KERNEL][Root][UV][CWM] Entropy's Daily Driver, 1/24/2012 (Misc Upstream Patches)) - xda-developers

    Once you have it downloaded to your pc, plug your phone into USB, mount storage and copy the whole ZIP file to your phone's internal SD drive...boot up into CWM recovery (hold power button, volume up and volume down until you get to the CWM recovery screen). Select install ZIP from SD, locate the kernel ZIP file and install it. Reboot the phone when it's done...it's super fast. Wifi works like a charm now. I'm new to the rooting world of the Galaxy S2 but not to Android so I hope this helps if you haven't found a solution yet :)

    **EDIT**
    I forgot to mention that my phone came with 2.3.4 and I did the OTA upgrade to 2.3.6. This kernel is all I had to install to fix the wifi issue. Never had to roll back to 2.3.4 or anything. Here's the guy's video that I followed when I rooted my phone...not sure how you rooted yours but I figured I'd put it here just in case it turns out to be helpful for someone else if it doesn't end up applying to your situation...
    Tutorial How To Root AT&T Samsung Galaxy S2 Android 2.3.6 (Windows) - YouTube
     
  12. wolfyboy359

    wolfyboy359 Well-Known Member

    Ok thanks so much for that momomuffins!! That cleared up a few things but raised two new questions:
    1. why not just flash to the second kernel to begin with?
    2. what if something goes wrong?
     
  13. DeanFoster

    DeanFoster Lurker

    I got it working! Seems one needs to reboot it several times. So, flash, flash, reboot, reboot seems to be the necessary pattern. (Why I don't know.) THe problem is called a boot-loop



    Samsung Galaxy S2 Cyanogenmod bootloop resolved - CyanogenMod Forum
     
  14. SilverLycan90

    SilverLycan90 Lurker

    I really appreciate you posting this! I knew it was a kernel issue but I could not for the life of me find an appropriate one to fix the issue. :eek: My only concern is this one at least with the most current up to date one he had is a bit laggy. Its minor and It probably won't be too much of a nuisance but I wondered if you had noticed the same thing? Thanks again. :cool:
     
  15. gcobb

    gcobb Android Enthusiast

    This is what I did, works like a champ. :driver:
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...