1. Download our Official Android App: Forums for Android!

Support WiFi keeps turning off...

Discussion in 'Android Devices' started by RJ McKenzie, Feb 19, 2011.

  1. RJ McKenzie

    RJ McKenzie Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    9
    Joined:
    Oct 22, 2010

    Hi all,

    I just got a Droid 2 Global today and I notice if you leave it alone for a while (which is hard to do with a new phone) the WiFi will turn itself off. The first thing I do with new Android phones is turn the WiFi Sleep Policy to "Never". And that is what I did today, but it still appears to be sleeping.

    When I wake the phone I notice that the WiFi is off (Both up in the notification bar and the widget is dark) and the 3G is off as well. The only that is showing is bars. In about 5 seconds the WiFi will turn back on and connect.

    Now this only happens if I don't play with the phone for a while. Turning the screen off and back on the WiFi will be on like normal.

    As this annoys me that it is doing it, it is the 3G is off at this time as well. Which means the phone isn't getting any data during the period that it is off. Which isn't good since I rely on Google Voice for all of my texting, which won't come in unless there is a internet connection.

    Any help on this will be great,
    Thanks
     

    Advertisement

  2. Frisco

    Frisco =Luceat Lux Vestra=
    Rank:
    None
    Points:
    1,343
    Posts:
    22,478
    Joined:
    Jan 19, 2010

    Hello RJ, welcome!

    When setting up wifi for a new device, it's a good idea to restart the router being accessed so that IP addresses are fresh; your device may be struggling to keep a good hand-shake with the router.

    Also, are you running Bluethooth? Bluetooth will sometimes not play nice with wifi in some Android devices. You may need to go into the Bluetooth app in application manager and clear data and cache.
     
  3. RJ McKenzie

    RJ McKenzie Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    9
    Joined:
    Oct 22, 2010

    Well that is the first time I did was go into my router and assign the Droid 2 Global it's own IP. I keep my network tidy and I like to know my IPs.

    But I did find out what was going wrong last night. In Settings>Battery Manager>Battery Mode it was set to Nighttime saver. That would have been bad because I work 3rd shift and I'm up and using this mainly at night.

    Thanks for the help though :)
     
  4. quickaudi

    quickaudi Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    3,100
    Joined:
    Jul 15, 2010

    Jul 15, 2010
    3,100
    415
    273
    TN
    yup, in Nighttime saver your connections turn off after about 15 minutes of screen off time
     

Share This Page

Loading...