1. Check out our companion app, Forums for Android! Download from Google Play

Support Wifi Keeps turning on and off

Discussion in 'Android Devices' started by acey612, Nov 19, 2010.

  1. acey612

    acey612 Active Member
    Thread Starter
    15

    Jul 6, 2010
    39
    0
    15
    On Droid 2, my wifi keeps turning on and of constantly. The only ay to stop it is to turn on airplane mode or reboot the phone. After rebooting wifi works for a little while, but after the phone sleeps for awhile and I wake it, it starts again.

    I have also found that if I go into wifi settings, hit menu, then hit "Scan" it fixes it, on a temp basis.

    This happening to anyone else? There a fix? Thanks!
     

    Advertisement

  2. chrlswltrs

    chrlswltrs Well-Known Member
    333

    Nov 12, 2009
    6,728
    1,790
    333
    Male
    Private Security
    Seattle
    One solution that has helped me on my X is Settings -> wireless & networks -> wifi settings -> menu button -> advanced -> sleep policy, I set mine to never. When I want Wifi off I turn it off or Tasker does, otherwise it stays on all the time
     
  3. acey612

    acey612 Active Member
    Thread Starter
    15

    Jul 6, 2010
    39
    0
    15
    Thanks for your input.

    This setting is already set the same way for me. The phone has always been set that way. Which is why I find the issue odd.
     
  4. acey612

    acey612 Active Member
    Thread Starter
    15

    Jul 6, 2010
    39
    0
    15
    Well your drunk input was not helpful and borderline rude my friend.

    The fact is that I like trying different types of gadgets. I am a former iphone owner, droid 1 owner, and droid X owner. One of the perks to the droid 2 is in fact the improved keyboard. Many still prefer a hard keyboard. A majority in fact, according to recent surveys.

    To get back on topic however, anyone else have a fix? :)
     
  5. depth1357

    depth1357 New Member
    6

    Dec 16, 2010
    1
    1
    6
    try checking your battery management settings. That was what was causing my DX to switch off wifi. It wasnt going to sleep because of the wifi settings mine was switching off automatically because I had it set to maximum battery saver. I changed it over to Night Time Saver and it stopped doing it.

    Maybe yours is doing the same?
     
    McLabia likes this.
  6. McLabia

    McLabia Well-Known Member
    173

    Mar 18, 2011
    1,213
    234
    173
    Male
    Working...
    City of Sharks to the City of Live Music!
    While I may be necroing this thread, thanks for posting this. It cleared up my moms issues with wifi continuously disconnecting. Now she can download PvZ...yay.:rolleyes:
     
  7. cityboy1

    cityboy1 New Member
    5

    Jun 20, 2011
    1
    0
    5
    HELP..technophobe so it needs to be simple,. My sgs2 keeps scanning on wifi then disconnecting. It worked yesterday. Please help in simple terms thanks
     
  8. McLabia

    McLabia Well-Known Member
    173

    Mar 18, 2011
    1,213
    234
    173
    Male
    Working...
    City of Sharks to the City of Live Music!
    You may want to try here.
    Samsung Galaxy S2 - Android Forums
     

Share This Page

Loading...