1. Download our Official Android App: Forums for Android!

Support Wifi keeps turning on automatically

Discussion in 'Android Help' started by Kenzou, Mar 29, 2016.

  1. Kenzou

    Kenzou Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    29
    Joined:
    Feb 4, 2015

    Feb 4, 2015
    29
    4
    26
    Male
    Hi,

    I have an Alcatel A564C. For the past week or so, the Wi-fi just keeps switching on even after I've turned it on. Had it for a year and this is the first time it's had this problem. Anyone know how to prevent this? Thanks!
     

    Advertisement

  2. Brian706

    Brian706 I like turtles!
    Moderator
    Rank:
     #29
    Points:
    1,053
    Posts:
    9,339
    Joined:
    Jul 25, 2012

    Jul 25, 2012
    9,339
    8,582
    1,053
    Drafter
    Have you installed any apps recently that might be enabling the wi-fi?
     
    tube517 likes this.
  3. Kenzou

    Kenzou Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    29
    Joined:
    Feb 4, 2015

    Feb 4, 2015
    29
    4
    26
    Male
    Hmm. It's possible, though I didn't know any apps did that. Is this entirely determined by going into those apps' settings, or are there some that require some other adjustment within Android?
     
  4. tube517

    tube517 Android Expert
    Rank:
     #35
    Points:
    693
    Posts:
    3,963
    Joined:
    Jun 7, 2010

    Jun 7, 2010
    3,963
    1,996
    693
    Male
    USA
    Settings > more > mobile networks > connections optimizer

    See if that is in your phone and turn it off. This feature is in some Sprint phones (and possibly Straight Talk).
     
    Brian706 likes this.
  5. Kenzou

    Kenzou Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    29
    Joined:
    Feb 4, 2015

    Feb 4, 2015
    29
    4
    26
    Male
    No connections optimizer option within the mobile networks menu. :\
     
  6. Brian706

    Brian706 I like turtles!
    Moderator
    Rank:
     #29
    Points:
    1,053
    Posts:
    9,339
    Joined:
    Jul 25, 2012

    Jul 25, 2012
    9,339
    8,582
    1,053
    Drafter
    Go into Settings > Wifi > ... (3-dot menu) > Advanced and uncheck the scanning always available option. From a quick search of your device it looks like you may be on KitKat and I believe that was an option in KK.


    Also, does it turn on instantly when you turn it off? Or is it just random?
     
  7. Kenzou

    Kenzou Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    29
    Joined:
    Feb 4, 2015

    Feb 4, 2015
    29
    4
    26
    Male
    I don't see a 3-dot menu at all in Wifi. However, and sorry for not mentioning this, it is absolutely KitKat.

    It seems to turn on randomly. It's possible it simply does this whenever it turns on, but it might just be doing it while it's already on.
     
  8. Brian706

    Brian706 I like turtles!
    Moderator
    Rank:
     #29
    Points:
    1,053
    Posts:
    9,339
    Joined:
    Jul 25, 2012

    Jul 25, 2012
    9,339
    8,582
    1,053
    Drafter
    If this is your device:
    k2-_92caef34-8ef2-4095-9033-94b66430ca96.v2.jpg

    I believe you could hit the button circled in red to open the menu and select advanced.
     
  9. Kenzou

    Kenzou Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    29
    Joined:
    Feb 4, 2015

    Feb 4, 2015
    29
    4
    26
    Male
    OK, found it, but the always scan option wasn't checked in the first place.
     
  10. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #31
    Points:
    818
    Posts:
    3,935
    Joined:
    May 15, 2015

    May 15, 2015
    3,935
    2,855
    818
    Male
    Electrician
    Satsuma,Alabama
    Brian706 likes this.
  11. Brian706

    Brian706 I like turtles!
    Moderator
    Rank:
     #29
    Points:
    1,053
    Posts:
    9,339
    Joined:
    Jul 25, 2012

    Jul 25, 2012
    9,339
    8,582
    1,053
    Drafter
    Jfalls63 likes this.
  12. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #31
    Points:
    818
    Posts:
    3,935
    Joined:
    May 15, 2015

    May 15, 2015
    3,935
    2,855
    818
    Male
    Electrician
    Satsuma,Alabama
    I use Straight Talk and have the app installed and never noticed the optimiser option in settings. Always thought it was cool that phone connected to my wifi when I come home automatically. Never noticed if it tried to connect to other networks when out and about.
     
  13. Kenzou

    Kenzou Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    29
    Joined:
    Feb 4, 2015

    Feb 4, 2015
    29
    4
    26
    Male
    No, forgot to mention mine's Tracfone.
     
  14. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #31
    Points:
    818
    Posts:
    3,935
    Joined:
    May 15, 2015

    May 15, 2015
    3,935
    2,855
    818
    Male
    Electrician
    Satsuma,Alabama
    Is there a account management app for tracphone installed? Something that lets you see how much data used and let's you add more air time to account? If so check in its settings.
     
  15. Kenzou

    Kenzou Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    29
    Joined:
    Feb 4, 2015

    Feb 4, 2015
    29
    4
    26
    Male
    Yes, but it only has this "APN settings" thing that doesn't give any indication that it's about disabling this wifi craziness.
     
  16. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #31
    Points:
    818
    Posts:
    3,935
    Joined:
    May 15, 2015

    May 15, 2015
    3,935
    2,855
    818
    Male
    Electrician
    Satsuma,Alabama
    Nothing like this installed?
     

    Attached Files:

  17. Kenzou

    Kenzou Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    29
    Joined:
    Feb 4, 2015

    Feb 4, 2015
    29
    4
    26
    Male
    Sorry, I meant to clarify that there IS such an app installed, but that I don't see anywhere within it that seems relevant to what I'm trying to fix. APN Settings and wi-fi optimizer are the only things that look like there's any chance they're relevant, but I don't yet see options within them that have helped.
     
  18. chanchan05

    chanchan05 The Doctor
    Rank:
     #28
    Points:
    1,108
    Posts:
    15,007
    Joined:
    Jun 30, 2011

    Jun 30, 2011
    15,007
    4,683
    1,108
    Male
    Any battery saver app installed? Some of those try to control wifi behavior as well.
     
  19. Kenzou

    Kenzou Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    29
    Joined:
    Feb 4, 2015

    Feb 4, 2015
    29
    4
    26
    Male
    No, and the problem still hasn't been solved. I'd reset it at this point, but then I wouldn't be learning how to deal w/ the issue in the future.
     
  20. Splodgie

    Splodgie Lurker
    Rank:
    None
    Points:
    6
    Posts:
    1
    Joined:
    Jul 3, 2014

    Jul 3, 2014
    1
    1
    6
    Hi, I have just spent days finding the cure on my phone, I started about 3 weeks ago, I loaded My Data Manager app to track down what was turning the WiFi on, Try This, Go to Setteings/Apps , All running apps as it a back ground app you are looking for, it's called Voice Unlock, It's part of the Google app OK Google voice unlock, Even though the google app was not on my phone the background app somehow got installed, To turn it off I had to install the Google app.
    To turn it off start Google, open the Menu (3 bars top left) Setting/Voice/ OK Google detection and turn it OFF. ( if it dose not open the option to turn it off, change the the Language and save, then the OK Google detection will open, turn it OFF, then change your Language back and save.
    This was the only thing that worked for me after days of trying.
     
    Jfalls63 likes this.
  21. ThePhizzle

    ThePhizzle Well-Known Member
    Rank:
    None
    Points:
    63
    Posts:
    208
    Joined:
    Oct 4, 2015

    Oct 4, 2015
    208
    61
    63
    Male
    Development
    Fresno,California
    Certain wifi apk's automatically turn on wifi and even automatically turn on hotspots,any recent wifi related apks you have installed could be the culprit,try to Uninstall any recent wifi apk's you may have installed.
     

Share This Page

Loading...