1. Download our Official Android App: Forums for Android!

Support wifi never brings up login page

Discussion in 'Android Devices' started by alejandria, Jul 29, 2010.

  1. alejandria

    alejandria Lurker
    Thread Starter
    5

    Jul 8, 2010
    1
    0
    5
    Hi,

    I'm new to android, (switching from a dumbphone + ipod touch combo), and I've been having problems connecting to my school's wifi. The system requires you to connect and then when you try to browse, it brings up a login site for you. However, no login screen ever appears (the browser doesn't redirect to that login site), it just times out. I've tried opening new windows, different sites, everything just times out.

    There has to be a way to get the login screen to appear since many public wifi networks use this method of login, but it just doesn't seem to appear for me. Thoughts? is there a setting that I'm missing?

     

    Advertisement

  2. HaveOmeed

    HaveOmeed Lurker
    5

    Aug 11, 2010
    1
    0
    5
    I have the same exact problem with my Samsung Vibrant trying to log into the school's bluesocket network. My other friends who also have droids log in just fine.
     
  3. zpzgclan

    zpzgclan Newbie
    15

    Aug 5, 2010
    13
    0
    15
    I also have the same problem...
    Seriously want my iphone4 back
     
  4. Dennis_Bham

    Dennis_Bham Well-Known Member
    38

    Jul 17, 2010
    156
    21
    38
    Lab Rat
    Alabama
    Maybe try a different browser ???
     
  5. sremick

    sremick Android Expert
    163

    Jun 18, 2010
    2,521
    356
    163
    IT Admin
    USA
    I just used my Captivate just fine in a hotel that has that sort of system, so it's not an inherent problem with the phone.

    Blame your school, not the Captivate.
     
  6. chicknlil

    chicknlil Android Enthusiast
    93

    Jul 22, 2010
    601
    104
    93
    Female
    New England
    Can you login from another machine and write down what the login webpage is? Maybe manually going to that page will do the trick? You can always save that page as a favorite if that works...
     
  7. Germanguy

    Germanguy Newbie
    16

    Jul 19, 2010
    24
    1
    16
    Normally, in these situations, when you start your regular browser, it should direct you to the login page.
     
  8. phillipbess

    phillipbess Newbie
    16

    Jul 23, 2010
    11
    3
    16
    Was this ever fixed? I have the same problem at my school, connects to wifi fine but never redirects to the login for acess
     
  9. sremick

    sremick Android Expert
    163

    Jun 18, 2010
    2,521
    356
    163
    IT Admin
    USA
    There's nothing to "fix" at the Captivate end. It's a problem with whatever portal system your school is using.

    You can try to use something like the Dolphin browser to spoof the user agent string to something like an iPhone or a PC to see if that helps, otherwise you need to talk to your school's IT staff.
     
    osiris010 likes this.
  10. joegrano2010

    joegrano2010 Lurker
    6

    Aug 21, 2011
    9
    2
    6
    Stationed overseas
    None of your answers were correct. It is not a problem with their school server. It is an Android problem that persists through to version 2.3.4 There is no browser or setting in any of the myriads of browsers, which will enable an Android platform to access certain login/password pages. I have an HTC G2 running current stock 2.3.4 and still have this problem. There are no solutions or answers and one gets the feeling that someone is busy deleting any mentions of this issue from existence. On the many websites you can find where someone has asked similar questions, there is never an actual solution or solid answer. Sorry.
     
    Cottes likes this.
  11. frankomally

    frankomally Lurker
    6

    Sep 22, 2011
    1
    1
    6
    My experience causes me to believe joegrano2010. I have a motorola droid x2 running android 2.3.3, and have tried the standard browser, dolphin, firefox, and opera. None can connect to the wifi at the hotel I am at. My laptop running windows 7 connects just fine.
     
    Cottes likes this.
  12. pfindan

    pfindan Lurker
    5

    Nov 13, 2011
    1
    0
    5
    I have the same problem, does anyone know the status of this problem? Will it be fixed on ICS ( andriod 4.0 )
     
  13. Cottes

    Cottes Lurker
    5

    Nov 15, 2011
    1
    0
    5
    I have the same problem when trying to sign in on the free wi fi with my Samsung galaxy tablet. While on the same wi fi, i can sign on with my wife's pad 2 :-(

    Android needs a fix. NOW!!!
     
  14. osiris010

    osiris010 Lurker
    6

    Nov 28, 2011
    2
    1
    6
    I have been having this issue as well on my brand new moto ATRIX 2 and I thought it might have been an android issue, but I was reading this thread when I came across the post made by a user a few posts (thanks sremick) up when it worked.
    this has been my biggest issue with android since my iPhone 4 that I just sold was always able to connect to any wifi network regardless of web login or whatever, which h my school happens to have.

    what worked for me:
    in either Dolphin HD or Dolphin Mini (the one I used) change the user agent to desktop. after I did that I went back to the wifi settings and selected my schools network and it connected with no problems at all. I never would have thought to try it this way but it worked flawlessly. I made this post connected to the Wi-Fi, so I had to create this account to share my success since I know this is very frustrating.
     
    bigtorchny likes this.
  15. bigtorchny

    bigtorchny Lurker
    5

    Dec 6, 2011
    1
    0
    5
    I am using eee pad transformer and tmobile galaxy s2 at my college. I can confirm that this has not been fixed yet. Even my Nokia e72 was able to connect easily, bringing up the login page. Needless to say iPod touch works so well also. I even used those wifi login apps from marketplace.none worked so far. Android sucks big time with wifi issues.
     
  16. phangrrl

    phangrrl Lurker
    5

    Feb 8, 2013
    1
    0
    5
    I'm not sure it's a bug. I have the issue, but I think what's happening for me is I use Maxthon browser - which unlike Dolphin does not store tracing info when set up. To access the wifi networks, you have to log in w/ a browser and for me, when I close the browser, the login info is lost (it does what I told it to do, delete all references to my session).

    Then when I hit the net through an app, it can't connect because the browser lost the login link. No apps prompt for network pwd.

    Looking for an app to manage wifi logins w/o browsers...
     
  17. Brad Saunders

    Brad Saunders Lurker
    5

    Oct 15, 2014
    1
    0
    5
    I always had to "Take a Tour" to access the WiFi login pages. I couldn't for the life of me connect to WiFi, then one day I accidentally hit the Take a Tour button and the WiFi login screen appeared and was able to connect. Now that I have cleaned my phone the Take a Tour option disappeared and I don't know how to get it back. Now i can't connect. This has happened before but I just can't remember how I get the Take a Tour page to come back. Hopefully this will help someone.
     
  18. FarVistas

    FarVistas Lurker
    5

    Sep 26, 2010
    2
    0
    5
     
  19. FarVistas

    FarVistas Lurker
    5

    Sep 26, 2010
    2
    0
    5
    I have had this problem repeatedly at hotels. Sign in once to wifi. Turn off computer and go to bed. The next day, unable to reach hotel log-in pages, so unable to get into wi-fi. Yesterday I spent 3 hours on the phone with the hotel's wifi consultants. I was passed to 3 levels of expertise because everyone was failing at resolving the problem. Finally the 3rd tech person solved it. The problem has to do with the DNS server address - it gets written into the computer, whereas it needs to be located automatically. Here are the steps:
    Go to Control Panel
    Click on Network and Sharing
    On left, click on Change Adapter Settings
    Right-click on the local Wi Fi logo
    Click on Properties
    Click on the WORDS of Internet Protocol Version 4 (leave the check box clicked)
    Click on Properties
    Check IP Address AUTOMATIC
    Check DNS Server AUTOMATIC
    That is the solution, and it has now worked for me on 2 successive days. It seems that clicking on DNS Server Automatic can easily disappear, and did for me after 1 day, but it is an easy thing to re-check Automatic again. Then I go out of the browser (Google Chrome) and back in again, and I am able to access the hotel wifi.
     
  20. kellrobinson

    kellrobinson Lurker
    16

    Nov 20, 2013
    5
    1
    16
    I was wondering what you meant by "control panel" so I googled "android control panel." I see there are several "control panel" apps. Which one do you use?
     
  21. BryanKoding

    BryanKoding Lurker
    15

    Jul 9, 2015
    1
    0
    15
    Hi alejandria,

    I was having the same problem with my hotel WiFi. (That's is how I came across this post.) But there was a simple solution for me.

    1 turn off the WiFi.
    2 close the browser.
    3 turn on the WiFi and connect to the desired network.
    4 open the browser.

    The login page should now load and you will be able to enter credentials.

    Thanks for bringing up this question and I hope this answer helps!

     
  22. Johor9

    Johor9 Lurker
    5

    Jul 20, 2015
    1
    0
    5
    Male
    The solution is to do the login step via the default web browser "Internet" instead of Chrome
    solution
     
  23. Hannah Rice

    Hannah Rice Lurker
    15

    Oct 15, 2015
    2
    0
    15
    Female
    Hi,

    This is not really a fix, but it is a way around it.
    I have a HTC one M8, and went into internet settings, and turned off the setting "Automatically Login to Saved Networks". This then allowed me to connect to the shared uni network and login via the connection settings and not the browser login page. Hope this Helps.
     
  24. Tony Webber

    Tony Webber Lurker
    15

    Nov 16, 2015
    1
    0
    15
    Male
    I have this same exact problem with a HTC Desire 626s. I was previously using a samsung galaxy note 3 and it let me log into the wi-fi here but the HTC doesn't. Any ideas??????
     
  25. bbzboss

    bbzboss Lurker
    15

    Dec 20, 2015
    1
    0
    15
    Male
    I m using samsung device and i cant get notification "sign in to wifi network" but erliers i was able to see it. I m usimg a hotel's wifi near my house.My whole family even the neigjbours are enjoying the wifi by loging in. Erlier i was able to see the notification "sign in to wifi network" but know i cant see that notification i used that wifi approx 20 days !!! Anyone plz help !!!
     

Share This Page

Loading...