1. Download our Official Android App: Forums for Android!

Support Wifi not connecting automatically?

Discussion in 'Android Devices' started by Veronykah, Jul 20, 2014.

  1. Veronykah

    Veronykah Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    23
    Joined:
    Oct 14, 2010

    Oct 14, 2010
    23
    0
    15
    I guess I have 2 questions.
    It seems my Moto X disconnects from Wifi to save battery power however, when it's charging or charged it doesn't turn the wifi back on. I have to go to settings and manually turn the wifi back on, even when I am at home on a remembered network.

    Is there a way to change this? I don't want it to turn off the wifi if it is on a trusted network, ever.
    I also want it to automatically connect to a trusted network.
    I keep finding myself on 4g when I am at home, wasting my data allotment without noticing as I've never had a phone that did this.

    Hope someone can help, I've looked everywhere and can't find out how to change these settings.
     

    Advertisement

  2. titetanium

    titetanium Member
    Rank:
     #1,266
    Points:
    18
    Posts:
    46
    Joined:
    Aug 27, 2012

    Aug 27, 2012
    46
    15
    18
    Settings > WiFi > settings/advanced > WiFi optimization - uncheck this. Also set Keep WiFi on during sleep to always. That should fix your issue.
     
    Clementine_3 likes this.

Share This Page

Loading...