1. Are you ready for the Galaxy S20? Here is everything we know so far!

wifi not obtaining ip address

Discussion in 'Android Devices' started by gazbut, May 16, 2010.

  1. gazbut

    gazbut Newbie
    Thread Starter

    hi all
    this is driving me mad
    got a desire from virgin, great phone
    wifi was fine at first but now when i turn wifi back on it says
    remembered secured with wps/wpa2 psk
    obtaining ip address
    but then after a few mins says unsucessful
    this is with the phone next to my router!
    also under settings - wifi settings i have no advanced tab to set my router time out? where is it?

    1. Download the Forums for Android™ app!


  2. SurfXombie

    SurfXombie Member

    Not sure if this helps but..

    If I use a 3rd party app to do the wifi connect (namely WeFi) it is a bit hit and miss.
    I have no problem doing it via the menu>settings>wireless&networks

    Not sure about time-out but you can get it to forget the connection (press & hold on the wifi connection in the list and then see the options)

    So my suggestion would be...
    1. Check the wifi router is working with other computers
    2. Turn off and on the router (I have one that needed regular reboots), then re-try
    3. power off and on the phone to see if that helps
    4. "forget" the connection and redo the link
  3. Neddyseagoon

    Neddyseagoon Lurker

    Perhaps not really on topic,but my desire & my wifes iPhone both see my home network but will not connect.The Passcode entered is correct as my wifes computer & the laptop connect OK.
    On Virgin with a VM crippled D-Link 615 router.
  4. germcevoy

    germcevoy Member

    Sounds obvious as hell but can be a cause. Your network key will be case sensitive so all upper case characters must be entered into the phone in upper case.
  5. thor_b

    thor_b Lurker

    If you get to "obtaining IP..." then the wifi part is OK. You should take a look at your DNS server (- I'm guessing its integrated in the router but its a separate function)
    - are there limits to how many adresses it can pass out
    - any log file entries to suggest reasons

    Another option that could be worth investigating is static IP address.
    Not really sure if the phone can be set to have a static address or how (mine doesn't have that option but perhaps with a 3rd party network app)
  6. nx1977

    nx1977 Android Expert

    If you have a BT or Orange box, then you need to press the pairing button.

    Also worth downloading from the market wifi analyzer and checking if any other routers are on the same channel.
  7. kboya

    kboya Android Enthusiast

    If other answers don't work, try adding the device to WiFi from your main pc. It may be that your router is denying connection.
  8. thor_b

    thor_b Lurker

    Did I just say DNS? I meant DHCP!
  9. Neddyseagoon

    Neddyseagoon Lurker

    Thanks for the replies.
    The passcode consist of upper/lower case & I inputted these correctly.
    May have a fiddle with the router but its not really a problem as my laptop connects OK.
  10. bybora2010

    bybora2010 Lurker

    Hey you guys! I have been spending 3 sleepless night now :mad:
    I can find the tethering switch on/off. I think that might be causing the issue. Because my router also gets spammed after several tries and PC signals no connection/limited connection.
    Can it be that tehtering, trying to act as a modem, somehow jams the router ip settings?

    Please help! I want to sleep...
  11. hippy247

    hippy247 Well-Known Member

    You should tryout wifi analyzer from the app market. Your channels could be overloaded and a simple channel change could hopefully solve your problems.
  12. Arober11

    Arober11 Lurker

    DCFC79 likes this.
  13. Nasalhair

    Nasalhair Guest

    I was recently on holiday and tried to connect to the hotel's unsecured wireless network. People using other devices were connecting without issues but my Desire stubbornly refused to connect. My Desire reported that the signal strength was excellent but it got stuck at the "obtaining IP address" part. Utterly infuriating, and I couldn't fix it.
  14. amlothi

    amlothi Android Expert

    These are virtually always a router issue and not a phone issue. If you own the router, contact tech support.

    Routers are so different and finicky, they don't all work the same way, they may be using non-standard channels or protocols, it may be that the type of encryption you have enabled isn't supported by your phone, or it could just be that the router isn't working properly.

    Your phone will be more sensitive to these things than a computer will. However, that doesn't mean the phone is the problem. It just means that the router is doing something strange, and that's making it not work properly with certain devices.
  15. Nasalhair

    Nasalhair Guest

    As I said, the router I was trying to connect to belonged to the hotel I was staying in, so I couldn't exactly go over and ask the manager to restart his router or reconfigure it, especially as people using devices other than HTC Desires seemed to be connecting just fine (I saw people using Samsung phones on wireless, and also iPhones & iPads.) My girlfriend's phone - also a Desire - also failed to connect to the router.
  16. Khusro.malik

    Khusro.malik Lurker

    I had this problem. Removed all wires from router (power and other RJ cables) and waited for two minutes. Did forget connection on my Tab.
    Started router with all connections in. Did reconnect wifi on my Tab and voila. Piece of cake. No issue.
  17. Nasalhair

    Nasalhair Guest

    That's all very well if it is your router - in my case (and others) this is with public wifi access points. You can't exactly go to the hotel manager and ask them to restart or reconfigure their router, especially when others are connected with no issues.
  18. kravezz

    kravezz Lurker

    Hi, I got Acer Iconia A500 with router Trendnet TEW-452BRP. Got a "obtaining IP address from..." Such thing helped: router setup-> wireless-> advanced -> Beacon Interval. It was 100 within range 20~1000. I set 1000 and everything began working.
  19. laim

    laim Lurker

    Hi i recently bought P500 ( 2.2 froyo ) and im unable to connect to the open wifi at my work place it shows excellent signal however it gets stuck at Obtaining ip address i have tried other wifi connections and some work ( or get connected ).

    I desperately need this open wifi at workplace to work, Any help in this regard would be much appreciated

HTC Desire Forum

Features and specs are not yet known.

Release Date

Share This Page