1. Check out our app, Forums for Android! Download and leave feedback here!

Wifi Obtaining address... from netgear router.

Discussion in 'Android Devices' started by godsdead, Aug 25, 2009.

  1. godsdead

    godsdead Member
    Thread Starter
    15

    Aug 25, 2009
    14
    0
    15
    Music Tech & Media Tech
    Clacton
    I have a HTC Hero - T-mobile

    Ok the problem, is i used to be able to connect to my wifi router no problem, its a netgear. "remembered, secured with WPA-Personal" and for some reason, it just wont get passed Obtaining address...

    So its connecting? but cant establish an IP?

    Help please!
     

    Advertisement

  2. ianr

    ianr Well-Known Member
    38

    Aug 7, 2009
    253
    18
    38
    Have you tried the obvious stuff like resetting the router? And the phone? Are there any logs on the router (particularly anything that mentions DHCP) that can shed any light on it?
     
  3. souleh

    souleh New Member
    5

    Aug 27, 2009
    2
    0
    5
    I usually find if its stuck on that I've got the key wrong.
     
  4. AMT

    AMT New Member
    5

    Sep 3, 2009
    1
    0
    5
    I have the same problem some times. It usually helps restarting the router.
     
  5. godsdead

    godsdead Member
    Thread Starter
    15

    Aug 25, 2009
    14
    0
    15
    Music Tech & Media Tech
    Clacton
    Yea, restarting the router fixes this, its just annoying it happens from time to time.
     
  6. daveybaby

    daveybaby Well-Known Member
    93

    Sep 21, 2009
    919
    105
    93
    Software engineer
    UK
    Couple of things to try:

    (1) make sure your router's firmware is up-to-date.

    (2) try limiting your router to 802.11 b & g only (i.e. disable n)
     
  7. happy1

    happy1 Member
    5

    Jan 9, 2010
    9
    0
    5
    I have this same problem....any other ideas?
     
  8. dimeworm

    dimeworm New Member
    5

    Sep 23, 2010
    1
    0
    5
    Same thing happens to me.
    I think it happens when you disconnect from the wiFi and another person entered the router. It seems that android is failing to obtain the new Ip Address. I am using SE Xperia Mini Pro..
     
  9. daveybaby

    daveybaby Well-Known Member
    93

    Sep 21, 2009
    919
    105
    93
    Software engineer
    UK
    I had the same problem the other day when trying to connect to a wifi hotspot - i was using wifi analyzer to find the hotspot and its scanning function was interfering with the connection process. Once i killed wifi analyzer i connected just fine.
     
  10. Arober11

    Arober11 New Member
    6

    Feb 11, 2011
    3
    1
    6
Tags:

Share This Page

Loading...