1. Are you ready for the Galaxy S20? Here is everything we know so far!

WiFi problem on S4

Discussion in 'Android Help' started by Jay Blackett, Jan 11, 2016.

  1. Jay Blackett

    Jay Blackett Lurker
    Thread Starter

    Hi,
    I was running android 4.4.2 when I realised a problem;
    when I try to turn on wifi it turns light green then goes grey and refuses to turn on.

    For this reason I decided to upgrade to 5.0.1.

    However, when I did the problem remains.

    I have spent lots of time searching this problem and I cannot find a permanent solution.

    The only thing that worked was turning off the phone, hitting it on the edge of the table and booting up again.
    After this, the wifi will turn on, but turns off after about 1-2 mins.

    This is frustrating me very much so help would be greatly appreciated.
    Thanks.
     


    #1 Jay Blackett, Jan 11, 2016
    Last edited: Jan 11, 2016

    1. Download the Forums for Android™ app!


      Download

       
  2. BubzzLemz

    BubzzLemz Newbie

    Was the WiFi working fine before you flashed the rom? I have an S4 and I'm debating on flashing the rom for it and been bugging my carrier to just release the update. However, I seen this problem is very common in ROM flashes and you may need to rest your phone completely with a factory reset and try flashing it again.
     
  3. Jay Blackett

    Jay Blackett Lurker
    Thread Starter

    No, the wifi started to do that about a day before flashing. I decided to factory reset and flash because I wanted to rid the problem and upgrade to lollipop. Sorry I should've mentioned that.
     
  4. BubzzLemz

    BubzzLemz Newbie

    Have you fixed the problem since? Are you connecting to one WiFi network or have you tried another? I would factory rest again and give it another go. Also, I would look into the WiFi connection if it's a home one and update the router firmware there as well (I had that issue with my S4 and since updating my router firmware and factory resetting the phone, it's been fine)
     
  5. AZgl1500

    AZgl1500 Extreme Android User

    You should have resolved the WiFi problem before you introduced "new software"...

    that is NOT the way to fix hardware issues, or other "software issues"...

    I think you should do a FDR, and let the phone come back up from scratch, that generally will fix network type problems.
     
  6. Jay Blackett

    Jay Blackett Lurker
    Thread Starter

    Thanks for the replies.
    No, the problem still persists. I dont think its a router problem because wifi refuses to turn on at all and I have been in a different house with a different router.

    I tried factory resetting but nothing happened. The wifi button goes light green and either stays that way or goes grey.

    Any further suggestions greatly appriciated.
     
  7. svim

    svim Extreme Android User

    Hopefully your S4 isn't having a hardware problem where the WiFi radio chip is the source. But maybe try these basic fixes:

    -- Restart your S4 in 'Safe Mode'. Your phone will be running in a bare Android-only mode so whatever apps and things you've installed won't show. If your WiFi is still not working or dropping out after a couple of minutes, in Safe Mode at least you know it's not because of anything you installed nor one of Samsung's goofy addons. Restart your phone normally to get back to its usual state. Unfortunately if your WiFi is still problematic in Safe Mode, there's a higher likelihood you have a hardware issue.
    http://www.technipages.com/samsung-galaxy-s4-turn-safe-mode

    -- Since you'll be restarting your phone anyway it's a good time to wipe the system cache partition. This won't affect any of your personal data or app settings, the system cache is just a dumping ground various system processes running in the background use to keep temp files and things. But occasionally some temp file might get corrupted and won't delete itself properly. It's a remote possibility but maybe something relevant to your phone's WiFi will get cleaned up. Also, since you mentioned that you upgraded up from 4.4.2 it always a good idea to flush the system cache.
    https://www.androidpit.com/forum/608584/how-to-clear-the-system-cache-for-the-samsung-galaxy-s4

    -- A 'Soft Reset' involves restarting your S4 but also involves removing the battery. In a normal restart your S4 is continuously powered the entire time, it's just a matter of the Android operating system shutting down, and then getting loaded back into memory again and starting up again. With a soft reset, you turn off your phone and by pulling the battery it clears any possible glitches that might be present in the hardware, in essence both your S4's hardware and software go through a reboot. If the problem is tied to the WiFi radio chip inside your phone this might help.
    http://smallbusiness.chron.com/soft-reset-samsung-galaxy-s4-81670.html
     
  8. Jay Blackett

    Jay Blackett Lurker
    Thread Starter

    I booted into safe mode and wiped the cache partition with no luck.

    If the wifi radio chip is broken is it easy to replace/get replaced?
     
  9. svim

    svim Extreme Android User

    If the WiFi chip is actually the source of the problem, generally it's a matter of the replacing the motherboard. The chip itself is soldered to the board. Here's a link showing a tear-down of a S4, step 13 indicates the Broadcom chip:
    https://www.ifixit.com/Teardown/Samsung+Galaxy+S4+Teardown/13947

    Another remote possibility is the connector for your S4's antenna needs to be pushed back into place. In step 13 of this link it shows a photo on where it's located:
    https://www.ifixit.com/Guide/Samsung+Galaxy+S4+Motherboard+Replacement/16537
    Pry it up and push it back into place. I really don't think this is the problem but it's worth trying.
     
  10. Jay Blackett

    Jay Blackett Lurker
    Thread Starter

    I took the back off the phone and it looks to me like the antennas fine.
    So does this mean I need to either replace the motherboard or get a new phone?
     
  11. ThePhizzle

    ThePhizzle Well-Known Member

    I had that same issue,here's what i did;everytime the problem accrued i would reboot into my custom recovery clear davak cache,wipe cache data,data factory reset than flash the rom again,it might take a try or to but the problem corrects itself trust me it happened twice to me already good luck.
     
  12. Jay Blackett

    Jay Blackett Lurker
    Thread Starter

    Sorry, could you please explain that a bit more? Where do I find the davak cache? Thanks
     
  13. ThePhizzle

    ThePhizzle Well-Known Member

    The davik cache can only be reached if you have flashed a custom recovery to your phone that's if you flash you're wrong with the custom recovery like clockworkmod or TWRP that's where you can find clear dalvik cache thats how i flash my roms but that's the only way I know how to correct that Wi-Fi no signal problem sorry if you use Odin to flash ROM I'm not sure if it works the same way but it might good luck.
     
  14. Blu8

    Blu8 Android Expert

    Jay, do me a favor and take a screenshot/tell us what your firmware and baseband versions are? They should be in settings>about phone.
     
  15. ThePhizzle

    ThePhizzle Well-Known Member

    i
    If it's 4.4.2 its kitkat,probably tried to update to the latest firmware possible for SG4 witch was probably a lollipop,correct?I favor slimkat and masterchief87 has good roms as well.just a guess but is your service MetroPcs?where you using cm-12.1-20151010-NIGHTLY-jfltetmo.zip rom or did you go odin more than likely scince you asked about davik cache swipe,you can grab a modem.bin and place it in the pda slot on odin and try flashing that onto your sg4.couldn't hurt but if that dosent help you should probably flash it back to stock rom M919NUVUFNK3_M919NTMBFNK3_TMB.zip but that ones T-Mobile but all the SG4 stock rom looks similar in name just depend on what carrier service the phone is,but hey give it a shot.
     
Loading...

Share This Page

Loading...