1. Download our Official Android App: Forums for Android!

Support WiFi Problem

Discussion in 'Android Help' started by Stoyan Georgiev, Mar 18, 2016.

  1. Stoyan Georgiev

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    6
    Joined:
    Mar 18, 2016

    Mar 18, 2016
    6
    1
    16
    Male
    Hello ! Recently I had a problem with one of the sim slots and I took my phone to the service centre. I took it back, but obviously they have done something to the wifi antenna, because the signal now is very week, even right next to the router. The problem is not in the router itself. I don't want to get my phone back to the service centre, because of many reasons. I understood that the problem could be in the wifi antenna, but I don't know where it is, in order to try to at least clean it. Can you help me? Thanks!
     

    Attached Files:


    Advertisement

  2. girolez

    girolez Often Off Piste
    Rank:
     #46
    Points:
    543
    Posts:
    3,847
    Joined:
    May 29, 2011

    May 29, 2011
    3,847
    1,919
    543
    Male
    Retired
    Les Gets, France
    Hi

    I have no experience of phone internals, but I do know that to have a chance of some meaningful help, you need to let us know what make and model of phone you have!
     
    scary alien and mikedt like this.
  3. mikedt

    mikedt 你好
    Rank:
     #4
    Points:
    3,238
    Posts:
    25,099
    Joined:
    Sep 22, 2010

    Sep 22, 2010
    25,099
    14,065
    3,238
    Teachaaa
    Jinan, China
    Could be the repairer might have dislodged or even damaged the WiFi antenna. What phone actually is it? Because this will be very device specific. Might be worth looking at Ifixit.com see if they have any teardown, disassembly or repair tips for it.
     
    #3 mikedt, Mar 18, 2016
    Last edited: Mar 18, 2016
    scary alien likes this.
  4. Stoyan Georgiev

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    6
    Joined:
    Mar 18, 2016

    Mar 18, 2016
    6
    1
    16
    Male
    Sorry, forgot to mention, it's Prestigio 5508
     
    scary alien likes this.
  5. Stoyan Georgiev

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    6
    Joined:
    Mar 18, 2016

    Mar 18, 2016
    6
    1
    16
    Male
    I think it might be happening because 2 out of 4 wires are not soldered. /sorry, English is not my first language, obviously :)/
     

    Attached Files:

  6. mikedt

    mikedt 你好
    Rank:
     #4
    Points:
    3,238
    Posts:
    25,099
    Joined:
    Sep 22, 2010

    Sep 22, 2010
    25,099
    14,065
    3,238
    Teachaaa
    Jinan, China
    You referring to the thing on the back of the battery, above the barcode? That's a thermal sensor, to ensure it doesn't get too hot and explode while charging. That only needs two connections. Have you looked on the other side of the assembly, logic board, and back of touchscreen? Post a pic of them.
     
    #6 mikedt, Mar 19, 2016
    Last edited: Mar 19, 2016
    scary alien likes this.
  7. Stoyan Georgiev

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    6
    Joined:
    Mar 18, 2016

    Mar 18, 2016
    6
    1
    16
    Male
    I didn't, because it's a single piece phone, I mean with no removable battery, so I'm kind of afraid to open it...
     
  8. Stoyan Georgiev

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    6
    Joined:
    Mar 18, 2016

    Mar 18, 2016
    6
    1
    16
    Male
    And I don't know how thw wifi antenna should look like ...
     
  9. JerrySong1

    JerrySong1 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    21
    Joined:
    Dec 9, 2015

    Dec 9, 2015
    21
    2
    16
    What brand/type of phone is it? Some wifi antennas coil around the inside of the phone. It sounds like the wifi card is ok but the coil is disconected. Your going to have to research to find the location and replace/repair it somehow...
     
  10. Stoyan Georgiev

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    6
    Joined:
    Mar 18, 2016

    Mar 18, 2016
    6
    1
    16
    Male
    it's Prestigio 5508
     
  11. DB_Carwell

    DB_Carwell Guest
    Rank:
    None
    Posts:
    0
    Joined:

    Hi 1) Try removing the Wifi information then do a soft reset to the phone. After that's complete, Reinter your Wifi information back into the appropriate place and watch for its connection.
    2) If it the problems persist with that connection see if any other Wifi connect Ed devices is having similar problems. If so your router need to be reset and repeat process 1) over again.
    2) Try a different connection like a hot spot of some sort. If the device having been damaged from accident or missing handling it, there should be no reason for the device hotspot to malfunction.
    3) If all fail do a hard reset of the device. NOTE: back up anything you don't want to be lost before you do a hard reset and remember to remove your SIM CARD and any SD CARD before do a hard reset to your device.
    4) replace your sim card and your SD card after the reset is complete and enter in all your information to set your device backups.
     
  12. DB_Carwell

    DB_Carwell Guest
    Rank:
    None
    Posts:
    0
    Joined:

    Your Wifi and mobile network carrier antenna is one of the same so if your network carrier is connecting to your device that means that you're Wi-Fi connection should be working also.
     
  13. DB_Carwell

    DB_Carwell Guest
    Rank:
    None
    Posts:
    0
    Joined:

    PS forgive me for any typos because I noticed a few before I forget to proof read the information before I logged in it and notice that wasn't a edit button in this forum.
     

Share This Page

Loading...