1. Download our Official Android App: Forums for Android!

Support wifi problems after upgrade to froyo

Discussion in 'Android Devices' started by mattbaloo, Dec 1, 2010.

  1. mattbaloo

    mattbaloo Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 1, 2010

    Dec 1, 2010
    1
    0
    5
    hi
    i upgraded my samsung s to froyo now i cant get my wifi too connect too my home wifi
    so far
    i done resets
    format internal sd
    downloaded gst rooted my phone and activated voodoo restarted etc etc still no wifi
    what more can i do
     

    Advertisement

  2. jaymzwatt

    jaymzwatt Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 1, 2010

    Dec 1, 2010
    1
    0
    5
    I just updated to froyo and am having the same problem. It will find my wifi but when you click connect it justget stuck on obtaing IP address from...' Would be great if someone knows how to fix this
     
  3. Babbilla

    Babbilla Lurker
    Rank:
    None
    Points:
    25
    Posts:
    5
    Joined:
    Dec 2, 2010

    Dec 2, 2010
    5
    0
    25
    try with static ip, gateway, dns!

    it's ok with me!
     
  4. Sdi1000

    Sdi1000 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    13
    1
    16
    I have the Same problem, obtaining IP.....and the says network is disabled. A factory reset works for about a week :mad::mad::mad:
     
  5. gabelu82

    gabelu82 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    1
    0
    5
    hi. I have the same problem. After updating to froyo wifi is not connectig anymore.
     
  6. tusshhar

    tusshhar Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 10, 2010

    Dec 10, 2010
    1
    0
    5
    I am also facing the same issue after upgrade of Galaxy S to 2.2. I am not able to connect to any wifi connection including my own. It stuck at "Obtaining IP address.." after authentication. I have one more Galaxy S phone with 2.1 which has no problem connecting to the same wifi connection. So it's definitely an issue with 2.2 upgrade.
     
  7. moridz

    moridz Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    2
    0
    5
    Appeared to have problem once upgrade to 2.2 but after allow the first time running the background data in setting/accounts and sync...the it turned to be okay.
     
  8. skip1469

    skip1469 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 13, 2010

    Dec 13, 2010
    1
    0
    5
    Hi mine says it is connected to my wifi, but i can't browse the net or do anything with it. I really am starting to dislike this phone and android OS. Might go back to Nokia if i cant get this fixed. HELP please
     
  9. manti452

    manti452 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 17, 2010

    Dec 17, 2010
    1
    0
    5
    same issue here.. wireless network is showing as disabled but is clearly detected. Worked for a week after buying the phone. Phone crashed last night and hasn't worked since. pushes to 3g to connect all the time. wifi icon is lit green showing it is on.. does the GPS thing have to be enabled too?

    am lost as this is my first android.
     
  10. pfinnegan

    pfinnegan Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Dec 15, 2010

    Dec 15, 2010
    7
    0
    5
    Try running your wifi on a different channel say 10. Change this on your router/wireless modem. There may be too many wifi signals in your area all running on the same channel.
     
  11. BanziMick

    BanziMick Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 17, 2010

    Dec 17, 2010
    1
    0
    5
    I upgraded to Froyo few hours ago and discovered that now I cannot connect to my company's wi-fi anymore!
    It's protected with 802.1x EAP and whatever I do, the "Phase 2 Authentication" setting is always reverted to "None", instead of being set to "MSCHAPV2".
    I've read it's a known bug, but I couldn't find any fix. Could anyone help me, please???
     
  12. JenLoong

    JenLoong Lurker
    Rank:
    None
    Points:
    6
    Posts:
    1
    Joined:
    Jan 8, 2011

    Jan 8, 2011
    1
    1
    6
    This wifi peoblem can be solve by below method.
    1. Go to account and sync
    2. Enable data & auto sync, then sync it one time after froyo updated.
    3. Enable wifi again...connected!
     
    treedroid likes this.
  13. ang3

    ang3 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    26
    Joined:
    Aug 24, 2010

    Aug 24, 2010
    26
    4
    16
    ^^ that didnt do anything for me ;(
     
  14. CrazySte

    CrazySte Well-Known Member
    Rank:
    None
    Points:
    18
    Posts:
    77
    Joined:
    Sep 22, 2010

    Sep 22, 2010
    77
    13
    18
    HI EVERYBODY,
    i had the same problem with my WiFi at Home since i Updated to Froyo... basically it was alwaws saying that my WiFi was out of Range even if i was just 3 Feet Away from it.


    Well, today i decided to take a look at it and i soon found the solution:


    I have a Secured Wireless Connection with Access Control, so i went to check the access control list, and sure Enough it was stating that the MAC Address of my Phone was connected even if the Phone was stating that the Wireless Network was out of Range.

    So I connected to my Wireless Router with the Computer that is wirely connected to it and i went into the WiFi Settings and did the Following:

    1) Disabled the Control Access List (where you have all the MAC Addresses allowed to Connect)

    2) i Disabled the PassKey

    3) i Disabled the WPA/WPA2 Encryption


    MAGICALLY
    now the Phone said that my WiFi was now in in Range.

    -I re-Enabled the WPA/WPA2 Encryption

    -I re-Enabled the PassKey

    -i re-Enabled the Access List by re-entering the MAC Address of my Galaxy S


    THEN
    on my Phone i had to enter again the PassKey, it was like if the Phone Forgot the Pass Key, so i entered it and now i am OnLine.


    I HOPE THIS HELPED
    CIAO
     
  15. robcroft

    robcroft Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jan 19, 2011

    Jan 19, 2011
    3
    0
    5
    Information Security Officer
    Edmond, OK
    I had the same problem with my Samsung Captivate running a leak version of Froyo 2.2 and tried all the previous fixes with no luck either. I knew it had to be something that was different with Froyo 2.2 cuz it worked before I updated and it worked at some of my other WiFi connections, but not my work connection which quit after the update. Same problem where it connects then trys "Obtaining IP Address" and doesn't then cycles back through that a few times then shows "disabled, ???". While trouble shooting the problem I noticed there was at the same time another WiFi device with a poor signal in my list that was showing up for available connection. I decided to try and connect to it and of course didn't have the password and I got it to show Disabled, Secured with WPA/WPA2 PSK and then my work connection imediately connected and has been working great ever since! ;) So, some how that other WiFi device in the available scan list was somehow interferring with my work WiFi. So any of you having this problem on any Froyo 2.2 device should check to see if there are others on your list in that area with an available signal that you will need to some how disable.

    I hope this helps others with this problem

    Thanks,
    Robert
     
  16. ang3

    ang3 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    26
    Joined:
    Aug 24, 2010

    Aug 24, 2010
    26
    4
    16
    i fixed this problem by turning on wifi thru the "allshare" app.

    its that simple
     
  17. poohbear99

    poohbear99 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    15
    Joined:
    Jul 18, 2010

    Jul 18, 2010
    15
    1
    16
    Thank you Ang3, it worked! I was Just about to go back to my old iPhone because I couldn't get the stupid wifi to work.
     
  18. scottie2345

    scottie2345 Newbie
    Rank:
     #1,597
    Points:
    15
    Posts:
    15
    Joined:
    Jul 10, 2010

    Jul 10, 2010
    15
    0
    15

    Just worked for me as well :)

    Scottie
     
  19. amortec

    amortec Lurker
    Rank:
    None
    Points:
    26
    Posts:
    5
    Joined:
    Dec 27, 2010

    Dec 27, 2010
    5
    1
    26
    I followed your tip and I was extremely happy when my wifi settings shows that I've connected. However for some strange reason, I can't seem to browse, update twitter, download gmail etc. etc. I disconnected and tried connecting again using the conventional method and the problem of perpetual "obtaining ip address..." persists !

    Am I missing something :thinking:.
     
  20. rahulraj

    rahulraj Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Dec 26, 2010

    Dec 26, 2010
    2
    0
    5
    I can confirm that the allshare tip worked for me too ! Absolutely no clue why, but it did get me back online!

    For reference, I did not get any problem in obtaining ip, but it just wouldn't browse web after connecting through wifi. I am running a rom from doc's kitchen.

    Cheers!

    ======================

    OK. The fix worked like a charm first time, but then it has stopped working. It's like a bacteria developing resistance to antibiotics!! :(

    Again, I have absolutely no issues in connecting to the router and getting an IP address, the phone just doesn't browse the net. Intermittently, it may go online - say connect to the market, but then it will not download anything.
    Further, I use AndFTP to connect to my local PC over WiFi-LAN, and it takes ages to connect unlike earlier, when it was nearly instantaneous. AndFTP also is not able to download anything giving some java error.
     
  21. TonuStark

    TonuStark Member
    Rank:
    None
    Points:
    16
    Posts:
    42
    Joined:
    Jul 31, 2010

    Jul 31, 2010
    42
    2
    16
    Retired
    Vermont
    My daughter is 1000 miles qwqy having this issue after I helped her update to 2.2. Is allshare an installed app. I've been rooted so long I don't remember?

    Has anyone found a more to the point resolution to the problem?
     
  22. seepage

    seepage Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    442
    Joined:
    Aug 16, 2010

    Aug 16, 2010
    442
    30
    43
    I notice that those of you who list a phone in your profiles have samsung captivates. Perhaps you would have a better chance of an answer in the captive forum.
     
  23. dbvirago

    dbvirago Member
    Rank:
     #1,190
    Points:
    16
    Posts:
    69
    Joined:
    Jul 11, 2010

    Jul 11, 2010
    69
    3
    16
    Having exact same symptoms on Droidx. Have disalbed all other devices that I can. Some are on the list regardless. To the later posters, What is allshare?

     
  24. ksaichandra

    ksaichandra Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Mar 9, 2011

    Mar 9, 2011
    2
    0
    5
    I had the exact problem as that of yours. I upgraded my galaxy S from eclair (2.1) to Froyo (2.2). My Wifi was never connecting and even though it did, it was not recieving any data from the web. This may be the case for many others too. If you/ users with same prob haven't yet gotten through with this, then there is a simple solution.

    Follow these steps:

    1.Apps>Settings>Wireless and network>Wi-Fi settings
    2. Press the menu key on that page (left most bottom hap key)>advanced
    3. Select Static IP
    4. Now enter the IP address, gateway, Netmask, DNS1 and DNS 2. You can find these numbers on your computer by typing cmd (dos command prompt) in the Run and then check youre IP settings. Type ipconfig in the cmd prompt. It will tell you the exact IP address. Make sure the last digit in the IP address is different from that of your PC. Else it will result in a conflict. Typically, the Static IP data on your Galaxy S will have to be like

    IP Address: 192.168.3.8 (the last digit will be that of your PC/ devices that you are using. It has to be diff for your smartphone)
    Gateway: 192.168.3.1
    Netmask: 255.255.255.0
    DNS1: 192.168.3.1
    DNS2: 192.168.3.2

    Try!! Good luck!
    It worked for me though...!
     
  25. shazz1991xoxo

    shazz1991xoxo Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 26, 2011

    Apr 26, 2011
    1
    0
    5
    thanx alot that worked great x
     

Share This Page

Loading...