1. Are you ready for the Galaxy S20? Here is everything we know so far!

wifi problems

Discussion in 'Android Devices' started by richard.tufty, Feb 10, 2011.

  1. richard.tufty

    richard.tufty Newbie
    Thread Starter

    Just got my Evo. and I am loving it, however I do have an issue with WiFi and the phone that I am hoping someone can help with.

    The phone mostly works just fine on wifi, very fast, especially compared to my old iPhone 3g. However, if I leave the phone alone for an hour or two, it will still show WiFi signal bars but it won't use the connection, thus no email notifications etc. The only way I have found to get it back to life is to turn the WiFi off and on again, then it works fine until I leave it alone again.

    Has anyone else experienced this and know of a fix?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. jimdroid

    jimdroid Android Expert

    richard,
    Try this. Go to any home page, press Menu->Settings->Wireless & Networks->Wi-Fi Settings->Menu->Advanced->Wi-Fi Sleep Policy->Never
     
  3. akazabam

    akazabam Android Expert

    There are a few things you can look at, but start with this. Go to menu->settings->Wireless & networks->Wi-Fi settings, then press menu and select advanced. Select Wi-Fi sleep policy, and set it to never. That will prevent wifi from going to sleep when the phone is inactive.

    EDIT: jimdroid beat me to it :)
     
  4. jimdroid

    jimdroid Android Expert

    but you had a better explanation :) Thanks!
     
  5. dzar

    dzar Well-Known Member

    Changing the sleep policy to "never" does not solve this problem. That's how I've been configured for a year and when the last OTA update came down (a few weeks ago) I started having this problem, too. It doesn't bite me regularly, however. But a couple times a week I will see it happen. I've had it happen at home and at work so it's not tied to a single access point or anything like that. It just stops talking over WiFi for some reason.
     
  6. Mr. Ed

    Mr. Ed Extreme Android User

    Download spare parts and change the policy to never within spare parts. Also make sure the" notify of new networks" is unchecked in the wireless network settings. The ONLY times this has happened to me was when the policy was not set to never...or an app was interfering (timeriffic tasker etc...look at your apps permissions)
     
  7. richard.tufty

    richard.tufty Newbie
    Thread Starter

    Thanks for the replies, sadly when I got a chance to test it just now, it was already set to Never under the Wifi options...

    Going to try the Spare Parts option now and see if that's any different.

    Here's hoping!
     
  8. jimdroid

    jimdroid Android Expert

    Good luck! Also, if it isn't already, turn off the setting for "Network Notification" and try that.
     
    Mr. Ed likes this.
  9. richard.tufty

    richard.tufty Newbie
    Thread Starter

    Hmmm, I thought Spare Parts had fixed it, but sadly not.

    Is it likely to be a hardware issue, just got the phone as I like it and taking it back for a replacement that is not likely to cure the issue is not 100% appealing!

    Any more hints gratefully received!

    Richard
     
  10. Mr. Ed

    Mr. Ed Extreme Android User

    does your router have any time out settings? what else does not work? does it load web pages?

    I know text messages and picture mail still go through 3g even when connected to wifi but I don't know about email
     
    richard.tufty likes this.
  11. richard.tufty

    richard.tufty Newbie
    Thread Starter

    Router seems to be fine (however my only evidence for this is that no other device in the house has issues, such as laptops, wii & wife's iphone etc) and I can't see any time out options in the settings.

    As for what else doesn't work, it's everything to do with data, such as web, app store browsing etc. I get very few SMS so not sure if I have missed any, but like you said, they should go cellular anyhow. No missed calls show up and I haven't had anyone tell me that they have tried to call me and didn't get through.

    I did wonder if it was DHCP related, but the phone won't work at all with a Static IP, it connects to the wifi and gives full signal bars, but refuses to use the connection (even with DNS servers set to my ISP's IP numbers rather than letting the router farm them out) so I can't confirm that DHCP is anything to do with the issue. In fact, when set to static, the symptoms are identical to my original issue.

    I did the Update profile from the phone settings and that might have made it slightly better, but it still fails several times a day, so it may be a placebo effect!
     
  12. Mr. Ed

    Mr. Ed Extreme Android User

    hrm...if you are having sms, call and vm issue there is something bigger going on here. Those don't travel through wifi even when you are connected to wifi..those go through the 3g connection (actually at the slower 1x connection)

    I would stop by a repair store and explain all of the issues to them. It's like your radios are all going into a sleep mode/malfunctioning
     
  13. richard.tufty

    richard.tufty Newbie
    Thread Starter

    I think the problem is fixed.

    I took the phone to a Sprint store on Saturday morning (they could learn a thing from Apple on customer service I can tell you) and the result was that there were no faults. My Evo stayed connected to their instore wifi for 6 hours.

    Upon getting my phone back home I trawled through the router settings one more time. I have a piece of junk Motorola cable modem/router that was supplied by Cox Cable (an SBG900), and I found that the DHCP lease time was set to a value of 3600. I had always assumed this was minutes, turns out it's SECONDS... As I understand it, this essentially means that once every hour, the router resets the IP address of every device on the LAN.

    I then finally got around to installing an external router that I purchased ages ago because I have never been happy with the SBG900 firewall abilities, but never installed properly due to the earache from my wife about how long the internet was down for during my experiments (NAT and DHCP with 2 routers took me some time to figure out). Well, she was out last night, so I took the opportunity to play!

    Since then, I have had no dropouts and even get a better signal strength from the new router. I'm not sure if it's some random feature the new router or the fact that it will let me set a lease time of 1 week that has improved things, but things are definitely better. Also, it's odd that the only device on the network that had problems with a 1 hour lease was my Evo (3 PCs, a Macbook, a Wii and Mrs Tufty's iPhone coped fine), so maybe it was the router not the lease time.

    Anyway, to summarise the long post above, if you have wifi problems and a Motorola SBG900 modem/router, try increasing the lease time or replacing the router with an external one (and increasing the lease time as well!).

    Thanks for the help offered in fixing this issue, it looks like Mr Ed. nailed it but I didn't spot the setting the first few times around!

    Richard
     

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...