1. Are you ready for the Galaxy S20? Here is everything we know so far!

WIFI problems.

Discussion in 'Android Devices' started by geminisign, May 15, 2011.

  1. geminisign

    geminisign Lurker
    Thread Starter

    Hi everyone. I've had this phone for about 2 weeks, and it has always had a problem with my WIFI network.

    my network is secured with WPA2.

    My phone has no problem finding the network, but when i try to connect it just says: "remembered, secured with WPA2" and nothing happens or "connection unsuccessful, try again"

    When i click on the network again, i choose "connect" but it keeps on doing the same and disconnects.

    I tried resetting the phone, the router and re-entering the password. But it is stil the same!When i make my network an open network and then try connecting, it just says "disconnected" under "WIFI"...

    Does anyone know what is wrong? Thanks.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. HaN6787

    HaN6787 Member

    Dunno about WPA2, but my X8 works well with WEP.
     
  3. evil nemesis

    evil nemesis Newbie

    dude you need to repair your software through SEUS
     
  4. gabeyong

    gabeyong Android Enthusiast

    Hi,

    X8 doesn't work with WPA2 --> only works with WPA2 Personal.
    suggest you use WEP.

    cheers :)

    @evil nemesis - there is nothing wrong with the X8 software.

    X8 Hardware Reference:
    security: Open, Open WEP, Shared WEP, WPA Personal and WPA2 Personal
    channel range: 1-10
     
  5. Dexter_prog

    Dexter_prog Newbie

    After having lots of disconnects I think I got it. I set my router to only use 11g mode only (no bgn mix, no, gnmix, etc). I am using WPA 2 PSK and so far, no disconnects for like 3 or 4 hours (previously I had disconnects every 30 or so minutes)

    edit: hmm, it seems that what I said is not quite right as I am still facing disconnections. Weird.

    ps: I tried WEP and the phone wouldn't even connect. It wasn't even listed in my routers statics of assigned IPs
     
  6. adastro

    adastro Lurker

    I have a Xpeira Arc S and had problems dropping the wifi connection. After an upgrade of firmaware the phone stayed connected.
    BUT after that, everytime I have had my router/modem powered off, the phone won't connect when I power on again.

    To get connected again I have to:

    1) Disable the WIFI security of the router so it is open (no problem connecting)

    2) Put the secutriry settings back [WPA/WPA2-Personal(PSK), WPA-PSK, TKIP+AES]

    The everything works, until next time I power off and on the router/modem.

    My Belkin model is # F5D7633-4
    The firmware upgrade i used was version: 1.00.17, OS compatibility: Any from Belkin : Support F5D7633au ADSL2+ ROUTER W/MODEM * 802.11g - Firmware Update

    As I don't want my router powered on 24/7 please anybody, is there any permanent solution??
     

Sony Ericsson Xperia X8 Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...