1. Download our Official Android App: Forums for Android!

Wifi problems.

Discussion in 'Android Devices' started by zms123, Jan 11, 2012.

  1. zms123

    zms123 Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    67
    Joined:
    Nov 19, 2011

    Nov 19, 2011
    67
    5
    16
    A few weeks ago when I had no school I flashed Checkrom and everything worked. When I came back to school I was unable to connect to the secure wifi connection of the university but I was able to only connect to the unsecure connection. I have no problems connecting to any other wifi connection. The phone starts trying to connect to the secure connection and then it disconnects right away. It does this every time. Before flashing Checkrom I was on 2.3.6 stock. My school says that to connect you most likely need to be on 2.3.3 or above so I thought it might have been CheckRom but CheckRom is based on 2.3.6.

    Any solutions or ideas other than wiping my phone.
     

    Advertisement

  2. ironass

    ironass Android Expert
    Rank:
     #20
    Points:
    1,343
    Posts:
    11,461
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    11,461
    5,683
    1,343
    Male
    Keeping one step ahead of the tax man.
    Cotswolds, England
  3. Hawker

    Hawker Android Expert
    Rank:
     #57
    Points:
    433
    Posts:
    4,095
    Joined:
    Aug 2, 2011

    Aug 2, 2011
    4,095
    1,911
    433
    Male
    UK
    l14m3 likes this.
  4. ironass

    ironass Android Expert
    Rank:
     #20
    Points:
    1,343
    Posts:
    11,461
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    11,461
    5,683
    1,343
    Male
    Keeping one step ahead of the tax man.
    Cotswolds, England
    Good shout hawker!

    Give that a try first before considering a wipe.
     
  5. Hawker

    Hawker Android Expert
    Rank:
     #57
    Points:
    433
    Posts:
    4,095
    Joined:
    Aug 2, 2011

    Aug 2, 2011
    4,095
    1,911
    433
    Male
    UK
    Its certainly worth a go, although its more to do with connection dropping, rather than not being able to connect at all.
     
  6. zms123

    zms123 Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    67
    Joined:
    Nov 19, 2011

    Nov 19, 2011
    67
    5
    16
    Thank you so much. It worked perfectly. I think its because of 802.1 x EAP protection that my school uses which caused the problem.
     
  7. zms123

    zms123 Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    67
    Joined:
    Nov 19, 2011

    Nov 19, 2011
    67
    5
    16
    had to rebump this as now I'm on v6 of checkrom and the wifi fix given to me in this thread doesn't work that well. I've noticed trouble connecting to wifi (it sometimes takes multiple turn on/off wifi to work) 802.1x network (MSCHAPV2). Someone on the checkrom thread on xda said there was a wifi fix for the v6 of checkrom. I couldn't find it. Do you happen to know where it is Hawker?
     
  8. daffyduck

    daffyduck Guest
    Rank:
    None
    Posts:
    0
    Joined:

    Did you do a complete wipe before upgrading the ROM, or as I am guessing, just upgraded through KitchenPro?

    Sometimes I find its good to start from a clean sheet, especially if things start to not work properly. Just do a titanium backup of your apps, do a nandroid and its not that much hassle.

    But try to fix first....I don't use CheckRom so can't help you....can't say i've had many problems connecting to wifi though recently.
     
  9. obivine

    obivine Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Nov 10, 2011

    Nov 10, 2011
    4
    0
    5
    Need help. How do i make use of the wifi fix, downloads as a zip file.
     
  10. Hawker

    Hawker Android Expert
    Rank:
     #57
    Points:
    433
    Posts:
    4,095
    Joined:
    Aug 2, 2011

    Aug 2, 2011
    4,095
    1,911
    433
    Male
    UK
    Here you go butty. WiFi fix for CRR6

    you need to boot up into cwm recovery and install it from there
     
    obivine likes this.
  11. zms123

    zms123 Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    67
    Joined:
    Nov 19, 2011

    Nov 19, 2011
    67
    5
    16
    Ty. And I did do a full wipe. I think this is a known problem.
     

Share This Page

Loading...