1. Are you ready for the Galaxy S20? Here is everything we know so far!

Wifi repeatedly drops (not DNS, not ISP, not router)

Discussion in 'Android Lounge' started by Berder, Dec 19, 2021.

  1. Berder

    Berder Lurker
    Thread Starter

    About every 10-15 minutes on average, my phone's wifi stops working, causing me to drop any ongoing connections etc. Turning wifi off on the phone and back on again makes it work, but 10-15 minutes later it will again fail.

    The specific failure is that the wifi remains connected but it says it no longer has internet access.

    What the problem isn't:
    • It's not the connection to the ISP. A computer connected to the same router never has the problem. Also when the problem occurs the phone even drops connections (SSH/VNC) to this computer, on the local network.
    • It's not a DNS problem. I tried setting a private DNS on the phone to Cloudflare's one.one.one.one server and this didn't solve the problem. Also, when the problem occurs, I can't ping 142.251.32.110 (IP address of google.com)
    • It's not a faulty router. I tried replacing the router with a different one and had the same problem.
    • It's not that the phone needs to be restarted. I tried that.
    • It's not that the phone is trying to switch between wifi and mobile data. Mobile data is turned off.
    Samsung a32 5g on Boost's network (T-mobile). I am suspicious that there may be some bloatware on the phone causing this problem, but I don't know what it would be or if there are any logs of network activity or app activity I could look at to narrow it down. I have disabled the "Network Companion" app, and tried a forced stop + deleting app data on the "Secure Wifi" app, neither of which had any effect.
     


    #1 Berder, Dec 19, 2021
    Last edited: Dec 19, 2021

    1. Download the Forums for Android™ app!


      Download

       
  2. Dannydet

    Dannydet Extreme Android User

    Could be the wifi module on the device itself.
    Have you tried different locations other than home?
     
    ocnbrze and mikedt like this.
  3. mikedt

    mikedt 你好

    Never heard of them. I have a Samsung phone myself and it doesn't those apps. "Secure WiFI", that sounds like a VPN app or service. Is it a carrier version A32 you've got there, like Boost or T-Mobile?

    Think you've already tried everything, so it could be there's a problem with the phone's WiFi. A hardware fault that needs repair or replacement?
     
    #3 mikedt, Dec 19, 2021
    Last edited: Dec 19, 2021
    ocnbrze and Dannydet like this.
  4. Berder

    Berder Lurker
    Thread Starter

    Edit: the following is probably not correct, bVNC is probably not the problem.

    I think the problem may have been the bVNC vnc client app I was using, as I've noticed the problem mostly occurs either when using VNC or when having a VNC connection in the background. I have switched to the "VNC Viewer" app and now I've gone several hours without losing my connection. Although it's possible that disabling "Network Companion" or "Secure WiFi" was what fixed it but took some time to take effect. But probably it was bVNC, which is too bad since bVNC is much more configurable and full-featured than VNC VIewer.
     
    #4 Berder, Dec 19, 2021
    Last edited: Dec 20, 2021
    ocnbrze likes this.
  5. Berder

    Berder Lurker
    Thread Starter

    Well, it happened again even after switching to VNC Viewer. So bVNC was not the problem. It does seem to be happening a lot less now than it had in the past - only every few hours - so maybe something I did improved matters somehow. But I couldn't say what. I stopped using VNC over SSL which might have done something - instead using an SSH tunnel now.

    mikedt, yes, it's a carrier version of the phone - Boost installed a bunch of junk apps on it, and so did Samsung.

    Maybe it's a hardware problem. I could see if the android system logs say anything. If I care enough then I could try capturing packets to see if anything weird happens at the time the connection drops.
     
    Dannydet likes this.
Loading...

Share This Page

Loading...