1. Are you ready for the Galaxy S20? Here is everything we know so far!

WiFi "saved" but not connecting

Discussion in 'Android Devices' started by crankerchick, Apr 11, 2012.

  1. crankerchick

    crankerchick Android Enthusiast
    Thread Starter

    This has happened to me twice now trying to connect to a WiFi access point. My device sees the access point. I tap to connect, enter the key, and the status goes to "saved, secured with WEP" but it NEVER actually connects to the network (no WiFi icon on the notification bar and no data connectivity). If I long press on the network and tap "connect" it's the same thing. If I long press and type "forget" and do it all again, same thing still.

    This isn't exclusive to my Galaxy Nexus, as it happens on my Xoom as well, on the same wireless networks so far. My WiFi "works" fine when I connect to some networks but has this problem I'm describing on some others. I know it could be a slew of things (like for example MAC address permissions with the router), but these are generally free wifi in businesses or just a friend's network whom I know doesn't do any MAC addresss permissions-type security. I think it has even done it once on an unsecured network.

    I do usually restore all my wifi keys using TiBackup after a wipe, but I can't see how this would make any difference.

  2. Best Answer:
    Post #2 by colchiro, Apr 11, 2012 (1 points)

    1. Download the Forums for Android™ app!


  3. colchiro

    colchiro Extreme Android User

    If you use custom roms, restoring wifi keys via TIBU is asking for trouble. I love wifi key recovery tho. You can use that to export your keys to your sdcard.

    Does any wifi work for you (like home) or do they all fail?

    Do you have an app that turns wifi on/off when you're near previously accessed wifi locations (like Y5 battery saver)? I have to turn that off when adding a wifi point until it connects or I'll get disconnected before it finishes. When I get it to work, I can turn Y5 back on.

    Many public access points require you to "agree" to something when you first open your web browser. After that your internet apps will work.
  4. crankerchick

    crankerchick Android Enthusiast
    Thread Starter

    Interesting. I know restoring some system settings when changing ROMs is bad, I just didn't think the wifi access points would fall into that category. It's just loading the data only, but in any event, mayhaps that is part of the problem. I used to not store them, because google backs them up, but at some point with ROMs on my Droid, my google backup failed and I lost my passwords so I just started backing them up. I'll check out the app you mentioned instead.

    I do use SettingProfiles to automagically turn my WiFi on at home, so I will also try disabling that the next time this happens. It is noteworthy, though, that I have had the same "problem" on my Xoom and that doesn't have any auto-wifi turn on/off apps on it.

    Some networks I am able to connect to with no issue, but then sometimes I have this problem. When it happens, it is usually on my Xoom, then I pull out my phone to see if it is able to connect, only to find it has the same issue.

    My experience with sites that require you to accept some terms on their web page has always been that your device shows you connected to the access point (the wifi icon appears in the notification bar) since you are indeed connected to the access point. The bars just don't change colors (because google services aren't connected) and you can't use the data network yet. Once you accept the terms then bars will change colors.

    When my devices have this problem, I'm never even connecting to the access point. The settings don't show "connected" for that access point in the list, but instead reads, "saved, secured with WEP" so it's like I'm never even connecting to the access point. I never see "Obtaining IP address" or any of that.
  5. colchiro

    colchiro Extreme Android User

  6. Tim K

    Tim K Android Expert

    Is your Xoom running ICS?
    What kind of router do you have? I've seen plenty of issues in the past with certain routers just not playing nice. I wonder if the other places you have trouble run the same router/brand....
  7. crankerchick

    crankerchick Android Enthusiast
    Thread Starter


    My router is the standard issue Verizon FiOS router. I have no problems with my router at home. I have no problems with some access points in the field and not with others.

    If it is a problem with some routers in the field, I guess I'll know never know the fix since I don't usually have access to those routers to see what it is about them that my xoom doesn't like.

    I think I'm going to try a wipe and not restore my WiFi passwords using TiBackup. I can test this at my friend's house the next time I go over.
  8. colchiro

    colchiro Extreme Android User

    Try wiping the wifi profiles first... much easier. :D
  9. Trooper

    Trooper Android Expert

    I've seen this happen myself with the Gnex and other phones. In my experience, its the router itself. Update the firmware and try again.
  10. psycho_maniac

    psycho_maniac Member

    I had this problem with a specific router. Not sure why though. Switched rotuers and I haven't had the problem since.
  11. Pascal333

    Pascal333 Lurker

    I just got my Nexus and at the moment do not have service.
    I thought I could use WiFi as I have on many other phones, including my Galaxy SII, Galaxy Fascinate and Captivate, iPone, etc. But I can not make a connection on either of two routers I have at home. At either high or low frequency. N or G. I have the Cisco e4200 on cable and a Verizon router on DSL. Neither router filters for MAC or anything else except the correct security. My Nexus "sees both routers clearly and shows strong signals until I try to connect, and then they do not get an IP and keep searching.

    On other Sammys I either use or have used, as best I recall, there were two places on the phone to activate wifi and both had to be ON. One in setup and one accessed by exposing the icons at the top of the phone...wifi, BT, GPS, etc., but I find only one on the Nexus. Am I missing one? This phone is entirely stock (I think..I got it as NEW on eBay so I can't be 100% sure but the app all look stock google.

    Any ideas would be appreciated. LOTS ;-)

    If there is a long answer or one not of general interest, my email is [removed]

    Thanks :)
  12. Tim K

    Tim K Android Expert

    There's only one setting under Settings> wifi. If its on - its on.
    Is the frequency band set to AUTO?
  13. Pascal333

    Pascal333 Lurker

    Yes, the frequency is set to auto. Any other hints? (fingers crossed) ;-)

    I saw a couple of posts whee users said they had good luck getting wifi by setting the IP of the phone. I do not see anyway to do that. So am I just stuck with a bad design? I did get wifi when I had a verizon connection. And I not that many apps say they need a DATA connection... does that mean they do not work without data from Verizon? I have not noticed that other Sammys said that. But then they worked straight away, so I was not looking for hints on how to salve a problem.
  14. Crashumbc

    Crashumbc Android Expert

    some general troubleshooting things try...

    First do you have security set-up on the wifi?
    if so can you turn it off for testing?
    Have you tried connecting to other networks? Mcdonalds,starbucks, a friends wifi?

    Have you tried rebooting the router?
    have tried "forgetting" the Wifi and re-enterning the info?
  15. Pascal333

    Pascal333 Lurker

    I followed your check list and connected at a friends, so investigated my router further. Found that somehow it had gotten set to reject unlisted MAC addresses. No idea when or how that happened. Maybe it was part of the auto setup(?) or maybe I accidentally set it while looking around in the settings. In any case, the router was the culprit, not the phone?

    Fixed that and now am running just fine. :dancing:

    Curious: Is there a way to set the phone's IP in the phone?

    Thanks for the suggestions... The help at this is great and
    much appreciated. :shakehands:
  16. Crashumbc

    Crashumbc Android Expert

    GOOGLE saves the day!

    Go to settings->wireless and networks->wifi settings. Then long press on your network and select "modify network" then where you see "IP settings" change from DHCP to Static, and then you're set! Hope this helped :)

    this is off a xoom forum, it looks like we have to also check "advanced settings" at the bottom.

    I didn't actually set mine, but I got to the screen so it should work!
  17. colchiro

    colchiro Extreme Android User

    I removed your email address.... that's just asking for a bunch of spam. :D
  18. tjdanie

    tjdanie Lurker

    Same issue for me - any solution? This is for a WEP security used. Earlier conections it was working fine.
  19. mogelijk

    mogelijk Android Expert

    One thing to check is if your WiFi is hidden as part of the security. This has been known to cause problems for devices trying to connect. The solution is to "unhide" your WiFi; it doesn't help with security so there is no reason to have it hidden.
  20. same problem happen with me But not regularly sometimes it show that "saved,secured with web"
    even I try again and again to connect that not connect
  21. rumana

    rumana Lurker

    A wifi network connection shows in my mobile that is aironet S2 and aironet S3 but i m not able to connect to it as it gets saved however i try i also tried to modify networt n change DHCP to static then i need to put ip address in it so what will the ip address? I hav no idea about it pls help
  22. Jaines

    Jaines Lurker

    I recently traveled to Bangkok. As soon as I reached the airport, there's free wifi and my Nexus 5 phone connected automatically, but then I could not connect to the internet.. When I reached the hotel, the same thing happened. The phone connected to wifi immediately and saved the address, but then I could not connect to the internet.. The thing here is, the phone did not prompt the password for the wifi (in both cases). The wifi at the airport and the hotel should prompt password but immediately the phone connected and saved without asking for the password. I've tried all I could think off - forget password, try again and again, wiped all saved connections, modify the setting.. Did not work.. In case this happens again, what should I do?
  23. rajaonlinegbc

    rajaonlinegbc Lurker

    Here is what fixed it on my Android/Cyanogen machine. It is related to Google Locations:
    On the main screen, swipe down to select the Gear icon (Settings)
    Select Wifi and make sure it is On
    Select the 3 vertical dots on top right
    Select Advanced
    Turn OFF "Scanning Always Available"

    This resolved the problem for me
  24. tube517

    tube517 Android Expert

    I bet your date and time settings were not correct (since you were travelling). This can mess up wifi connections.
  25. Joja33

    Joja33 Lurker

    reset your router turn it off wait 30 sec to a minute turn it back on it should work just fine

Galaxy Nexus Forum

The Galaxy Nexus release date was November 2011. Features and Specs include a 4.65" inch screen, 5MP camera, 1GB RAM, TI OMAP 4460 processor, and 1750mAh battery.

November 2011
Release Date

Share This Page