1. Are you ready for the Galaxy S20? Here is everything we know so far!

WiFi shuts off spontaneously. Android 6.0.1.

Discussion in 'Android Lounge' started by Dan Smith, Jun 14, 2017.

  1. Dan Smith

    Dan Smith Lurker
    Thread Starter

    Samsung Galaxy Luna. Device name SM-S120VL. Android version 6.0.1.

    WiFi stays on as long as I stay within WiFi range of home, but spontaneously shuts off after I leave home and does not automatically turn on again when I return home.

    Settings, Wi-Fi, On; MORE, Advanced, Keep Wi-Fi on during sleep: Always.

    Battery, power saving mode, Off. Ultra power saving mode, Off.

    Settings, Data usage, Mobile data: doesn't matter. If Mobile data is on, then it switches to LTE. If Mobile data is off, then it simply disconnects from the network. Either way, Wi-Fi gets turned off and does not get turned on when a Wi-Fi signal is available.

    Settings, Location, On. Locating method: GPS only. Improve accuracy: Wi-Fi scanning off, Bluetooth scanning off.
     


    #1 Dan Smith, Jun 14, 2017
    Last edited: Jun 14, 2017
  2. Best Answer:
    Post #2 by deluco, Jun 14, 2017 (1 points)

    1. Download the Forums for Android™ app!


      Download

       
  3. deluco

    deluco Lurker

    I'm having exactly the same problem...same android version on Samsung S5. It just started happening and I can't recall any recent changes or new apps added. I've checked all the logical settings (as Dan states above). Nothing obvious. Keeps shutting wifi off...turning it back on ... randomly and not logically. Does not automatically connect when I get home to my home router. Sometimes it just turns back on and connects on its own.
     
  4. deluco

    deluco Lurker

    The only thing that seemed to work was to turn the "Smart network switch" to off. When on, it is supposed to automatically switch back and forth between mobile networks (data) and wifi. The problem is that it didn't do that ... not consistently. I have a wifi router in my home and it seldom would connect to that unless I forced it.
    Now with that switch off it only switches to mobile networks when the wifi is not available.
     
  5. deluco

    deluco Lurker

    Well, I thought it worked but it didn't. Wifi continues to turn off and on randomly and even while I'm at home with my wifi router within ten feet, it does not automatically turn on and connect. It stays on 4g data.
     
  6. Tonyaigunter

    Tonyaigunter Lurker

    Its an easy fix. Log into your router and create a guest log in. Connect to it with the device having trouble and it should fix the issue.
     
  7. Dan Smith

    Dan Smith Lurker
    Thread Starter

    Why would using a guest account make a difference? I don't want to do that because the guest account has no security.
     
Loading...

Share This Page

Loading...