1. Download our Official Android App: Forums for Android!

Support Wifi stays awake even though I have it set to sleep

Discussion in 'Android Devices' started by lickwidravr, Aug 22, 2013.

  1. lickwidravr

    lickwidravr Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    88
    Posts:
    310
    Joined:
    Nov 10, 2011

    Nov 10, 2011
    310
    380
    88
    I haven't been able to find a solution or even a topic regarding this but both mine and my fiances S4's have extreme battery drain if we leave Wifi on and we aren't connected to a wifi hotspot. We both had wifi set to not be "awake" when its off of the charger and it just destroys battery, stays awake all day.

    When we check battery usage it shows a solid blue bar for wifi awake and our phones even stay warm.

    Any solutions besides having it never be awake?

    Verizon GS4 one is white one is black
     

    Advertisement

  2. ScandaLeX

    ScandaLeX Wasn't Me
    Rank:
    None
    Points:
    223
    Posts:
    3,829
    Joined:
    May 4, 2010

    May 4, 2010
    3,829
    966
    223
    Female
    PhiLLy
    I got nothing but someone may be able to help you out.
     
  3. Adara

    Adara Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    275
    Joined:
    Nov 13, 2009

    Nov 13, 2009
    275
    39
    43
    I feel like a total dolt here, but I don't see where you can set it to do that. (Which is to say, I don't see it as a wi-fi setting or under one of the power saving modes.) If you've got it set up to do that via tasker or something, maybe there's a problem in that app. ???

    In any event, there is certainly a solution besides never having it be awake. You can turn Wi-Fi on manually when you want, and off when you don't. I even downloaded myself one "Wifi Toggle Widget," which sits happily on my home screen* -- and just hit it to turn Wifi on or off. I particularly like it as it is color-coded -- green when on; red when off. Simple as pie, and that way I always know if my wifi is on (wasting battery) looking for a network when there isn't one.

    *Eagle-eyed readers may note I was recently opposed to such toggle widgets. But I picked up the Bluetooth one, and it worked so perfectly, I followed up with the Wi-Fi to save myself some screen-taps.
     
  4. lickwidravr

    lickwidravr Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    88
    Posts:
    310
    Joined:
    Nov 10, 2011

    Nov 10, 2011
    310
    380
    88
    Wifi>Menu Key>Advanced> "Keep Wi-Fi on during sleep: 1-Always, 2-Only when plugged in, 3-Never (increases data use)

    My issue is when its set to option 2-Only when plugged in, it still stays awake 24/7 an keeps the phone awake which drains battery.

    No third party app is being used here, on all of my past Android phones (10+ multiple manufacturers) having this option set would allow Wi-Fi to sleep when i'm not using the phone, aka not looking for any connection while it's sitting in my pocket or on my desk unused.
     
  5. Adara

    Adara Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    275
    Joined:
    Nov 13, 2009

    Nov 13, 2009
    275
    39
    43
    Got it. Thanks for explaining.

    (In that case, ... I got nothing.)
     
  6. Goodspike

    Goodspike Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,144
    Joined:
    Dec 28, 2010

    Dec 28, 2010
    1,144
    143
    143
    Male
    Seattle
    Do you have "Notify me" checked in the Wi-Fi settings? If so, have you tried unchecking that?
     

Share This Page

Loading...