1. Are you ready for the Galaxy S20? Here is everything we know so far!

Wifi suddenly goes off when screen is off

Discussion in 'Android Devices' started by st230, Aug 14, 2012.

  1. st230

    st230 Member
    Thread Starter

    About a week ago my DHD running LeeDroid crashed a couple of times for no apparent reason and now the wifi keeps turning itself off in sleep mode, ie. when the screen is off. It usually seems to go off after a while, because if I switch off the screen and turn it on a short while later, wifi is still active. But if I wait longer (I can't say how much longer) then when I turn it on again wifi is off but goes on again by itself. I've tried switching off all power saving options, Tasker automation, etc etc but I can't prevent this from happening. And I never had this problem before. Normally I have Tasker automation in place that reacts on these events, which now are causing undesired things to happen as soon as the screen is off :( So my question is, are there any low-level tweaks that I can check that control these things and that may have been altered by the earlier crashes I had? Any hints are highly appreciated. :)

    1. Download the Forums for Android™ app!


  2. CDPlant

    CDPlant Android Expert

    If you go to Settings > Wireless Networks > Wifi and then press Menu, it should come up with an option called 'Advanced'. If you go in there, there should be an option called 'Wifi sleep policy' and switch it to 'Never'. This should stop it from turning off all the time.

    I think it was silly on Androids part to hide this option so deep in the settings, and a lot of people don't even realise there is an Advanced setting in there :(
    JohnDF1, D-U-R-X and st230 like this.
  3. st230

    st230 Member
    Thread Starter

    Thanks CDPlant, you just made my day! I had no clue about this settings menu and I agree that it's a shame it's hidden away like that. Oooh, great news! :)
  4. CDPlant

    CDPlant Android Expert

    Glad you're sorted! :D
  5. handyandy

    handyandy Newbie


    I was pleased to see your suggestion because I thought it would solve the problem of the proximity sensor turning off the screen, and the wi-fi, during Skype calls but found my HTC HD is already set to never switch off the w-fi. Seems the proximity sensor overrides this setting.

    Don't want to hijack the thread but if anyone has a solution to the Skype problem I would be grateful.

    There is a workround by pressing the back button once the Skype call is established but a permanent fix would be better.


HTC Desire HD Forum

The HTC Desire HD release date was October 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 768GB RAM, Snapdragon S2 processor, and 1230mAh battery.

October 2010
Release Date

Share This Page