1. Are you ready for the Galaxy S20? Here is everything we know so far!

Wifi Tethering inoperative (followed all posted fixes)

Discussion in 'Android Devices' started by LettuceFace, Aug 12, 2012.

  1. LettuceFace

    LettuceFace Lurker
    Thread Starter

    Hello all,

    Like many here and elsewhere, I've successfully unlocked and rooted my HTC EVO 4G. Yet when I turn on my wifi tether app the down and up stay at 0. I have gotten them to move a few times to as high as .4kbs for either up or down, but that isn't even close to the 1-4 mbs that I get with my 4g connection. The tether doesn't say that it doesn't have permission, it just doesn't work. I've tried every combination of settings--routing enabled/disabled mss clamping enabled/disabled profile generic ics/auto/htc evo 4g. I also tried back editions of the tether (both 2.0.8 and 2.0.7) and the most recent mikG rom just in case it was the android OS that was keeping it from working. I'm on Android version 2.3.5 If anyone can give me a hand I would really appreciate it. I rooted my phone solely for this function and I can't get it to work when everyone else seems to change one or two settings and everything runs perfectly. Thanks.

    -LettuceFace
     



    1. Download the Forums for Android™ app!


      Download

       
  2. LettuceFace

    LettuceFace Lurker
    Thread Starter

    And oh yeah, it's a sprint phone.
     
  3. Leslie Ann

    Leslie Ann Android Expert

  4. LettuceFace

    LettuceFace Lurker
    Thread Starter

    I'm using that app. That is the one that is malfunctioning

    And I'm using sprint.

    EDIT: Sorry, I didn't realize that I didn't put that in the title.
     
  5. LettuceFace

    LettuceFace Lurker
    Thread Starter

    Any ideas? This is a real drag.

    -LettuceFace
     
  6. Chingling

    Chingling Android Enthusiast

    Not sure man, not experienced with Sprint phones. Make sure the ROM doesn't have any bugs with Wifi tethering. Maybe even try reflashing the ROM.
     
  7. Leslie Ann

    Leslie Ann Android Expert

    Did you install it in system/apps or data/apps. System will cause it to crash. Also, be sure to use the app, NOT the built in tether (they look similar). Be sure to change those settings, and it should work. Make sure you get that beta version linked, NOT the one on Play Store.

    If it still won't work, then it could be something with your rom.

    Oh, and do you mean a Sprint labeled Evo V or Sprint service. There is no difference between Sprint labels and Virgin labels except the logo. There are some out with mixed parts even (Sprint and Virgin parts).
     
  8. mastersoup

    mastersoup Android Enthusiast

    my guess is he didnt read the post, and didnt change it to generic ics and enable router fix and clamping. both may not be necessary, but i have them both checked and it works for me.
     
  9. LettuceFace

    LettuceFace Lurker
    Thread Starter

    I'm not sure where it is, but I'll follow ur suggestions and report back. Thanks.
     
  10. mastersoup

    mastersoup Android Enthusiast

    depending on the version, you might only have routing fix. it should work fine.

    open the wifi tether app, go to settings, and at the very top it says device profile. change this to "generic ics device"

    then scroll down to router fix, and then make sure it is checked.
     
  11. xkravenx

    xkravenx Member

    I am having the same problem.
    Running midnight rom, everything seems to start fine. It get ip from dchp. But can't connect to anything.

    Have enable routing fix checked.
    Don't see the option for mms clamping under LAN with wifi tether for root.

    Do you guys tether in 4g or 3G?. Wonder what else it could be. I don't really tether but nice to have in case I need it.

    Update: was able to get it to work by using ad-hoc mode. Why does it work with others?.
     
  12. nameless1

    nameless1 Lurker

    Make sure the check box for connected/authorized clients is checked for each client connecting to your hotspot.
     
  13. mastersoup

    mastersoup Android Enthusiast

    and your profile is generic ics right?
     
  14. xkravenx

    xkravenx Member

    This only applies if you have access control enabled.

    Sure thing.
     
  15. xkravenx

    xkravenx Member

    UPDATE:
    Wifi Tethering is working fine with a Laptop using Wifi Tether for root with the routing fix checked + ICS Profile.

    Will test it with my iPad tonight. Maybe it was the iPad from the beginning.
     
  16. drachma

    drachma Newbie

    Op... I think you're on the wrong forum. You said your phone is EVO 4G running Android 2.3.5

    This forum is for EVO V 4G (virgin mobile with ice-cream-sandwich / android 4.0.3)

    WiFi Tether works for us who are rooted and use a custom rom. i.e. I use Midnight 1.1.9 and WiFi Tether (With generic ics selected + routing fix)

    I think the problem lies in the fact that you need to find a solution for your gingerbread 2.3.5 rom.
     
  17. xkravenx

    xkravenx Member

    Here is my update.
    On 3G wifi works as expected.
    On 4G tethering does no work. Download speed crawl like 10kbps while upload speed are normal. 1mbps and higher. Don't know what's causing this.

    At first I thought it wasn't working, but it turns out the pages just take forever to download because of the speed.

    So in conclusion tether on 3G. This test was done on a laptop and iPad 3rd generation.
     
  18. djdrma

    djdrma Well-Known Member

    So you have to pay virgin mobile to tether or it works with a app?
     
  19. xkravenx

    xkravenx Member

    No you don't have to.

    It would be awesome if it worked with 4g.
    But 3g speed with the evo are better than with the triumph
     
Loading...

Share This Page

Loading...