1. Are you ready for the Galaxy S20? Here is everything we know so far!

WIFI tries to connect to EVERY network when Im not home. AAAARRGGGHH!!!!!

Discussion in 'Android Devices' started by Connectz, Aug 8, 2012.

  1. Connectz

    Connectz Android Enthusiast
    Thread Starter

    Why is it that my VZW Gnex is CONSTANTLY trying to connect to WiFi networks I don't want it to???? This used to happen on my old EVO too. I'll be in the middle of listening to Pandora or using navigation and it will get interrupted because WiFi has automatically connected to some network along the way that I don't have access to. Then it takes time to get back on 3 or 4G.

    I want to leave WiFi on. I don't want to turn it off. I tried tasked and ON{X} and they only work sometimes.

    How do I fix this? Is there a setting I'm missing that tells the phone to not automatically try to connect to every network it detects?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. mogelijk

    mogelijk Android Expert

    The fix is simple: Turn Wi-Fi Off. If you leave Wi-Fi on it is going to try and find an open network to connect to.

    A possible work around would be to get a program like JuiceDefender Plus/Pro, which will turn your WiFi on and off for you, depending on your location.
     
    colchiro likes this.
  3. sean76

    sean76 Android Expert

    There is a setting that asks to tell you about open wifi networks.
     
  4. FramCire

    FramCire Android Expert

    Why do you not want to turn off wifi.? You don't want it to connect to wifi, so turn it off.

    Honestly, simple answer.
     
  5. Menddles

    Menddles Guest

    Settings>Wifi>Click in the 3 dots in the bottom right hand corner>Advanced>avoid poor connections
    That might help.

    Or, now I'm too sure about this, turn off the wifi when not at home. 75% sure that someone has said that though.</sarcasm>
     
  6. UncleMike

    UncleMike Android Expert

    As far as I know, android will automatically connect only to known networks (networks you have previously told it to connect to). Are you saying your device is connecting to networks you've never connected to before? If so, do these networks have the same SSID as one or more of your known networks?
     
  7. idic

    idic Well-Known Member


    People don't want to turn off WiFi because it is a useful location tool which doesn't require GPS and therefore saves battery. If you forget to switch it back on when you get home the extra battery you'll use on 3G will far outweigh the minimal use it had whilst on in the background during the day, saving battery again. It's really an unnecessary extra step. I've tested this myself, and really found o advantage in turning it on and off all the time, and there are several advantages to just leaving it on.

    Either of the solutions posted above will solve the OP's problem without just turning WiFi off...
     

  8. I see 2 options here...
    1) Turning of your Wi-Fi (which you clearly don't want to do)
    2) Everytime your phone connects to networks you don't want to connect to, go to settings->wi-fi settings-> and then, click on the network you're connected to and click on it and then click on the "Forget" button. This way, your phone won't connect to those networks that are "forgotten"... Helps?
     
  9. jj14x

    jj14x Android Expert

    @Menddles - I don't have an "avoid poor connections" option there - are you on the stock ROM? (GSM? CDMA?)

    @op On the Sprint GNex, there is a "network notification" checkbox in the advanced menu of wifi settings. (description is "Notify me when an open network is available")
    If that is available on your VZW GNex, uncheck that - does that help?
     

Galaxy Nexus Forum

The Galaxy Nexus release date was November 2011. Features and Specs include a 4.65" inch screen, 5MP camera, 1GB RAM, TI OMAP 4460 processor, and 1750mAh battery.

November 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...