1. Are you ready for the Galaxy S20? Here is everything we know so far!

WiFi will not turn on anymore

Discussion in 'Android Devices' started by PartyboobApril, Jun 13, 2017.

  1. PartyboobApril

    Thread Starter

    So, the S4 is my old phone. Older than the old phone I use now. Never had any problems with it, it just didn't meet the requirements of my mobile gaming addiction. I passed it on to a teenager I know and it worked perfectly for almost a year for him. He's never relied on REAL phone service for use of the phone, he's always used WiFi and our Xfinity account info for everything.
    Well, one day the WiFi shut off and he could never log back in. (He's since then given the phone back to me and I've replaced it with an LGK10 which he LOVES and I hated)
    Working with the S4 is.... pointless. Searching online forums has proved fruitless. When you click or long press on the WiFi symbol, the WiFi "attempts" to scan for nearby service, but it never connects. I never even get the option to chose my homes WiFi. I have even factory reset the phone. I'm interested in using this phone for my music and puzzle games, simply because...
    •my main phone has an SD slot that suddenly stopped working one day and the S4 can still read my card
    •I can multitask with 2 phones much faster with all my crap spread out between them both
    •I can possibly root one of them with the other remaining phone a back up in case I screw up

    So, how do I fix this? I just want to be able to sign in to WiFi again!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Grandliseur

    Grandliseur Lurker

    I may not have a solution; however, I have had a problem with connection also.
    The thing is, do you have another tablet / phone?
    My problem seems to occur because I try to connect when in a room where the Wifi is weak. This seems to crash the system even when I go right next to the Wifi dispenser.

    My tablet was new; so, this made me unhappy. Fortunately, I have another tablet, and it cannot connect either though not having had this problem in a distant room. Thus, I found out that once the crash occurred, both tablets were affected though only one caused it. This made me realize that my Wifi server had the problem. So, I rebooted, and waited about 40 min, and the server auto-fixed whatever the problem was. (I cannot understand what the problem might be).

    The point being that if you have another tablet, does it also have the same problem while your first one does? If they suffer from the same problem, you might have the same problem as I. Otherwise, it is your phone that is broken and needs to be looked at by a professional.

    Also, try to connect to another service, e.g. at your local library. If that doesn't work you kind of know where the problem is.

    If there are settings on the Wifi mode, you could try playing with them! Sorry for not being of more help.
     
  3. PartyboobApril

    Thread Starter

    No, all other devices work perfectly fine on the WiFi. It won't even let me enable WiFi to select the signal.... HOWEVER... it is so bizarre, because after posting my situation, I for some reason decided to turn on the S4 and play with the toggle. Immediately upon turning the phone on, I was notified of open WiFi connections! I could even select my homes WiFi! But, alas, I couldn't make it thru typing my password before it would switch off again, but that was definitely some sort of progress....
    Also strange; my SD card has been in the S4 for months now because my main phones Sd Card slot suddenly refused to acknowledge ANY SD card in it. Well, the S4 kept mounting and unmounting the card on its own. Afraid it would corrupt data or something, I decided to remove it and placed it in my main phones SD slot for safe keeping. Well all of a sudden THAT stared to work! My main phone hasn't detected an sd card for months and all of a sudden it does! I just don't understand it!
    So I just need to get the S4 picking up WiFi again.... does it matter that the S4 is not connected to any carrier? It was on straight talk when it was my main phone, but when I transferred my number to new phone, it became a "WiFi mode only" type of deal and worked just fine like that for over a year up until now.
     
  4. Grandliseur

    Grandliseur Lurker

    I'm afraid I cannot be much help to you, but I will let you know that I run Vipre antivirus on all my devices. At times, I have found it helpful when a device malfunctions. Of course, if you cannot connect, obviously, you cannot download that service either. I have had cases where the antivirus program seemed to clean the problem up.

    I hope someone else can give you more information. You could send it in for a repair job, but at times, it is as cheap to buy a new one.
     
  5. nu2andy

    nu2andy Android Enthusiast

    Hi PartyboobApril, More detail on your phone please. Samsung S4 - i9500? i9505? Is it locked to a carrier? Battery in good condition? Has it been damaged/dropped/immersed in water? Has it been dismantled by anyone? What Android version is it? Has it been "Rooted"?
    No. I have a spare S4 i9505 rooted and running CM13 (Marshmallow Android 6.0.1) and no SIM card installed and it runs 100% WiFi.
     
  6. PartyboobApril

    Thread Starter

    Hello nu2andy,
    When I go to the model number in About Device, it says it's SM-S975L....

    It's a Straight Talk phone, so as far as "locked to a carrier" it is, but I can still choose whatever carrier I want thru ST anyway..?

    And the battery is fine, it charges and dechares normally, I think once upon a time the phone MAY have fallen in the toilet because I forgot it was in my pajama pants pocket (cursed pj's) but an overnight in some rice, just to be safe, kept it working normally.

    Android Version 4.3, which was a drag even when the wifi WAS working... couldn't even download PoGo! But I believe that is because ST never intended on giving this phone new life.

    Dismantled, no.... Rooted, no.. altho I thought about rooting it, however, I can't connect to wifi. I refuse to purchase a sim card for it because it truly is a spare, junk phone , but to atleast have the wifi working on it again would allow me to use it for downloading music, or playing games... basically my "guinea pig" at testing my "rooting skills" because I've never tried doing that either.

    Anything else?
    Oh, also it seem the SD slot is acting weird too, because I HAD a chip in that read just fine, but lately the phone kept acting as if the chip was being taken out. I kept getting "The SD card has unexpectedly removed" or something like that. Honestly, I don't care about that slot, mostly just being able to connect to my wifi again!
     
  7. nu2andy

    nu2andy Android Enthusiast

    I think this is probably your problem. Unless the phone is completely dismantled and serviced correctly, there is no guarantee that rice will remove ALL the moisture. I would suspect that there is now a collection of corrosion causing your intermittent and erratic problems. The phone is 4 years old and really unless you have the expertise to carry out a full service and bear the cost of a logic board replacement - it isn't worth it.
    I've refurbished S4 phones and the problem is procuring parts at the right price. New boards are available but you need to ensure you get the correct one to fit your phone. SD/SIM card holders are available also, but is a 4 year old phone worth it???
    I've paid between $95 - $125 for logic boards and they have to be un-locked and suitable for your country of origin. Screen LCD/Digitizer assemblies are very dedicated to phone model and can cost between $115 to $150. Antenna and charging circuit units are also very dedicated to phone model and are usually under $10.
    I hope this gives you an idea that you need to weigh up very carefully what the current value of the S4 is to the cost of parts + labour (where I am that is about $75-80 per hour). Second hand S4's sell here for around $250.
     
    #7 nu2andy, Jun 15, 2017
    Last edited: Jun 15, 2017

Samsung Galaxy S4 Forum

The Samsung Galaxy S4 release date was April 2013. Features and Specs include a 5.0" inch screen, 13MP camera, 2GB RAM, Exynos 5410 Octa processor, and 2600mAh battery.

April 2013
Release Date
0
Reviews
Loading...

Share This Page

Loading...