1. Download our Official Android App: Forums for Android!

Support WiFi won't shut off?

Discussion in 'Android Devices' started by willowave, Sep 6, 2010.

  1. willowave

    willowave Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    49
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    49
    1
    16
    Computer Tech
    Sioux Falls,SD
    I'm not sure if I should have this in this forum or under another one...I can't turn my wifi off. Even in settings. I am running the skyraider rom.
    I went in a killed any tasks that I thought could cause a problem since it just started recently.
    Any ideas?
     

    Advertisement

  2. kylec

    kylec Member
    Rank:
    None
    Points:
    35
    Posts:
    35
    Joined:
    Aug 29, 2010

    Aug 29, 2010
    35
    0
    35
    boating
    CT
    You could check what your wifi sleep policy is. Go into settings>wireless and network>wifi settings. At this point hit the menu key again and select advanced. This will bring you to another screen and you can check your wifi sleep policy along with other settings. Keep in mind when you are not connected via wifi it uses up your data plan usage.
     
  3. najaboy

    najaboy Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    390
    Joined:
    May 3, 2010

    May 3, 2010
    390
    68
    53
    Which kernel are you using? Some people have had the same issue after installing the stock kernel after King's BFS kernel due to the phone still having King's wi-fi driver.
     
  4. willowave

    willowave Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    49
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    49
    1
    16
    Computer Tech
    Sioux Falls,SD
    Thanks for replying guys. Ok I'm going to answer you both in this post.

    On the wifi settings, I had checked that and I had it set to never. This is my first smart phone and I'm not clear on my wifi/3g stuff. So if I turn the wifi off, it automatically goes to 3g even if I have it turned off? I thought I had to switch it on. (I'm not too concerned about it cuz I'm always around wifi but this stuff is good to know : )

    Second on the kernel -
    I've got kernel 2.6.32.15, if you know which one that was causing problems that would be nice (or a link would be cool too) and how do I flash the kernel if I need to? I'll be doing some research I think.
     
  5. najaboy

    najaboy Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    390
    Joined:
    May 3, 2010

    May 3, 2010
    390
    68
    53
    It seems that the kernel may very well be your issue. I'm assuming you're on Skyraider 3.0 RC3?
     
  6. mstarbear

    mstarbear Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Aug 21, 2010

    Aug 21, 2010
    2
    0
    5
    I am wondering about the wifi settings as well. I read in one of these forums that you should have the wifi sleep policy checked to never. The signal strength in my home is terrible-always between -99 to -104. Does this mean if my wifi is not on that the battery is getting eaten up trying to get a 3g signal? I almost never have a 3g signal at home. My battery life seems to have gone down quite a bit since update. Maybe my wifi settings got changed? I'm certain that the battery drain has something to do with this. I would appreciate some advice!
     
  7. willowave

    willowave Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    49
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    49
    1
    16
    Computer Tech
    Sioux Falls,SD
    yep. it just updated...actually now that I think about it...that may be when it started this wireless problem.
    got any suggestions as to another ROM to try? I've tried virtuous, skyraider and plain old froyo.
     
  8. kylec

    kylec Member
    Rank:
    None
    Points:
    35
    Posts:
    35
    Joined:
    Aug 29, 2010

    Aug 29, 2010
    35
    0
    35
    boating
    CT
    Ok willowave, going back to the sleep policy. It is ideal to have your phone set to never sleep, on my captivate I can still turn wifi on or off even with the sleep policy to never sleep.

    And yes mstarbear if you have your wifi to never sleep and u are around wifi you want to use wifi instead of 3g. This is because of two reasons 1, your phone does drain a lot of battery if it is constantly seaching for 3g and 2, when u use wifi your data usage isn't being used. So u can save your data usage for when u really need it. You may also want to check the market for an app killer. For whatever reason apps will start running even if you didn't open them and this will drain your battery as well and lag your phone. It's like having a bunch of windows open on your computer. I use advanced app killer it's free and it works great on my captivate. There are other app killers as well some come with an uninstall tool some you can pay for. I don't like to use the uninstall one's because I don't want to uninstall an app by mistake. Besides my settings has that ability anyway.
     

Share This Page

Loading...