1. Are you ready for the Galaxy S20? Here is everything we know so far!

Will the SD card ever work? Please help a fellow user.

Discussion in 'Android Devices' started by Webnaut, Jan 1, 2013.

  1. Webnaut

    Webnaut Lurker
    Thread Starter

    If anyone would please help me, I would greatly appreciate it. I tried to be thorough in describing my problem and so the post became quite lengthy. Again, thanks to those who could offer any solutions.

    I recently got my Spring Samsung Galaxy S3 set up with a 64 gigabyte Sandisk mircosdcx card. The phone initially recognized the card right when I put it in, but then the problems start when I try to transfer data into the external SD card through three ways that all eventually fail. I am using Windows Explorer through Windows 7 and Vista in turn for every instance.

    First, I turn off the phone, I take the SD card out, and connect it to the computer with an adapter. I transfer music, movies, and games into it and put it back into the phone after ejecting it or safely removing it. ES File Explorer will show nothing, I turn off the phone, connect the SD card to the computer, and everything is there. I completely format the card with Panasonic's SDFormatter and put it back into the phone. Oh, now ES File Explorer can recognize its contents since I see "LOST.DIR" in the external SD card, but all of my data is gone.

    Second, I dismount the SD card and do all of the above. Through ES File Explorer, the phone will either show absolutely nothing in the external SD card or will show all of my folders with no files or sub directories in them before going ahead and showing nothing at all. I format the SD card again and put it back into the phone.

    Third, I connect the phone to the computer with the USB cable that came with the device with the SD card inside. I transfer data into the phone through Windows Explorer and unplug the cable straight from the phone when it is finished (since there is no "eject" or "safely remove" option). I check out my data and see that everything is there and in working order! I try doing this again and again until the computer tells me that the device suddenly is no longer connected or communicating to it. I unplug my phone and access the external SD card through ES File Explorer, and lo and behold everything is gone or disappears within 2 minutes of me accessing a working song or movie. Powering off and on or restarting the phone will show the data again until it evaporates back into the ether within a few moments.

    Now I would love to take advantage of this powerful phone by making this basic process work correctly. All I want to do is transfer files to the external SD card like I have always done for numerous devices, and I feel like I am going through the nine circles of hell as I backup, format and restore data again and again. If I wasn't clear on any part of this process please make a mention.

    1. Download the Forums for Android™ app!


  2. Szadzik

    Szadzik Extreme Android User

    Use GUI Format or something similar to format the card to FAT32 and you will have no more issues.
    Webnaut likes this.
  3. Russell Ng

    Russell Ng Android Expert

    Try using the phone to format the sdcard. And maybe test with another sdcard just to make sure its not the card problem in the first place.
  4. WAWood8

    WAWood8 Well-Known Member

    The phone isn't actually rated for 64GB cards -- only for 32GB at most. While some such cards DO work, they're not guaranteed to work.
  5. UserName872

    UserName872 Android Enthusiast

    This is actually incorrect... Right from Samsung's page, device is rated for 64GB cards.

    Samsung GALAXY S III
  6. Metfanant

    Metfanant Android Expert

    not all 64GB cards seem to function properly...ive seen reports that some cards work fine, others dont work at all...might want to do some reading over at the xda forums and see if you can find a consensus on what cards are working for people and just buy one of those
    Webnaut likes this.
  7. funkylogik

    funkylogik share the love peeps ;)

    All i can say is my 32gb sandisk ultra (class10) is buggin up, i have to reboot between each tune!!!!
    I dont know why one of the bigger forums arent doin a petition on this????
    And the two different qualitys of screen glass (mine gets thrown around and is flawless but mostly US users get deep scratches when they baby thier phone.
    These are the reasens ill never buy a sammy phone again (that and them changin the HDMI adaptor and bein SO slow with updates) :)
  8. vw driver

    vw driver Newbie

    This is what worked for me.
  9. dan330

    dan330 Extreme Android User

    This is what I had to.. A new kernel to support better large format is needed
  10. Stoney62

    Stoney62 Android Enthusiast

    That's what cus serv at best buy said too when I was replacing the 16 gb card that was no longer mounting on my new S3. Luckily, I was able to retrieve all my data from the old sd card.
  11. Webnaut

    Webnaut Lurker
    Thread Starter

    Thanks for the responses. I am using EaseUS Partition Manager to change the SD card to FAT32 with limited success.

    For the first try, I power the phone off and on as I exchange the SD card between the phone and the computer. The phone is off and the card is out, I format it from exfat to FAT32 with EaseUS, immediately eject/safely remove it, put it in the phone, and power the phone on. The phone recognizes it, I power it off, take it out, and store around 10 gigs of music on the card after placing it back into the computer. I safely remove it and put it back into the powered off phone, turn everything on, and it tells me that the SD card is damaged and that I should format it.

    For the second try, I dismount the SD card and store around 30 gigs of media on it before putting it back into the phone. The phone begins to chug and slow down, but eventually speeds up and lets me access the data on the SD card as ES File Explorer recognizes it and makes it appear. Curiously enough, there are these new folders in the SD card that weren't there before, prefixed with a Greek "mu" before "apps" or "games." Since they are empty, I delete them, notice that there are more files under "LOST.DIR," and watch a video. I dismount the card again and plug it into the computer whereupon it recognizes all but one of the sub-directories in my video folders, leaving me with two videos to watch, and my music and games are likewise disappeared. I put the card back into the phone and it chugs without getting any faster, and it shows nothing in the same directories, yet the space is somehow being used up according to "data" in the settings. I take out the card and format it.

    Third, I format the SD card with the Panasonic software, format it into FAT32 with EaseUS, and put it on the phone to transfer data through the USB cable. The computer eventually tells me that the device got disconnected as it transfers my music into the card and now nothing appears in ES File Explorer. I put the card back into the computer and format it.

    I am honestly grateful for any help that I receive here, but I have struggled with this SD card business all day to the point that I am almost nostalgic for my old LG Optimus' ability to accomplish the simple task of recognizing new SD card data. If anyone has a specific and consistently successful way for going about putting their data on a fancy Sandisk, 64 gig, class 10 SD card please feel free to comment.
  12. Szadzik

    Szadzik Extreme Android User

    Petition to do what? Petition for you to start searching before you post? This thread has nothing to do with 32GB cards. If you have a bad card or a bad phone, replace either and yo uwill be fine.

    Why do you take it out to do data transfer? Why not keep it i nthe phone and connect the phone itself? Maybe you card reader does not support SDXC and breaks it? I have seen it happen.
  13. Webnaut

    Webnaut Lurker
    Thread Starter

    I do in fact connect the phone to the computer to transfer data, but it still fails. This is what I am referring to when I say, "transfer data through the USB cable."

    But also, why should anything fail to support the card if the card is formatted in FAT32 from exfat? It is no longer an exfat card, but a 64 gig, FAT32, SD card which some claim works for them. Unfortunately, I am still forced to exclude myself from that list of happy customers.
  14. Russell Ng

    Russell Ng Android Expert

    Have you tested with another card? Had an issue with a 32GB Kingston once. Changed it to 16GB Sandisk and had no issue. Upgraded to a 32GB sandisk and also had no issue.

    Might be the card. Maybe for a 64GB, a certain speed is required for proper reading and if that speed don't match up, it doesn't work. It works on PC because its more robust.

    Try with another card first before ditching the phone.
  15. vw driver

    vw driver Newbie

    Google for free download of "guiformat.exe" , download it, re-format your card with it in your card reader, then try it. We know that works for us. Several people have told you that.
  16. bigslam123

    bigslam123 Newbie

    Try airdroid. With that app you can move things around wirelessly. less chance of a screwup.
    Webnaut likes this.
  17. Webnaut

    Webnaut Lurker
    Thread Starter

    Thanks guys, I'll just be employing the suggestion to use other tools to format the card aside from EaseUS. I'll also try out Airdroid, but hearsay tells me that there are some compatibility issues there as well.

    For anyone else who might be reading this and wondering, I can't say for certain if the S3 is cut out for use with exfat SD cards since my friend is having a dandy time with his perfectly-functioning Sandisk, exfat, 64 gig card and Galaxy S3 from Sprint. We both have the Sprint models and the same kind of SD card. There seems to be a point where success with this technology can be on an individual level, since my friend disregards my advice to format his card to FAT32 as I cite this topic to him.
  18. A full format should fix your problem as everyone else mentioned.
  19. Szadzik

    Szadzik Extreme Android User

    Add a chkdsk /r to that.

Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date

Share This Page