1. Are you ready for the Galaxy S20? Here is everything we know so far!

Windows 8 WiFi connection keeps going limited

Discussion in 'Computers' started by MacFett, Nov 12, 2014.

  1. MacFett

    MacFett Android Expert
    Thread Starter

    I have a lenovo x131e laptop and when on wireless the connection constantly goes limited. I can toggle airplane mode and it comes back fine for a time. I have tried every suggestion I have found online. I have it set to work over a metered connection.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. palmtree5

    palmtree5 Sunny Vacation Supporter!
    Moderator

    Try updating the drivers? The drivers provided by the computer manufacturer or Windows Update aren't always the newest updates available so you may have to search a bit for the latest ones for your wireless card
     
  3. MacFett

    MacFett Android Expert
    Thread Starter

    I have updated to the newest drivers I can find and the problem still persists. Some days I have no problem other days, like today, I lose connection every 5 minutes or so.
     
  4. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    I had a hell of a time with that exact problem on a Samsung laptop. It was driver related, but I can't remember exatly what. It wasn't the NIC ir WiFi directly, but something else related. I'll take a look when I get home to see if something triggers my memory, but I got the update a while ago.:(
     
  5. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    Could something on your network possibly be trying to use the same IP as your laptop? Try setting a static IP address for your wireless adapter and see if that helps.
     
    Crashdamage likes this.
  6. Crashdamage

    Crashdamage Android Expert

    Is this happening on a 2.4Ghz network or 5Ghz? If lunatic59's suggestion of a static IP doesn't help and you have both 2.4 & 5Ghz available, try splitting them by giving them different SSIDs. 2.4Ghz should be more reliable because it penetrates walls better and carries farther but 5Ghz is usually faster. If you use 5Ghz set it to use a channel well over 100. For either frequency set the router to use channels with a minimum of interference. I use WiFi Overview 360 to find the optimum setup. An excellent tool.

    https://play.google.com/store/apps/details?id=de.android.wifioverviewpro
     
    #6 Crashdamage, Jan 13, 2015
    Last edited: Jan 13, 2015
    lunatic59 likes this.
  7. MacFett

    MacFett Android Expert
    Thread Starter

    It is a 2.4ghz network. I have the most up to date drivers I can find. This happened on my last 3 networks. My current network is just a simple cellular modem with wifi from VZW. It happens at the library on all three of their wifi networks.

    With the cellular modem there is very little customization available, I've not found how to set a static IP. However it happens when my laptop is the only thing connected.

    Thanks for the ideas. Still trying to figure this out.
     
Loading...

Share This Page

Loading...