1. Are you ready for the Galaxy S20? Here is everything we know so far!

Windows XP USB MTP errors

Discussion in 'Android Devices' started by dhworph, Dec 23, 2011.

  1. dhworph

    dhworph Android Enthusiast
    Thread Starter

    Yet another windows xp usb driver issue. I have adb/fastboot working just fine on windows and ubuntu, but can't get mtp to work on either.

    Windows XP Pro
    Dell E1505

    Windows XP says:

    "Found New Hardware:
    SAMSUNG Mobile MTP Device"

    Device manager properties gives the following errors:

    "This device cannot start (code 10)"

    "No drivers are installed for this device."

    It alternates between the two above errors. With the "SAMSUNG Mobile MTP Device" sub selection (under "Portable Devices" in the Device Manager), having a yellow exclamation point icon that alternatingly appears and dissapears.

    Samsung Kies does not open either. It won't even open, was giving me some driver issue, but now it doesn't even do that... I can't rememebr which driver it was screaming about earlier though.

    I have tried several different drivers posted on various forums and the google usb driver given by the sdk. nothing seems to change. and now with a rooted device, nothing has changed either. I've tried airdroid and wifi file explorer, but just really don't like them. I would like a traditional explorer interface... mmuch easier to deal with + usb is faster than wifi.

    any ideas will be greatly appreciated...:thinking::mad::thinking:

    1. Download the Forums for Android™ app!


  2. syntrix

    syntrix Android Expert

  3. dhworph

    dhworph Android Enthusiast
    Thread Starter

    hm... I've never seen the mtp porting kit, I installed it just now, and no change.... still no mtp support on my XP...

    I'm having some trouble with my .net framework maybe that is related. I can't install the MS .net framework updates, I can't figure out what the issue is... maybe related... just gotta keep searching for a solution...
  4. syntrix

    syntrix Android Expert

    Yeah, maybe I didn't need that, just the samsung drivers that I found in the past. Crap, didn't need them on my home computer (win7) but my forced work laptop with XP, I should still have it in my download history, sorry.

    And the obvious, use the OEM usb cable, and use the best usb port available... it if it's a laptop, right on the laptop, not a docking station. if it's a desktop, just try a rear facing usb port.

    I'm sure you have tried all that already, no?
  5. dhworph

    dhworph Android Enthusiast
    Thread Starter

    porting kit didn't do anything... I am thinking I have some problems with my windows installation, luckily I found DroidExplorer Droid Explorer it works through USB like a charm. Also, got Astro File manager Bluetooth module app, and that is awesome too. So now I have several options for transferring files, still would love native usb mtp transfer, but as long as it all works, I'm good to go...
  6. dhworph

    dhworph Android Enthusiast
    Thread Starter

    ok, so I ended up doing a windows xp pro reinstall due to an old hard drive issue... but it was a blessing in many ways.

    Connect your phone to the computer via usb then run windows update. Windows update found a hardware update, which was the samsung usb mtp driver. I don't know why the one from the samsung site didn't work... but... anyhow... all my drivers seem to be working. I'd be curious to see what is faster though, MTP or droid explorer...

    I dont see the driver in my add/remove control panel dialog, it was called "SAMSUNG Electronics Co., Ltd. - Other hardware - SAMSUNG Mobile USB Composite Device" and "SAMSUNG Electronics Co., Ltd. - Other hardware - SAMSUNG Mobile MTP Device" on windows update. Two different drivers? I dunno...

    This was all the extra info windows update offered:
    "SAMSUNG Electronics Co., Ltd. - Other hardware - SAMSUNG Mobile USB Composite Device
    SAMSUNG Electronics Co., Ltd. Other hardware software update released in October, 2011"

    Now when I connect my GNex via usb it opens up the sdcard to read the files. DroidExplorer still works too.
  7. dhworph

    dhworph Android Enthusiast
    Thread Starter

    Same thing goes for installing ADB, PTP, or RNDIS (usb tether) drivers. connect the phone to the computer and then launch windows update. It will show the driver update under optional hardware updates. "Samsung ... driver... "

    Don't know why this advice wasn't anywhere else to be found on the net...
  8. maicou3834

    maicou3834 Lurker

    I was looking for some foruns and reading about.
    I don't know if all this files are necessaries, but With me it works perfectly well !!

    Search in Google (or 4Shared):




    Install Windows Media Player 11

    ...and it works!!!!

Galaxy Nexus Forum

The Galaxy Nexus release date was November 2011. Features and Specs include a 4.65" inch screen, 5MP camera, 1GB RAM, TI OMAP 4460 processor, and 1750mAh battery.

November 2011
Release Date

Share This Page