1. Download our Official Android App: Forums for Android!

Support Wireless connection since 2.2

Discussion in 'Android Devices' started by Misterre, Apr 28, 2011.

  1. Misterre

    Misterre Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    44
    Joined:
    Nov 19, 2010

    Nov 19, 2010
    44
    9
    16
    Since the upgrade my wireless does not automatically connect. I have to go in and turn it off and then on again.
    Any idea how to fix this?
     

    Advertisement

  2. Podivin

    Podivin Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    3,679
    Joined:
    Nov 29, 2009

    Nov 29, 2009
    3,679
    881
    213
    Jacksonville, Fl
    Check your WiFi sleep settings. My phone was doing that until I set WiFi to never sleep.
    We're on different phones so the menu could be different, but on mine it's menu > settings > WiFi Settings > menu > advanced > WiFi sleep policy.
     
  3. Misterre

    Misterre Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    44
    Joined:
    Nov 19, 2010

    Nov 19, 2010
    44
    9
    16
    Thanks
    I will see if that works
     
  4. Misterre

    Misterre Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    44
    Joined:
    Nov 19, 2010

    Nov 19, 2010
    44
    9
    16
    I changed the setting but have the same problem.
    Any other ideas from anyone?
     
  5. Darkseas

    Darkseas Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    212
    Joined:
    Jan 10, 2011

    Jan 10, 2011
    212
    25
    43
    Could this be a problem with your network/router or your Wifi settings on the phone?

    Are you limiting devices on your network with MAC addresses? Is your router assigning static IP addresses? In either case, if your network isn't seeing a sign-off from your phone, it may be holding the IP address or the MAC device as in use, so you can't sign on until you close it manually.

    In any case, it wouldn't hurt to check the settings on your router and the WiFi settings on your phone.
     
  6. DustinLuck

    DustinLuck Member
    Rank:
    None
    Points:
    16
    Posts:
    30
    Joined:
    May 3, 2011

    May 3, 2011
    30
    4
    16
    Application Developer
    I've had the same problem since upgrading to 2.2. I have wifi set up at work and home. When I go from one location to the other, my phone won't automatically connect unless I turn the wifi off and then on again.

    I've tried the sleep policy setting to never and made sure that it's not limiting by MAC addresses and its not assigning static IPs. This worked with 2.1 and I haven't changed my router settings at all, so it leads me to believe it's something to do with the phone.
     
  7. stef7

    stef7 Android Expert
    Rank:
    None
    Points:
    153
    Posts:
    1,066
    Joined:
    Dec 29, 2010

    Dec 29, 2010
    1,066
    136
    153
    Male
    Systems Engineer
    I'd delete the Wifi connection, and start again from the beginning.
     
  8. Misterre

    Misterre Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    44
    Joined:
    Nov 19, 2010

    Nov 19, 2010
    44
    9
    16
    It worked for me with 2.1
    Since upgrade it will not connect to WiFi unless I turn it off and then back on. This happens at both work and home.
    I changed the "never sleep" option and that made it so I had to turn off the wifi to get it to connect to the 3G network.
     
  9. DustinLuck

    DustinLuck Member
    Rank:
    None
    Points:
    16
    Posts:
    30
    Joined:
    May 3, 2011

    May 3, 2011
    30
    4
    16
    Application Developer
    I'll try this and report back with results.
     
  10. Darkseas

    Darkseas Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    212
    Joined:
    Jan 10, 2011

    Jan 10, 2011
    212
    25
    43
    Dustin and Misterre, it might help if you posted what brand/model router you're connecting to. Be interesting if both were the same. It's obviously not the phone and 2.2 alone, because most people aren't having the problem.

    It seems to me that when they sleep, your phones aren't disconnecting, at least not so the network knows about it, so when you wake up the phones and they try to log on, the network tells them they're already on. It's certainly possible that code changed somehow between 2.1 and 2.2 that made this happen.

    Once the phone sleeps, you might also try going into your router settings and seeing if the phone is still listed as active on the network. Mine is listed as inactive when it's sleeping and active when it wakes up. It stays active for a while after it goes to sleep.
     
  11. Misterre

    Misterre Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    44
    Joined:
    Nov 19, 2010

    Nov 19, 2010
    44
    9
    16
    This happens to me at work and at home so it is not specific to one router.
     
  12. bobbysweatpant

    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Apr 30, 2011

    Apr 30, 2011
    14
    0
    15
    This happens to me as well. I have the wifi option set to never sleep but sometimes when I'm in a part of the house with a weak signal (mostly overnight in the bedroom), the connection will drop until I turn the screen on again. It seems to only happen occasionally though.
     
  13. Darkseas

    Darkseas Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    212
    Joined:
    Jan 10, 2011

    Jan 10, 2011
    212
    25
    43
    And you're sure that home and work have different brands of routers?

    Try an experiment. Go to the part of your home where you have the strongest WiFi signal. Sleep the phone for 15 seconds. Wake it back up. Do you have to turn WiFi off and on again to restart it?

    If you don't, keep pushing out the time the phone sleeps to see what amount of sleep causes the problem. If it's 10 minutes, or 60 minutes, or longer, suspect a router issue.

    If it needs to be stopped and started again after 15 seconds, I'd bet it isn't a router issue, at least not one I've identified.
     
  14. DustinLuck

    DustinLuck Member
    Rank:
    None
    Points:
    16
    Posts:
    30
    Joined:
    May 3, 2011

    May 3, 2011
    30
    4
    16
    Application Developer
    I know it's been a while, but I'm still having the issue. The last thing I tried was deleting the wi-fi profiles and adding them back.

    Like Misterre, the problem is happening for me at work and home. The problem does not happen when the phone sleeps in the vicinity of the same wi-fi network, but rather when traveling between work and home.

    What I've seen happen is that when I get home from work, I notice that I don't have a wi-fi connection (no wi-fi icon in the notification area). If I pull up the wi-fi settings screen on my phone, I will see the messages "Connecting..." & "Disconnected" going back and forth. The work network will show up with a low signal icon (just the dot at the bottom), while my home network will show up as "Not in range". The same thing happens in reverse when going from home to work.
     
  15. stef7

    stef7 Android Expert
    Rank:
    None
    Points:
    153
    Posts:
    1,066
    Joined:
    Dec 29, 2010

    Dec 29, 2010
    1,066
    136
    153
    Male
    Systems Engineer
    Perhaps try WiFi Manager or Quick Settings download?
     
  16. DustinLuck

    DustinLuck Member
    Rank:
    None
    Points:
    16
    Posts:
    30
    Joined:
    May 3, 2011

    May 3, 2011
    30
    4
    16
    Application Developer
    I looked at both of those, but it seems like they are both manual workarounds (i.e., they offer a convenient way to switch wi-fi on/off). It would be nice if there were a way to switch off the wi-fi antenna when a remembered network is out of range and then turn it back on when the screen wakes up to search for a remembered network. I tried 'Auto WiFi Toggle', but that didn't seem to work.

    On another note, even though 'Quick Settings' didn't fit the bill by offering an automated solution, it did give me a way to access settings via the notifications area, which is something I've been looking for.
     
  17. stef7

    stef7 Android Expert
    Rank:
    None
    Points:
    153
    Posts:
    1,066
    Joined:
    Dec 29, 2010

    Dec 29, 2010
    1,066
    136
    153
    Male
    Systems Engineer
    DustinLuck. Compromises right? :)

    I had read somewhere, not sure where, there is a download that allows you to "script" stuff. Perhaps that can be part of the automated "solution" you seek.

    Sorry, I don't remember the name of the download.

    Good luck.
     
  18. DustinLuck

    DustinLuck Member
    Rank:
    None
    Points:
    16
    Posts:
    30
    Joined:
    May 3, 2011

    May 3, 2011
    30
    4
    16
    Application Developer
    Yes, life is full of compromises. It seems like I'll just have to deal with the problem.

    Thanks for the help everybody.
     
  19. bobbysweatpant

    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Apr 30, 2011

    Apr 30, 2011
    14
    0
    15
    There is an application named Tasker that will do what you are asking. Through GPS, it knows when i leave the house and turns the wifi signal off automatically. When I come home, it turns wifi back on again. You can set this up for as many locations as you wish and this handy little app can automate all sorts of other stuff too.
     

Share This Page

Loading...