1. Are you ready for the Galaxy S20? Here is everything we know so far!

Wireless glitch, both xtrROM and Kaos38

Discussion in 'Android Devices' started by APCharlie, Nov 2, 2010.

  1. APCharlie

    APCharlie Newbie
    Thread Starter

    I noticed a glitch with my Eris' wireless. On any normal network, it works fine, but when I try to use a network where they redirect to a site to register/login (like at my school or Panera's) phone is unable to use the signal.

    I always thought this was a glitch in xtrROM 4.6, but I recently flashed Kaosv38 and had the exact same issue.

    Has anyone found a workaround for this?

    1. Download the Forums for Android™ app!


  2. Praetorian

    Praetorian Well-Known Member

    I was never able to get these types of wireless networks working on my Eris even when I was on stock. I'm not sure its a glitch so much as just lacking the capability of handling it.
  3. T2noob

    T2noob Android Enthusiast

    My eris works fine with those kind of networks but i use plainjane so it might be a problem with froyo on the eris?
    because aren't those roms both froyo?
  4. MrWilliams

    MrWilliams Member

    T2, are you saying you can pull data from those networks without first, opening your browser and logging in? I'm currently running xtrROM 4.6 and I can't use these types of networks without logging in. I've also ran your rom, and had the same experience.
  5. doogald

    doogald Extreme Android User

    That's the way that many of those sites work - they will deny any network activity over their WiFi network until you authenticate and accept the terms of service using a browser.
  6. MrWilliams

    MrWilliams Member

    Correct, but I got the impression from T2 that he was able to access data without logging in. Maybe I was reading too much into his post...
  7. APCharlie

    APCharlie Newbie
    Thread Starter

    kaos is froyo but xtrrom is 2.1, and in both cases,i couldn't even get to the authentication page. when I turn off my 3g and only have wireless on, it just says there is no connection

    T2, how did you get your wireless to work?

    also mr williams, were you able to get to the authentication page? is your internet working?
  8. T2noob

    T2noob Android Enthusiast

    I thinl I may have misunderstood this topic. My skewl uses a wifi connection that needs to you to log in through browser after you connect. I just have to try to go to any page and i will get redirected to the schools authification page I log in then I get rredirected back to my original page. I use this metwork about every other day and have never had a problem with the d1or eris connecting. I figured that this problem might have been rom related because every rom/phone I have tried has no problem with this kind of authentification process. But I only used plainjane on the eris on my d1 I use a diff rom about everyday. Is this the problem you guys are having not being to use the internet after trying to authenticate through this process? If it isn't sorry to have given you false hopes.
    Edit: I use dolphin if it makes a difference. Now that I think about it once I tried logging to the network through the stock browser on plainjane and it wouldn't get redirected to the login page, so if this is the problem you guys are having maybe try dolphin browser.
  9. APCharlie

    APCharlie Newbie
    Thread Starter

    Hey T2, thanks so much.

    So I tried accessing the wireless at my school with the stock browser. I have always used Opera. Using stock, I was able to get to the authentication page, and sign in, and now wireless works (except not on Opera, other internet requiring programs work though, google talk, gmail) I guess it was a problem with the browser. Hope this helps people.

HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date

Share This Page