1. Are you ready for the Galaxy S20? Here is everything we know so far!

Wireless Tether in Infrastructure Mode

Discussion in 'Android Devices' started by Necrotoxin, Jul 10, 2011.

  1. Necrotoxin

    Necrotoxin Well-Known Member
    Thread Starter

    For those of you who don't know the difference between ad-hoc mode and infrastructure mode:

    Ad-hoc mode is commonly used for tethering, rather than being a hotspot access point it uses direct communication with another device (aka a computer) and basically "shares" it's internet connection with that device.

    Infrastructure mode is Like a wireless router that broadcasts, directly, the network connection. Certain devices, such as phones or psp's will only discover and connect to infrastructure wifi access points.

    If you want to tether (wirelessly) your xbox, ps3, psp or other phones to your 3g service You need to use infrastructure mode. This is something I've figured out that works on the prevail for getting it to tether in infrastructure.

    NOTE: You will need root access for this to work.

    First get the new wireless tether 3.1 <Latest Beta> from android-wifi-tether - Wireless Tether for Root Users - Google Project Hosting


    Then change the Device-profile to Samsung Galaxy Indulge


    And last change the Setup-Method to Softap for Samsung (master)


    You'll want to keep your phone awake during use or else you will lose the connection (I haven't figured out anyway to get past this) so you'll want to find a "stay awake" app such as "Stay Awake Widget"

    Happy Infrastructure mode tethering :D

    1. Download the Forums for Android™ app!


  2. wyelkins

    wyelkins Android Expert

    Thanks for that! My laptop connects. I never could get the ad-hoc to connect but this does. But...I am not getting internet. The laptop icon either says "no internet" or "limited"


    Sorry about that. It works! I am kind of in a hurry to get out the door this morning, but I had to try it so I did not take any time to troubleshoot. It might have been bumping against my wifi router or some previous trash in my laptop. Who knows? Anyway, I rebooted the laptop and turned off my wifi box and it works! Like you said, got to fix the timeout. I did see a message pop up and it may have been because of the timeout, but it said something like "what the hell?, your phone took back control....etc." I could not read the rest in time and do not have time right now to reproduce it. It may also have something to do with Juice Defender which I just reinstalled last night for the "hell" of it, but no problem to get rid of if that if it is the problem. I definitely need to donate to these guys.

    Thank you so much!
  3. Necrotoxin

    Necrotoxin Well-Known Member
    Thread Starter

    Just glad to have helped even one person.
  4. RRSpikes

    RRSpikes Newbie

  5. Necrotoxin

    Necrotoxin Well-Known Member
    Thread Starter

    Well I spent about an hour trying to find some way to tether my soon to be brother in law's psp so he could get an update and once I figured it out I figured others might benefit so I posted it. :D enjoy
  6. RRSpikes

    RRSpikes Newbie

    I'm now having a problem. When I stop tethering and then try to exit the app, my Prevail shuts off and reboots itself.

    This started after I connected both my PlayBook and GT 10.1.

    Anyone have any idea as to what's going on? :thinking:

    EDIT, It would appear that the battery temp was the culprit. After I ceased charging and let the phone cool down, all went back to normal.
  7. new optimus

    new optimus Android Expert

    I am very happy with this, great find. This allows me to connect to my XP laptop and I believe it will allow me to have more then one connected if needed, such as my wifes vista laptop and mine if we are traveling.
    I didnt lose connection when the screen turned off, though it may have slowed.
  8. Necrotoxin

    Necrotoxin Well-Known Member
    Thread Starter

    Sorry man I have no idea. I haven't had that issue so far. The only issue I've had was the connection dropping when the phone sleeps.
  9. wyelkins

    wyelkins Android Expert

    Yeah, it still has some quirks. But they are obviously working on it. We need to check for updates and post our problems on their site. I noticed a few things that I assume had to do with it.

    After I tethered this morning I exited the app and left, I made a call and received a call. The next time I looked at my phone it was "dead" or so I thought. It finally came back but the screen would not respond. it did the occasional beep. I finally took out the battery. As stated in my earlier post, it may be because of Juice Defender which I will disable before the next time I use the Tether.

    Somewhere in the back of my mind, I am a little concerned that if we go hog wild using this to connect a bunch of stuff to our phones that Boost will eventually have to do something about it that we will not like. Especially, if we use it for a lot of Netflix, etc. Not trying to be a wet blanket but just sayin...
  10. wetbiker7

    wetbiker7 Extreme Android User

    I had the same problem . Fixed it with the Stay Awake Widget . :)
    wyelkins likes this.
  11. ashesawit

    ashesawit Newbie

    I am having problems connecting to my mac. I can "connect" to the wifi signal from my prevail, but I can't load a webpage on my mac. Airport says it is connected to AndroidTether, however it also indicates there is a problem, which it can't diagnose. On top of that, the phone is restarting when I disconnect. Any ideas?
  12. wetbiker7

    wetbiker7 Extreme Android User

    Are you running both the beta & and the wireless tether for root users together ? Ya gotta run them both . Least I did and it's working great . :D

    Nice job & thx Necrotoxin !!
  13. wetbiker7

    wetbiker7 Extreme Android User

  14. RRSpikes

    RRSpikes Newbie

    du bist willkommen
  15. Amazon Jim

    Amazon Jim Lurker

    I'm running PdaNet on my computers and it is working very well. I might have to try out this as it allows for others to connect to me as well. hmmm.....

    ShabbyMod .9 too.
  16. kolosus

    kolosus Android Expert

    I've tried the beta1 and 2. On both I can connect in Ad-hoc mode... but when I try to connect in infrastructure mode all hell breaks loose. I cant connect anymore. My computer tries to connect (can see the network) but cannot connect. Plus to top it off, once I try infrastructure mode it and it cannot connect I try and go back to ad-hoc mode but I cannot connect anymore. :(

    Infrastructure mode would've been nice. But maybe I should wait for the non-beta version.
  17. ashesawit

    ashesawit Newbie

    I tried using this version but still couldn't connect to my mac. I also tried running the previous beta version simultaneously with "wifi tether for root users", and while my mac recognizes the connection and my phone says they are connected, no data is being transferred. Is there a setting necessary to change on my mac to make this work?
  18. wetbiker7

    wetbiker7 Extreme Android User

    I wish I could help ya .... I'm not that familiar with a Mac . I'm Running Windows 7 .
  19. wetbiker7

    wetbiker7 Extreme Android User

    I was having a conflict somewhere because the beta version kept crashing . I said what the heck and did a complete wipe , reinstalled just this app (wifi_tether_v3_1-beta2.apk - android-wifi-tether - WiFi Tether for Root Users 3.1-beta2 *** BETA *** - Wireless Tether for Root Users - Google Project Hosting ) as my WiFi and NO MORE PROBLEMS ! As matter of fact , I noticed that my web pages were loading faster on my PC so I did a speed test and I got 5 readings above 0.85 Mbps with the highest being 0.96 Mbps . This was with the stock proxy settings too . :D Come on Sprint , we know the speed is there sooooo why don't ya let us have it ??????? :p
  20. Flightkid_23

    Flightkid_23 Lurker

    I was having the same Limited Connection message on my PC running XP. I think I got this thing figured out now. In WiFi Tether Beta 2 under settings, Go to Change Channel and change it to Channel 6. Thats what I did and now I'm able to connect my Prevail to my PC (running XP) and my Nintendo Wii via Infrastructure Mode. You must do this after the steps listed by Necrotoxin This is my first post please be kind. Oh yeah I uninstalled Easy Tether Pro from my PC and Prevail before I did this.
  21. kevincott

    kevincott Android Expert

    Newb here.

    Don't think I will use tethering often, but will be great to have in a pinch.

    Thanks for the thread.
  22. Kamel

    Kamel Well-Known Member

    I did want to thank you immensely for your help here, I'm so glad I was able to get infrastructure mode working.

    I am still trying to find a way to get it encrypted, however. When enabling encryption in infrastructure mode (WPA2), the access point doesn't show. When I did get it to show, as soon as I tried to join and it disappeared. I tried using ad-hoc, but I can't get it working at all with this version.

    Any ideas? I'm not at all comfortable surfing on an open wireless access point :(
  23. new optimus

    new optimus Android Expert

    you can use mac addy filtering with this, saves finding a way to make encryption work.
    if the mac addy is not on file the connection gets rejected so no one else can use it.

Samsung Galaxy Prevail Forum

The Samsung Galaxy Prevail release date was April 2011. Features and Specs include a 3.2" inch screen, 2MP camera, GB RAM, MSM7627-3 processor, and 1500mAh battery.

April 2011
Release Date

Share This Page