1. Check out our companion app, Forums for Android! Download from Google Play

Support wonky USB

Discussion in 'Android Devices' started by bubbajones4u, Dec 20, 2012.

  1. bubbajones4u

    bubbajones4u Member
    Thread Starter
    25

    Dec 20, 2012
    6
    0
    25
    Male
    healthcare
    This Planet
    I usually download photos from my Galaxy SII once a week to my PC. This has never been a problem, but now it is a problem.

    I go to Settings>Wireless and Networks>USB Utilities and it shows the 'Connect storage to PC'.

    I click the button, and the Connect USB pop-up comes up.

    I plug the cable in, and it beeps and kicks me back to the 'Connect storage to PC' menu?

    I have tried different cables, and still the problem.

    When I try a different computer, I can get it to connect, but after copying a few files, it disconnects, and then I try to connect again on that computer, I get the 'Connect storage to PC' loop.

    Any idea what the problem could be?
     

    Advertisement

  2. Digital Controller

    Digital Controller The Real Bass Creator
    953

    Sep 5, 2012
    12,647
    3,553
    953
    Male
    Civil Engineer
    Cincinnati, Ohio
    First off welcome to the forums :)

    I have moved this thread into the Galaxy S2 AT&T forums to get you some better assistance.

    Also, have you tried pulling the battery and restarting the device. This can sometimes reboot your system and might fix this issue.
     
    bubbajones4u likes this.
  3. Ikenstein

    Ikenstein Well-Known Member
    63

    Jan 30, 2012
    187
    49
    63
    Oklahoma, USA
    Check the USB port on your phone. If it is dirty, that can cause issues.

    Alternatively, have you tried using Kies Air? You can transfer files that way as well.
     
    bubbajones4u likes this.
  4. bubbajones4u

    bubbajones4u Member
    Thread Starter
    25

    Dec 20, 2012
    6
    0
    25
    Male
    healthcare
    This Planet
    Thanx for the replies.

    I have cleaned the USB port with alchohol and canned air - no change.

    I tried Air Kies and Airdroid, and it dosen't work. The browsers can't find the phone, even though the phone can find and use the network. I changes the settings in Windows according to the documentation for the apps, and still it doesn't work.

    I backed up the important stuff to Google drive.

    Can I upgrade my OS with out the USB connectivitiy?
     

Share This Page

Loading...