1. Are you ready for the Galaxy S20? Here is everything we know so far!

Won't connect to ssid

Discussion in 'Android Devices' started by liderbug, May 24, 2018.

  1. liderbug

    liderbug Lurker
    Thread Starter

    The distance [including walls, concrete] to between my router and greenhouse causes me to see the word "buffering" way to much. So in the greenhouse I have a RasPi-3B and created a router. Using my laptop (fedora 27) I can connect to ssid GH1 works fine. Howerer my XT1254 says "connecting, getting IP, no internet, saving, connecting, getting IP, no internet, saving..." and about 3 time of this my phone backs off and connects to House1. Any thoughts? Thanks in advance
     


  2. svim

    svim Extreme Android User

    So do you have one main broadband connection for the house and a second broadband connection for the greenhouse (two separate, distinct home LANs), or is it matter where you have a single broadband connection feeding the two different routers, one in the house and the other in the greenhouse?

    If the former, does your greenhouse router have the option to dial back the signal strength? Try setting it back a bit as it sounds like since you have two different, competing WiFi networks that are conflicting with each other because of their proximity with each other. With two WiFi networks so close that you're intentionally creating an overlap between them, there's apparently a 'noise floor' issue to contend with. Even though you have both SSID networks set up in your phone, apparently it just keeps trying and trying to hold on to the one even when you've entered the coverage range of the other.
    https://documentation.meraki.com/MR...ise_Ratio_(SNR)__and_wireless_signal_strength

    If the latter, try using one SSID for both WiFi networks, a requirement being the home router should be the single gateway with the greenhouse router having all routing functions disabled so it's just acting as a switch. Same SSID and password, but be sure to use separate channels for each router (i.e. if a 2.4GHz network, using channel 1 for the home router and channel 11 for the greenhouse.) If set up correctly your phone should just switch back and forth between the two more or less seamlessly as you walk back and forth.
     
  3. liderbug

    liderbug Lurker
    Thread Starter

    Wasn't sure how much detail to go into - so: cloud -> router (wifi Home1)@192.168.0.1, cat 5 to greenhouse (RasPi). Set up GH1, RasPi router, wlan0 @ 192.168.1.1 Prime reason to connect to ESP8266 chips controlling cooling fan speed (but that's a side story - and that's working). So around the house, using phone, connect to Home1 - no problem. When out in the greenhouse where app Wifi Analyzer says GH1 at about -35dB. So, >Settings, >WiFi, avail 1of2 (really 4, neighbors) is GH1, tap, connect, getting IP, no inernet, connect, getting IP, no internet... falls back to Home1. So what I like is to connect to GH1, browse, pandora, etc connected to GH1, 5' away, no buffering buffering buffering. But it won't connect. Hope I made this understandable.
    Tks
     
  4. svim

    svim Extreme Android User

    You're apparently focusing on signal strength in your greenhouse but the underlying, basic networking issues need to be resolved first. With two different SSIDs, you've also implemented two different LANs, with the resulting problem being the greenhouse LAN isn't able to provide viable online access.
    Try setting up one SSID, where there's a single LAN (wired and wireless) that extends throughout your home and your greenhouse. Set up your Raspberry Pi to work as a switch, not a router. With your home <<>> greenhouse Cat5 cable plugged only into LAN and not WAN ports, you want your home router to be the single gateway, doing all routing functionality. With a single SSID and password, and your home router set to use a specific channel and your Pi set to use a different, specific channel, this should result in a one WiFi network that extends between your home and greenhouse. With your greenhouse Pi acting only as a switch, it's just an extension of your home LAN and by only being a wireless access point and not a competing wireless router, your phone no longer has to switch itself between two distinct WiFi networks.
     

Motorola Droid Maxx 2 Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...