1. Check out our companion app, Forums for Android! Download from Google Play

Support Won't Recognize any SIM Card

Discussion in 'Android Devices' started by RogueJd, Mar 12, 2012.

  1. RogueJd

    RogueJd New Member
    Thread Starter

    Mar 12, 2012
    Hey all. First time posting here.

    I have a Samsung Galaxy S II 4G LTE from NTT Docomo (SC-03D) in Japan. I just purchased the phone about 6 weeks ago, and so far, I love it.

    I travel a lot to the US from Japan, and just before my last trip, I had NTT Docomo unlock the phone so it can accept other companies' SIM cards.

    It worked fine for a few days with no issues (with my Japanese SIM Card while in Japan). I took the SIM card out of the phone (may have still been powered on) just before I got on the plane to the US. It costs even if the phone connects to a tower over here, so I didn't want to take any chances.

    When I got to the states, I turned the phone on - no SIM inserted. As expected, there were two icons in the top-right corner (1 of a SIM card, one of those circles with a slash through it) - presumably the icons that simply indicate there's no SIM.

    So I popped in a SIM card from an old AT&T prepaid phone. - Icon didn't even blink. I watched carefully to see if anything was blinking, etc.. - Nothing. Checked NTT SIM Card - Nothing.

    For both SIM cards - Powered off, took out battery, powered on. Left it sit w/ no battery, repeat. Plugged it in, repeat. USB connected it, repeat. Restored device to factory - nothing.

    Same icon. Not budging - not allowing me to connect.

    Phone is not rooted, and SIM cards have been verified to work in other phones.

    Is this a software deal? I can't imagine this is hardware related. I'm no slacker when it comes to electronics components - Hell! I have a Master's degree in Information Technology and a Focus in Computer Forensics (That includes mobile phones...)

    So, now I'm stuck without my "good" phone in the States. Can't take it anywhere because it's NTT Docomo. It's a slightly different model than US ones - SC-03D.

    I'd consider rooting it if that would be a solution. The only thing is, if it is somehow hardware related, I don't want to void my warranty. ...I know roots can be reversed - but I'm not quite ready to commit to that.

    Again - I really, really doubt it's hardware related. I think firmware for the SIM reader, or something to that effect got messed up.

    Please realize that this may be an advanced problem that requires advanced answers. I'm hoping someone out there has some first-hand knowledge. I'm also hoping to avoid posts like "turn it off n on agin" or obvious recommendations to take it back to the dealer.

    I've tried searching the forums - and the few hits I've seen had only the above solutions...

    Thanks all!

    - J. "Jon" Rogue


  2. fendee1

    fendee1 Member

    Jan 12, 2012
    Maybe try another carrier Sim ask a coworker or family use a different carrier, tmobile,sprint or just find a kiosk in a mall and ask a person there. Just a few suggestions. Hope it works out for you. We have great technology but cant use it. Any ideas anyone.
  3. fendee1

    fendee1 Member

    Jan 12, 2012
    Listen to engadget podcast 129 at the 49 minute mark they discus how he bought from Korea a Samsung lte and the firmware doesn't work here . You might try a rom with that firmware for the sim. But could be the reason. When you go back n forth just switch roms.

Share This Page