1. Are you ready for the Galaxy S20? Here is everything we know so far!

Work Intranet Page not connecting

Discussion in 'Android Devices' started by willdogs, Jan 5, 2010.

  1. willdogs

    willdogs Android Enthusiast
    Thread Starter

    Using the broswer, I am trying to access my companies intranet homepage.

    When I try to access the link, it usually presents a pop up login box but using the Eris it dows not.

    I get a page "You are not authorized to view this page" web page...

    Anyone else have this issue? Is this a limitation of Android? I've tried messing with all the settings and still nothing. No way to Log Into the page.

    I've even tried using Dolphin Browser, same thing.

    I believe we use Microsoft Sharepoint and other microsoft back end products
     


  2. Bxrider11

    Bxrider11 Well-Known Member

    I used to work for a large company that had an intranet system. When I had my blackberry, I experienced the same problem. I had to eventually have the IT department do something to give clearance to use my phone browser for the intranet. I don't know if it is the same situation with your company. Hopefully this may help.
     
  3. MisterMcGoo

    MisterMcGoo Well-Known Member

    Since your phone is probably not part of the domain, I don't think you'll be able to see any sites on your corporate Intranet. There could be some other roadblocks too like if your company uses PKI and has softcerts installed on all clients, you're phone will also not work. I'm also assuming you're connected to your corporate network via WiFi, otherwise you'd need some type of VPN connectivity (either via client or SSL/TLS, if your corporate IT security personnel know anything at all). :D
     
  4. SamMax

    SamMax Android Expert

    I tried to access my wifes companies non Intra-net website that requires a username and password and I couldn't get in there either.
     
  5. willdogs

    willdogs Android Enthusiast
    Thread Starter

    Our intranet site is designed to be access from anywhere, no need to be part of the domain.

    It works from any PC using any browser. It also works using the browser on my Ipod Touch.

    I'm guessing it has something to do with either android or the browsers cant handle the security.
     
  6. Wolfedude88

    Wolfedude88 Android Expert

    hmm... That is strange, I would have thought it was something with security but I am not quite sure now.
     
  7. Timber

    Timber Lurker

    Anyone ever find out about this? I have the same problem with my works internal sites. I never get a login prompt, just the "you're not authorized" page. Works with all browsers on Linux, just not Android.

    Oh, the sites I'm having problems with are corporate sites using sharepoint. A local CUPS installation prompts me for login credentials just fine.
     
  8. cmatthaios

    cmatthaios Member

    You might need to install a certificate to grant access. I know if I use Dolphin Browser I can accept the certificate, which takes me to a login prompt and then access the intranet
     
  9. Caddyman

    Caddyman Android Expert

    can you change your user agent in your setting in the stock browser. i think you can in dolphin browser. the site may be picking you us as android browser and blocking you. you can (Sometimes) change your browser identification on some browser to get around this.
     
  10. Podivin

    Podivin Android Expert

    In the settings for the Internet app, make sure that 'Block pop-up windows' is not checked. And it might also help to check 'open in background'. I'm assuming here that the login window is a separate window, which may not be the case.
     
  11. Timber

    Timber Lurker

    I tried all of that, none of it makes a difference. The CUPS page I access does pop up a login dialog that works fine. It seems to have something to do with the MS Sharepoint web pages.

    Both Chrome and Firefox, on my Linux box, not on the domain, pop up a dialog box, and let me in with the correct credentials. The page I get on Android is the same one I get if I hit cancel on the login dialog.

    Standard browser and Dolphin behave the same way.
     

HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date
0
Reviews
Loading...

Share This Page

Loading...